Jump to content
tkvebbs

Ryzen 7 5800X, 6800 XT, and low FPS.

Recommended Posts

I recently fulfilled a childhood promise to myself: to buy a proper gaming PC. Specs:

 

ASUS ROG Strix X570-F Gaming

AMD Ryzen 7 5800X

Corsair Vengeance RGB Pro DDR4 3600 MHz 16GB

MSI Radeon RX 6800 XT Gaming X Trio

Proper cooling etc.

 

I expected it would run ArmA 3 maxed out at 60+ fps without breaking a sweat, but it does not. I have to admit it is a bit disappointing, although I am also happy to have better performance than ever. After reading numerous threads on optimization, and playing around with the settings quite a bit, I have come to understand the CPU is the problem and not the GPU. In singleplayer a lot can be achieved by adjusting the viewing distance, but when I host a server to play with friends this does not help. Indeed, I can set graphics to maximum and to minimum without much impacting FPS -- especially on more demanding scenarios, such as Dynamic Recon Ops on Tanoa (Runs in the tens or twenties). The Apex campaign was a lot better even while hosting, although for some reason it hogged an increasing amount of VRAM. By the fifth mission it had reached 14GB. Odd.

 

Three questions:

 

Can I do anything to make ArmA better utilize my CPU?

 

Can I do something smarter to host a multiplayer game on some cores and play ArmA on others? 

 

Can you recommend an easy-to-use and resonably priced ArmA 3 server provider, than can be configured with mods etc.?

 

Cheers!

Share this post


Link to post
Share on other sites

Hello tkvebbs, Welcome to BI forums!

2 hours ago, tkvebbs said:

Can I do anything to make ArmA better utilize my CPU?

  • Keep view distance relatively low as you know, 2000m and under is best suitable
  • Is the game on an SSD? Because that will help smooth out loading and better optimize performance, less strain on the cpu.
2 hours ago, tkvebbs said:

Can I do something smarter to host a multiplayer game on some cores and play ArmA on others? 

Cant really say as the game auto detects what your running and is rather limited i think, best ask the guys on the computers thread

as they could better tell you.

https://forums.bohemia.net/forums/topic/187603-will-my-pc-run-arma3-what-cpugpu-to-get-what-settings-what-system-specifications/

2 hours ago, tkvebbs said:

Can you recommend an easy-to-use and resonably priced ArmA 3 server provider, than can be configured with mods etc.?

Streamline Servers!

https://streamline-servers.com/gameservers/arma3.php

You can also compare the GSP's seen here https://comparegamehosting.com/game/best-arma-3-server-hosting

keep in mind that prices may be cheaper with some GSP's but when the server isn't working correctly then you'll want

a GSP that has great support, just saying you get what you pay for.

 

I reccomend Streamline as i;ve used them for many years, among many others and Streamline was easiest to use,

and the support staff is great!

You have your choice between 10 and 100 slots.

If you do decide to go with them and have no idea where to start, setup, send me a pm, i'd be happy to

help you configure the server.

 

Hope that helps!

Ps. in the future search before you post, and post any general questions in this section:

https://forums.bohemia.net/forums/forum/167-arma-3-questions-answers/

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Sorry for the late reply, but I am very grateful for your help 😃

Arma is running on M.2, so there should be no problem there. I'll be sure to check out the thread you referred to, and maybe ask there about my processor. Lastly; very helpful tips on the server-front. Headed over there right now!

 

  • Like 1

Share this post


Link to post
Share on other sites

I play Arma 3 multiplayer on an AMD 3600, 5700XT, 32 Gb 3200 ram, and the frame rate is not much faster than my ancient i5 2500K @ 4.5Ghz in Arma. The game is smoother using Ryzen and I experience less frame drops but the average frame rate is almost identical. 

 

It's the engine mate. Your system is fine. Most people get 25-40 frames in the heat of battle, no matter what your specs. There are exceptions, but I guess those are silicon lottery winners. I too have just ordered the 5800X and will be testing Arma 3 extensively across different multiplayer missions. Coop being a favourite. I'm not expecting night and day differences over the 3600 or even the i5 2500K. In other games I am. I'm expecting an atomic performance gain.

 

edit: I forgot to mention my Laptop specs which again yielded a similar performance. I think it was an Intel 6300HQ, with 16 GB 2400 ram and an GTX 965M 4GB. 

  • Thanks 1

Share this post


Link to post
Share on other sites

im also getting low fps no matter what settings i change. all from low to very high dont change my fps at all. just the same lame 25-30 fps makeing SP campaign a pain to do. i know its sp mission etc. but also happens in multiplayer and been an issue since beta for me. despite hardware upgrade from back then to now. just the same old fps cap at 30 -.- no change with Zero mods or alot still 30 fps cap.. Yes Vsync is off at all times..

I7-9700k (stock)

RTX 2080 (stock)
3800Mhz 16gb ram
500gb SSD (only arma 3 and mods are installed there atm)
Win 10
ASUS ROG STRIX Z370-H GAMING (bios updated to support my current cpu)

  • Thanks 1

Share this post


Link to post
Share on other sites
On 2/2/2021 at 11:52 AM, Zipet said:

im also getting low fps no matter what settings i change. all from low to very high dont change my fps at all. just the same lame 25-30 fps makeing SP campaign a pain to do. i know its sp mission etc. but also happens in multiplayer and been an issue since beta for me. despite hardware upgrade from back then to now. just the same old fps cap at 30 -.- no change with Zero mods or alot still 30 fps cap.. Yes Vsync is off at all times..

I7-9700k (stock)

RTX 2080 (stock)
3800Mhz 16gb ram
500gb SSD (only arma 3 and mods are installed there atm)
Win 10
ASUS ROG STRIX Z370-H GAMING (bios updated to support my current cpu)

What resolution?

You should really consider overclocking that CPU. ARMA3 is CPU (and memory) bound, so every 100MHz helps.

I have my 8700k at 5GHz on all cores and get decent framerates (about twice yours) - at 3440x1440 - on 'very high' preset.

30 FPS - you must have your view distance at insane distances. Use the presets - High, Very High - and dont touch view distances/object etc.

I would experiment with individual settings on Ultra (rather than using the full preset).

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

a little more input to this. i also have a 6800xt with a 5900x and ever since i replaced my old gtx 970 with the new 6800xt my YAAB benchmarks have dropped 10fps on average.

with stock cpu clocks and ram speed at 3600mhz cl16-19-19-39 with the 6800xt i was getting 70-73fps (i am using CMA). the same setting with the gtx 970 was getting 80-84fps average.

 

with the gtx 970 and cpu clocked to 4.6ghz all core this bumped up to 88-91fps average. the same setting with the 6800xt was still getting 70-73fps.

 

with the 6800xt and cpu clocked to 4.5ghz (made some adjustments since last test) and ram overclocked to 3600mhz cl14-14-14-28 there was still 0 gain.

 

overclocking my cpu and ram with the 6800xt in it yielded 0 improvement in arma where as it made a MASSIVE improvement with the gtx 970. it seems theres something going on with the rx 6000's and arma and i have yet to figure out what since their release is causing this issue because i should be pushing over 90fps average in that benchmark now with the cpu and ram overclock i have setup now but im still stuck at 70-73. so far there is only about a 2fps difference (margin of error) between 1080p and 2160p in that benchmark with this setup with standard settings

  • Thanks 1

Share this post


Link to post
Share on other sites
On 2/11/2021 at 8:29 PM, gokitty1199 said:

a little more input to this. i also have a 6800xt with a 5900x and ever since i replaced my old gtx 970 with the new 6800xt my YAAB benchmarks have dropped 10fps on average.

with stock cpu clocks and ram speed at 3600mhz cl16-19-19-39 with the 6800xt i was getting 70-73fps (i am using CMA). the same setting with the gtx 970 was getting 80-84fps average.

 

with the gtx 970 and cpu clocked to 4.6ghz all core this bumped up to 88-91fps average. the same setting with the 6800xt was still getting 70-73fps.

  

with the 6800xt and cpu clocked to 4.5ghz (made some adjustments since last test) and ram overclocked to 3600mhz cl14-14-14-28 there was still 0 gain.

 

overclocking my cpu and ram with the 6800xt in it yielded 0 improvement in arma where as it made a MASSIVE improvement with the gtx 970. it seems theres something going on with the rx 6000's and arma and i have yet to figure out what since their release is causing this issue because i should be pushing over 90fps average in that benchmark now with the cpu and ram overclock i have setup now but im still stuck at 70-73. so far there is only about a 2fps difference (margin of error) between 1080p and 2160p in that benchmark with this setup with standard settings

It's long been known that Nvidia performed better than AMD in Arma3 (plently of articles online about it).

I replaced my old RX480 with a GTX 1080 because of this (at least in part).

 

To be honest, I only noticed the performance increase in YAAB, not actually in-game.

I'd be very surprised they'll be willing (or able) to do anything about this.

 

 

Share this post


Link to post
Share on other sites
On 2/11/2021 at 8:29 PM, gokitty1199 said:

a little more input to this. i also have a 6800xt with a 5900x and ever since i replaced my old gtx 970 with the new 6800xt my YAAB benchmarks have dropped 10fps on average.

with stock cpu clocks and ram speed at 3600mhz cl16-19-19-39 with the 6800xt i was getting 70-73fps (i am using CMA). the same setting with the gtx 970 was getting 80-84fps average.

 

with the gtx 970 and cpu clocked to 4.6ghz all core this bumped up to 88-91fps average. the same setting with the 6800xt was still getting 70-73fps.

 

with the 6800xt and cpu clocked to 4.5ghz (made some adjustments since last test) and ram overclocked to 3600mhz cl14-14-14-28 there was still 0 gain.

 

overclocking my cpu and ram with the 6800xt in it yielded 0 improvement in arma where as it made a MASSIVE improvement with the gtx 970. it seems theres something going on with the rx 6000's and arma and i have yet to figure out what since their release is causing this issue because i should be pushing over 90fps average in that benchmark now with the cpu and ram overclock i have setup now but im still stuck at 70-73. so far there is only about a 2fps difference (margin of error) between 1080p and 2160p in that benchmark with this setup with standard settings

I wager there are huge numbers of players that would love to be 'stuck' at 70-73fps.

I remember when it was the concensus that 30fps was adequate to play this series.

Share this post


Link to post
Share on other sites

Noticed a good avg. 20 fps boost going from 1070 to a Rx6800xt 319 merc. Now when i display gpu usage and cpu usage ingame the gpu is rarely over 15-20% usage on everything ultra. My cpu however sees a 70-80-90% load on 1 core. Rest of the cores are at 20-30%. Cpu is a i5 9600k @ 5200ghz.
 

Look at your resource usage ingame. Also the amount of mods may degrade your performance.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×