Jump to content
fingolfin

Mag proxies on handguns

Recommended Posts

Hey there,

 

I have a quick question regarding the magazine proxy system regarding handguns. Everything works fine until the weapon is holstered on a vest, then the magazine does not show. I have looked at the vanilla pistols and saw that they do not use mag proxies, same for the ones in RHS. So, now my question: Did I forget something or is the system not designed for handguns and mag proxies generally do not show up on holstered weapons?

Share this post


Link to post
Share on other sites

There's a fix for this (along with a new showHandgunMagProxy = 1; config parameter added to vests) on the Arma 3 dev Branch (rev 146887)

Handgun behaviour has been to hide all attachment proxy objects to avoid suppressors, lights etc. clipping out of holsters. And until now, the magazine was treated likewise

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks, in that case I’ll keep the current setup.

Share this post


Link to post
Share on other sites
On 11/6/2020 at 12:01 PM, fingolfin said:

Thanks, in that case I’ll keep the current setup.

Do keep in mind though that the fix is defined as part of the vest config and as such your current setup may still not work as intended on all vests as presumably some vests will still have 'showHandgunMagProxy' set with a 0 value.

Share this post


Link to post
Share on other sites
5 hours ago, Jackal326 said:

Do keep in mind though that the fix is defined as part of the vest config and as such your current setup may still not work as intended on all vests as presumably some vests will still have 'showHandgunMagProxy' set with a 0 value.

 

Thanks, that is good to know. I'll hope that most gear mods will update their mods if it is just a config fix.

Share this post


Link to post
Share on other sites

its nice to see this fix but why that value isnt 1 by default? because that would been much easier without any mod changes

Share this post


Link to post
Share on other sites
34 minutes ago, roberthammer said:

its nice to see this fix but why that value isnt 1 by default?


Backward compatibility? Addon makers are the holly grail of this game for devs, but sometimes also a devil 😉 There are some abandoned mods the fix would create a bug (visual glitches) in their vests. Maybe this create more work for current projects but less players barking about 'this is arma's thing' and ' "they" again have broken things while fixing them'  😉 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×