Jump to content
Babura

Unit play and capture

Recommended Posts

just copy n paste the complete file path.sqf in a spoiler pls...

Share this post


Link to post
Share on other sites
17 minutes ago, sarogahtyp said:

just copy n paste the complete file path.sqf in a spoiler pls...

I cant when i paste it to spoiler i cant load site.

Share this post


Link to post
Share on other sites

sry, but I can't see any reason for this beviour... should just work...

you could try a sleep 0.5 after first unit play command. maybe it's a timing problem, but I doubt that this helps.

 

do you have any output in ur .rpt file?

Share this post


Link to post
Share on other sites

im new to editor and scripting so i dont understand what .rpt file means anyway.Other heli with all different cordinates follows path of first heli in every cm,fuck.

Share this post


Link to post
Share on other sites

I always put the paths in their own separate sqf file, and call each one separately. 

Share this post


Link to post
Share on other sites
4 minutes ago, stburr91 said:

I always put the paths in their own separate sqf file, and call each one separately. 

I tryed but it didnt worked(i think i did something wrong)can you send me example or some kind of template.

Share this post


Link to post
Share on other sites
26 minutes ago, Babura said:

im new to editor and scripting so i dont understand what .rpt file means

google helps!

https://community.bistudio.com/wiki/Crash_Files#Arma_3

 

19 minutes ago, stburr91 said:

I always put the paths in their own separate sqf file, and call each one separately. 

What? I thought you are running what u showed...

 

Share this post


Link to post
Share on other sites
Just now, Babura said:

I tryed but it didnt worked(i think i did something wrong)can you send me example or some kind of template.

 

You just need two separate path files, one file for unit1, and one file for unit2.

Example

path1.sqf    

path2.sqf

 

Your init.sqf should look like this.

 

Path1 = compile preprocessFile "path1.sqf";

Path2 = compile preprocessFile "path2.sqf";

 

 

Call the paths like this.

 

rec = [] spawn Path1; rec = [] spawn Path2;

 

 

Share this post


Link to post
Share on other sites
21 minutes ago, stburr91 said:

I always put the paths in their own separate sqf file, and call each one separately. 

shouldn't make a difference

Share this post


Link to post
Share on other sites
4 minutes ago, sarogahtyp said:

shouldn't make a difference

 

I don't know if it would make a difference or not, it's just how I've done it, so I know it works.

 

 

OP

 

Can you upload your mission file?

Share this post


Link to post
Share on other sites

i tryed with separate path files but still same problem,it follows first path.

Do you need mission file with everything in folder or just mission.sqm?

Share this post


Link to post
Share on other sites
3 minutes ago, Babura said:

i tryed with separate path files but still same problem,it follows first path.

Do you need mission file with everything in folder or just mission.sqm?

 

Upload the mission folder (with everything in it). 

Share this post


Link to post
Share on other sites
3 minutes ago, Babura said:

Yes

 

I won't be able to open it then.

 

Give me a little time, and I'll create an example mission for you. 

Share this post


Link to post
Share on other sites
54 minutes ago, Babura said:

Yes

 

Let me know when you get the mission file, so I can then remove the link. 

Share this post


Link to post
Share on other sites

Donwloaded it it worked in your map,but when i changed map heli and paths again same thing,i think its something with map.I have no idea.Thanks for help anyways.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×