Jump to content

Mission not Loading on Dedicated, Tested perfectly on Local Host

Recommended Posts


Here is the RPT:

Here is the config:



// server.cfg
// comments are written with "//" in front of them.


hostname            = "DRAGONS TEST SERVER";    // The name of the server that will be displayed in the public server list
password          = "saaaa";                       // Password to join the server
passwordAdmin       = "aaaa";                        // Password to become server admin. When you're connected to the server, open the chat and type '#login password'
//reportingIP       = "arma3pc.master.gamespy.com";            // not used anymore in Arma 3
logFile             = "server.log";
verifySignatures    = 0;    // Prevent players with unknown mods from joining the server (best kept at 2 if you want to reduce the number of hackers)
requiredSecureId    = 2;    // was used to define type of secureID

// WELCOME MESSAGE ("message of the day")
// It can be several lines, separated by comma
// Empty messages "" will not be displayed at all but are only for increasing the interval

motd[] =
    "Welcome to DRAGONON's ArmA 3 Server",
    "TS3 Server:     teamspeak.somewhere.com",
    "Web:            www.example.com"
motdInterval        = 7;        // Time interval (in seconds) between each message

maxPlayers          = 50;        // Maximum amount of players. Anybody who joins the server is considered a player, regardless of their role or team.
kickDuplicate       = 1;         // Each player normally has its own unique ID. If set to 1, players with an ID that is identical to another player will be kicked
//requiredBuild     = 12345;     // Require clients joining to have at least this build version of game, preventing obsolete clients to connect

roleTimeOut = 777777777;
votingTimeOut = 7777777777;
briefingTimeOut = 7777777777;
debriefingTimeOut = 77777777;

voteMissionPlayers  = 1;         // Tells the server how many people must connect before displaying the mission selection screen, if you have not already selected a mission in this config
voteThreshold       = 0.33;      // Percentage (0.00 to 1.00) of players needed to vote for something, for example an admin or a new mission, to become effective. Set to 9999 to prevent people from voting random players as admins.

class Missions
    class Mission1

disableVoN = 1;                  // If set to 1, voice chat will be disabled
vonCodecQuality = 10;            // Supports range 1-30; 8kHz is 0-10 (narrowband), 16kHz is 11-20 (wideband), 32kHz is 21-30 (ultrawideband); higher = better sound quality
persistent = 1;                  // If set to 1, missions will continue to run after all players have disconnected
timeStampFormat = "short";       // Set the timestamp format used on each line of the server RPT log file. Possible values are "none" (default), "short", "full".
BattlEye = 1;                    // If set to 0, BattlEye Anti-Cheat will be disabled on the server (not recommended)

allowedLoadFileExtensions[] =       {"hpp","sqs","sqf","fsm","cpp","paa","txt","xml","inc","ext","sqm","ods","fxy","lip","csv","kb","bik","bikb","html","htm","biedi"}; // only allow files with those extensions to be loaded via loadFile command (since Arma 3 build 1.19.124216) 
allowedPreprocessFileExtensions[] = {"hpp","sqs","sqf","fsm","cpp","paa","txt","xml","inc","ext","sqm","ods","fxy","lip","csv","kb","bik","bikb","html","htm","biedi"}; // only allow files with those extensions to be loaded via preprocessFile/preprocessFileLineNumber commands (since Arma 3 build 1.19.124323)
allowedHTMLLoadExtensions[] =       {"htm","html","xml","txt"}; // only allow files with those extensions to be loaded via HTMLLoad command (since Arma 3 build 1.27.126715)

onUserConnected = "";            // command to run when a player connects
onUserDisconnected = "";         // command to run when a player disconnects
doubleIdDetected = "";           // command to run if a player has the same ID as another player in the server

onUnsignedData = "kick (_this select 0)";    // command to run if a player has unsigned data
onHackedData =  "kick (_this select 0)";     // command to run if a player has data with invalid signatures
onDifferentData = "";                        // command to run if a player has modified data


I am using Host Havoc to host my server, thus cannot access the bandwidth settings

I have worked with their support to address other concerns but I seem to be stuck on this one. 
I can see the server requiring the mods that I need for this mission, I can join the server and see the slotting screen for the mission. I can see the mission through #missions. As I try to load the mission, I get booted back to the slotting screen of the same mission. 
Here is the mission's pbo https://gofile.io/d/uqaben 

I have updated RHSUSAF and RHSAFRF, no changes in the RPT. I have updated all the mods probably 20 times now, I've deleted and redownloaded the steamapps folder required multiple times as well. 

Tested from a local host with the same mods with 15~ people, ran fine for the 3 ish hours we ran the op. Any help or suggestions would be appreciated. 

Share this post

Link to post
Share on other sites

rpt lines 1255 to 1295 shows error in code


difference between local host and dedi server are

1) use of code such as

if(HasInterface) ...... and not assuming possibility of  IsServer



and then of course the localised setup compared to the dedi environment


  • Like 1

Share this post

Link to post
Share on other sites

Oh wow, your'e absolutely correct, I don't know how I missed that. Have you seen that error before / provide some context so I can fix it? 

> I'm unsure if this suggests server side or mission side 

extra info

Share this post

Link to post
Share on other sites

Have i seen scripting errors in rpt files ? Yes.

Have i seen that error? No

Where is it, ? Don't know do a mass search for a string in the mission file. _OldCompat.

Addon scripts are failing because i presume you are calling them incorrectly, syntax errors, missing ";" at end of lines etc



0 spawn compile preprocessFileLin

Looking at the rpt am assuming somewhere you are trying to add an  Eachframe missioneventHandler

  • Like 1

Share this post

Link to post
Share on other sites

Ok, I did some searching around and I've narrowed it down to a problem in my mission.sqm file. I've opened it with visual studio code and am seeing (potentially) where the error lies. 

For some ACE_ items that are being called up I get the error

The "ACE_" namespace is reserved. Please enable ACE commands in the settings.sqf

Similar thing happens for some CBA_  expressions. 

I find it odd that it's not flagging every one of my ACE_ items / expressions, any pointers from here?  I've made a settings.sqf file and have imported settings that were used while local hosting

I'm blind, I need to fix ""File [userconfig\cba_settings.sqf] not found or empty.""


Share this post

Link to post
Share on other sites

Update; I could use help on how to work around the userconfig/cba_settings.sqf requirement to be in the root arma directory as I am renting this through Host Havoc. I have the settings I would like already exported to a text file and just need to clear this error>

I have tried enabling and disabling -filepatching, doesn't work. I've put my settings into a settings.sqf for the mission .pbo, and as a cba_settings.sqf for the pbo, no luck. 

Am I missing something here?

Share this post

Link to post
Share on other sites

So in your root Arma3 root server install, where all the arma3**.exe's are, you should have a folder called userconfig

In that folder should be a file called cba_settings.sqf.


so path would be arma3\userconfig\cba_settings.sqf


This is the content in ours..



Your home local server will have this file, just copy it over to the server

Share this post

Link to post
Share on other sites

I don't have access to the root arma3 install location as I am renting this server through Host Havoc

Share this post

Link to post
Share on other sites


Mission file I was using as a test had issue that caused a lot of headache. 

cba_settings_hasSettingsFile = 1;   < adding this to your description.ext and added a file called cba_settings.sqf with your exported settings should resolve any issues. 

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now