Jump to content

Recommended Posts

Using Altis Life v5.0.0

 

I have tried to set the texture to global (so everyone sees it). So far the player can see it on their screen but everyone else on the server cannot see it, They see the base uniform used.

Any suggestions would be appreciated.

 

Thank you.

 

//Set jail uniform
hint "Your gear has been placed in the evidence locker!";
old_gear = getUnitLoadout player;
removeUniform player;
removeHeadgear player;
removeVest player;
removeGoggles player;
removeBackpack player;
removeallWeapons player;
//removeallAssignedItems player;
player forceAddUniform "U_IG_Guerilla2_1";
player setObjectTextureGlobal [0,"textures\prisonuniform.paa"];

 

 

Share this post


Link to post
Share on other sites
1 hour ago, bumyplum said:

Try use;

[player,[0,"textures\prisonuniform.paa"]] remoteExec ["setObjectTexture",0,true];

ok ill try ty.

Share this post


Link to post
Share on other sites
2 hours ago, bumyplum said:

Try use;

[player,[0,"textures\prisonuniform.paa"]] remoteExec ["setObjectTexture",0,true];

Testing it now - It didn't work. The texture is of the base uniform.

Share this post


Link to post
Share on other sites
4 minutes ago, Steel_Dragon said:

Testing it now - It didn't work. The texture is of the base uniform.

Are you sure "textures\prisonuniform.paa" is correct?
try changing it to a default arma texture and see if it works

  • Thanks 1

Share this post


Link to post
Share on other sites
17 minutes ago, bumyplum said:

Are you sure "textures\prisonuniform.paa" is correct?
try changing it to a default arma texture and see if it works

yes it is correct, it was showing local using - player setObjectTextureGlobal [0,"textures\prisonuniform.paa"];

Share this post


Link to post
Share on other sites

This is the code im using did i miss something?

//Begin jail uniform
hint "Your gear has been placed in the evidence locker!";
old_gear = getUnitLoadout player;
removeUniform player;
removeHeadgear player;
removeVest player;
removeGoggles player;
removeBackpack player;
removeallWeapons player;
//removeallAssignedItems player;
player forceAddUniform "U_IG_Guerilla2_1";
[player,[0,"textures\prisonuniform.paa"]] remoteExec ["setObjectTexture",0,true];

Share this post


Link to post
Share on other sites

The command setObjectTexture is not remoteExec-able, that is what setObjectTextureGlobal is for.

Your problem is just a timing issue between the uniform being changed on a client and the setObjectTextureGlobal changing the uniforms image.

Use your original script but just put a small sleep(0.02) between forceUniform and setObjectTexture.

Remember this means your code shown must be suspend-able( spawn or execVM 'ed ).

 

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, Larrow said:

The command setObjectTexture is not remoteExec-able, that is what setObjectTextureGlobal is for.

Your problem is just a timing issue between the uniform being changed on a client and the setObjectTextureGlobal changing the uniforms image.

Use your original script but just put a small sleep(0.02) between forceUniform and setObjectTexture.

Remember this means your code shown must be suspend-able( spawn or execVM 'ed ).

 

Thanks ill try it.

Share this post


Link to post
Share on other sites
6 hours ago, Larrow said:

The command setObjectTexture is not remoteExec-able, that is what setObjectTextureGlobal is for.

Your problem is just a timing issue between the uniform being changed on a client and the setObjectTextureGlobal changing the uniforms image.

Use your original script but just put a small sleep(0.02) between forceUniform and setObjectTexture.

Remember this means your code shown must be suspend-able( spawn or execVM 'ed ).

 

O.k. so i tried your suggestion. Its still the same. I can see it (the prison texture) as the player but the other people in the server cannot - they see the base uniform texture. I tried to take the uniform off and put it back on to reset it and it turned into the base uniform textures local side. This is the code i tried - 

 

//Begin jail uniform
hint "Your gear has been placed in the evidence locker!";
old_gear = getUnitLoadout player;
removeUniform player;
removeHeadgear player;
removeVest player;
removeGoggles player;
removeBackpack player;
removeallWeapons player;
//removeallAssignedItems player;
player forceAddUniform "U_IG_Guerilla2_1";

sleep (0.02);

player setObjectTextureGlobal [0,"textures\prisonuniform.paa"];

Share this post


Link to post
Share on other sites

Oh do i have to set up a spawn / execVM for the Civ? i assume it would be in the fn_initCiv.sqf?

I am not really sure how to go about that.

 

I am trying

 

In the mpmissions\Altis_Life.Altis\init.sqf

//Jailme
[] execVM "core\civilian\fn_jailMe.sqf";

 

would it be something like that?

Share this post


Link to post
Share on other sites

Trying in the player skins under Civ - 

 

            //Jail Texture set
            if (uniform player isEqualTo "U_IG_Guerilla2_1" && life_is_arrested) then {
                player setObjectTextureGlobal [0, "textures\prisonuniform.paa"];
            };

Share this post


Link to post
Share on other sites
22 hours ago, Steel_Dragon said:

Trying in the player skins under Civ - 

 

            //Jail Texture set
            if (uniform player isEqualTo "U_IG_Guerilla2_1" && life_is_arrested) then {
                player setObjectTextureGlobal [0, "textures\prisonuniform.paa"];
            };

Did not work textures did not show either side.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×