Jump to content

Recommended Posts

4 hours ago, redarmy said:

Also is there an issue with the revive? im not always revived by my AI nor do they always revive each other. In its current state i cant reliably use the revive

What revive system do you use? Ideally the revive should only be used with the "Add Revivability" cheat.

 

4 hours ago, redarmy said:

Iv disabled most things like cheats/zues/medic etc.

None of those affect your FPS.
 

4 hours ago, redarmy said:

and im using a "scheduled' envoirnment as per your tool tip says better performance which leaves me wondering,in what situations could this mod negatively affect my FPS?

That's only used by the tasking system (e.g. giving waypoints)
Well I don't say "scheduled has better performance". It basically has no performance impact, at the cost of being less accurate if you have a heavily scripted scenario and/or your FPS is low. The game queues running scripts in the scheduled environment, and only executes 3 ms of a script every frame and moves on to the next script in the next frame, so under heavy load it may take a lot of time for the game to circle back to a script.

TL,DR, the script becomes less "responsive". e.g. your medic plays the healing animation but you don't see any healing effect, or the healing takes a lot of time to finish, because my mod only heals during the healing animation, but due to this scheduler behavior it may never see the animation.

I recommend unscheduled instead. Under normal usage it doesn't affect your FPS noticeably.

As for what affects FPS:
1. Having too many "Super pilots" active
2. Having too many tasked squad units when unscheduled tasking is selected.

There's not really anything else in the mod that affects the FPS. The AI themselves hurt your FPS several times more! 😉

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Leopard20 said:

What revive system do you use? Ideally the revive should only be used with the "Add Revivability" cheat.

 

None of those affect your FPS.
 

That's only used by the tasking system (e.g. giving waypoints)
Well I don't say "scheduled has better performance". It basically has no performance impact, at the cost of being less accurate if you have a heavily scripted scenario and/or your FPS is low. The game queues running scripts in the scheduled environment, and only executes 3 ms of a script every frame and moves on to the next script in the next frame, so under heavy load it may take a lot of time for the game to circle back to a script.

TL,DR, the script becomes less "responsive". e.g. your medic plays the healing animation but you don't see any healing effect, or the healing takes a lot of time to finish, because my mod only heals during the healing animation, but due to this scheduler behavior it may never see the animation.

I recommend unscheduled instead. Under normal usage it doesn't affect your FPS noticeably.

As for what affects FPS:
1. Having too many "Super pilots" active
2. Having too many tasked squad units when unscheduled tasking is selected.

There's not really anything else in the mod that affects the FPS. The AI themselves hurt your FPS several times more! 😉

Thanks for the thorough explanation.

 

Regarding revive,i turned the cheat revivability on,but wasnt getting revived by team mates reliably,they werent in combat they just let me bleed out. i was using scheduled setting perhaps it had an effect.

 

Honestly i think i just took some more time getting used to it,i didnt DL it for a long time because i thought it was way more than i "needed" but i dont think i could play Arma3 without this now. The defense setups you can do at the click of the mouse is really nice too. Im trying to play as vanilla as possible for FPS sakewhich is why i  asked about performance issues but nice to know it should be smooth. Has been so far, thanks again for the work done on this mod.

Share this post


Link to post
Share on other sites

Hi Leopard.

 

when using high command menu (just after opening it) im getting an error:

 

"recruit submenu 4 pushback. undefined variable in expression"

 

Things still seem to work ok just wonder what it means. its really odd,its only showing this error when nearby a group of particular AI while in base. Trying to troubleshoot. After deleting some AI in the area where this happens(no particular ones,just a set amount) i dont get the error anymore. is there some issue with too many AI in the scene? only had about 15 AI split into two groups who are hanging about at base that i want ready to recruit.

Share this post


Link to post
Share on other sites
5 hours ago, redarmy said:

Hi Leopard.

 

when using high command menu (just after opening it) im getting an error:

 

"recruit submenu 4 pushback. undefined variable in expression"

 

Things still seem to work ok just wonder what it means. its really odd,its only showing this error when nearby a group of particular AI while in base. Trying to troubleshoot. After deleting some AI in the area where this happens(no particular ones,just a set amount) i dont get the error anymore. is there some issue with too many AI in the scene? only had about 15 AI split into two groups who are hanging about at base that i want ready to recruit.

There shouldn't be any error. Which variable does it say is undefined? I looked at the code and even tested to be sure but didn't get any errors

Share this post


Link to post
Share on other sites
3 hours ago, Leopard20 said:

There shouldn't be any error. Which variable does it say is undefined? I looked at the code and even tested to be sure but didn't get any errors

AIO_Recruitsubmenu5

So its not just "submenu4"..itcould be "submenu3" or "5" or whatever the array is.But,above is the variable when i booted up to test now. The error message is very short and appears when activating the high command menu when within 100 or so meters of friendlies(more than 10units or so/if i delete a few and access HC from your mod menu i dont get the error,but no "specific" units,just a certain number. i cant think of anything else causing this except one known oddity...if i ask a unit to join my group...he becomes "unit 1"and i am "unit 2 " in the command bar though im still the leader...possibly relevant.

 

I am running mods but not many,i assume this may have something conflicting with JEBUS respawn but this is very hard to identify. The thing is that the units im near dont have JEBUS script attached to them. Other mods are just unit mods but units in question are vanilla

Share this post


Link to post
Share on other sites
2 hours ago, redarmy said:

AIO_Recruitsubmenu5

So its not just "submenu4"..itcould be "submenu3" or "5" or whatever the array is.But,above is the variable when i booted up to test now. The error message is very short and appears when activating the high command menu when within 100 or so meters of friendlies(more than 10units or so/if i delete a few and access HC from your mod menu i dont get the error,but no "specific" units,just a certain number. i cant think of anything else causing this except one known oddity...if i ask a unit to join my group...he becomes "unit 1"and i am "unit 2 " in the command bar though im still the leader...possibly relevant.

 

I am running mods but not many,i assume this may have something conflicting with JEBUS respawn but this is very hard to identify. The thing is that the units im near dont have JEBUS script attached to them. Other mods are just unit mods but units in question are vanilla

I updated the mod and made some tweaks. Let me know if it still happens.

Share this post


Link to post
Share on other sites
25 minutes ago, Leopard20 said:

I updated the mod and made some tweaks. Let me know if it still happens.

Thanks for quick response.

 

Tested.

 

Issue is still there,however now the player needs to be much closer in proximity to have the error occur. Also frames are really bad when initialising upon loading scenario in editor

 

EDIT

 

Cant reproduce frame issue,maybe was something on my end,disregard

Share this post


Link to post
Share on other sites
2 hours ago, redarmy said:

Thanks for quick response.

 

Tested.

 

Issue is still there,however now the player needs to be much closer in proximity to have the error occur. Also frames are really bad when initialising upon loading scenario in editor

 

EDIT

 

Cant reproduce frame issue,maybe was something on my end,disregard

I made another update. Please test it again.
If this doesn't fix it I'm gonna need the full mission to be able to debug the problem because I can't reproduce it at all.

Share this post


Link to post
Share on other sites
36 minutes ago, Leopard20 said:

I made another update. Test it again.
If this doesn't fix it I'm gonna need the full mission to be able to debug this because I can't reproduce this at all.

issue still there.

 

you really cant reproduce it in editor? All i did was load Arma3 with your mod and cba,placed my charater on Altis,placed two NATO weapon teams down,brought up High command menu from your mod and the error pops up.

 

Quite strange indeed. Just to be clear,everything still works,its simply popping up errors and im keen to understand why

 

EDIT: I l unsubscribe from the mod just to triple check and resubscribe

 

 

EDIT EDIT: OK THAT FIXED IT!  

 

Had to resubscribe. No more errors.

 

THANK YOU MATE

Share this post


Link to post
Share on other sites
26 minutes ago, redarmy said:

issue still there.

 

you really cant reproduce it in editor? All i did was load Arma3 with your mod and cba,placed my charater on Altis,placed two NATO weapon teams down,brought up High command menu from your mod and the error pops up.

 

Quite strange indeed. Just to be clear,everything still works,its simply popping up errors and im keen to understand why

 

EDIT: I l unsubscribe from the mod just to triple check and resubscribe

 

 

EDIT EDIT: OK THAT FIXED IT!  

 

Had to resubscribe. No more errors.

 

THANK YOU MATE

Ah so it was a classic Steam update issue.
BTW you can just right click on the mod and select repair.
Anyway, glad it's sorted out.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 2/20/2022 at 2:58 AM, Leopard20 said:

This time, I'm trying to make the mod as independent of SQF as I can. So I take all the information I need from the game and cache them in disk/memory (those cached to disk are "one time constant caches", such as terrain info, etc.), and use them in my own "engine", which runs on its own thread(s). So Arma will simply be in charge of "displaying" the results (AI movement, animation, shooting, etc.), while the heavy calculations (path finding, finding cover, group coordination, and other "AI brain" stuff) are being made elsewhere.
With this approach I won't have to make any compromises anymore, since Arma is running on its own thread and its performance will not be impacted as much as before.

 

Each little bit I learn about arma moddikng/scripting, I lean closer towards this concept--It seems like this really would the way to go for most mods that are intensitve.  It makes me wonder what the potential for some sort of CBA esque unified framework could acheive  ie not an interfacing thing, but like a general engine that multiple mods could use to get access to non arma threads and do heavy lifting, with info transfer back and forth with the engine.  Very excited to see how this develops, and love your other mods--thanks for all the great work you do,

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi again Leopard,

 

Is it possible for you to count units for the High command "after" mission start?

 

Say for example i place a tank with call sign "Tank 1" but he has a 0% probability of spawn,he still shows up in the options to add to high command,regardless of his presence on map or not.

Share this post


Link to post
Share on other sites
1 hour ago, redarmy said:

Hi again Leopard,

 

Is it possible for you to count units for the High command "after" mission start?

 

Say for example i place a tank with call sign "Tank 1" but he has a 0% probability of spawn,he still shows up in the options to add to high command,regardless of his presence on map or not.

I don't know what could be the problem because I simply grab the list of all groups using the allGroups command.
Maybe when probability is 0 it still creates the group but it's empty?
Anyway, I'll look into.

Share this post


Link to post
Share on other sites
48 minutes ago, Leopard20 said:

I don't know what could be the problem because I simply grab the list of all groups using the allGroups command.
Maybe when probability is 0 it still creates the group but it's empty?
Anyway, I'll look into.

in High command menu of your mod,beside NATO smbols,units that are not actually present in mission upon start have some odd info on their distance

 

"1e+010m"

 

So i dont know. i tried setting the group to "delete when empty" in Eden but no luck there.

Share this post


Link to post
Share on other sites
1 hour ago, redarmy said:

in High command menu of your mod,beside NATO smbols,units that are not actually present in mission upon start have some odd info on their distance

 

"1e+010m"

 

So i dont know. i tried setting the group to "delete when empty" in Eden but no luck there.

Yeah I checked and the group is empty.

Share this post


Link to post
Share on other sites

Hi,

I was reading the comments about “scheduled” vs “unscheduled” above and it’s potential effect on FPS/healing. Can someone explain what these two modes are and where to change those settings? I could not find anything in the mod’s manual. 
 

Thank you

rainbow

Share this post


Link to post
Share on other sites
1 hour ago, rainbow47 said:

Hi,

I was reading the comments about “scheduled” vs “unscheduled” above and it’s potential effect on FPS/healing. Can someone explain what these two modes are and where to change those settings? I could not find anything in the mod’s manual. 
 

Thank you

rainbow

You can change the mod's settings in Options -> Addon Options -> Server -> Addon: All-In-One Command Menu, the line you're interested in is called "Tasking Environment".

As for the difference between the Scheduled and Unscheduled environment, according to the description: Scheduled has less performance impact but doesn't well work at low FPS, because it's tied to how many FPS you have. Unscheduled doesn't take the FPS into account but depending on your hardware and mission design, you may feel every change Leopard's mod does.

Share this post


Link to post
Share on other sites

Thanks for the explanation. I will look into it. 
 

On a different not, is the Super AI still in development or has the project been stopped? I remember Leopard was mentioning some limitations of the Arma engine which make the development of Super AI impossible. Not sure what the latest update is or where to find information on the project. 

Share this post


Link to post
Share on other sites
On 2/20/2022 at 7:58 AM, Leopard20 said:

I have posted some development updates, but they're irrelevant now, since I have scrapped most of the old design decisions due to issues during testing (I have already revised many stuff during development)
Currently trying a new approach. If this fails to meet my requirements again then I'll have to cancel this project, because there's no better way left to do this anymore.
But so far everything is good.

Simply put, the biggest obstacle during the development has been performance issues. I used to make accuracy sacrifices in favor of performance and hope for the best, but those accuracy sacrifices have always caused problems here and there.

The primary performance bottleneck is SQF, Arma's scripting engine. It's the only way of "communicating" with the game, and it only runs on the main game thread, which already has so much to do. Previously everything in the mod was being done in SQF.

This time, I'm trying to make the mod as independent of SQF as I can. So I take all the information I need from the game and cache them in disk/memory (those cached to disk are "one time constant caches", such as terrain info, etc.), and use them in my own "engine", which runs on its own thread(s). So Arma will simply be in charge of "displaying" the results (AI movement, animation, shooting, etc.), while the heavy calculations (path finding, finding cover, group coordination, and other "AI brain" stuff) are being made elsewhere.
With this approach I won't have to make any compromises anymore, since Arma is running on its own thread and its performance will not be impacted as much as before.

Of course, this approach has its own challenges. So we have to wait and see how it'll turn out. But I have thought out almost everything, and I'm 90% certain that this time it'll be a success. And so far it has been going according to plan.

@rainbow47

Share this post


Link to post
Share on other sites
On 5/13/2022 at 12:23 PM, rainbow47 said:

Hi,

I was reading the comments about “scheduled” vs “unscheduled” above and it’s potential effect on FPS/healing. Can someone explain what these two modes are and where to change those settings? I could not find anything in the mod’s manual. 
 

Thank you

rainbow

https://community.bistudio.com/wiki/Scheduler
 

22 hours ago, rainbow47 said:

is the Super AI still in development or has the project been stopped?

It's not. If it was I would announce it. No need to ask every time.

 

22 hours ago, rainbow47 said:

mentioning some limitations of the Arma engine

They're not really engine limitations. The engine is capable of the features I want. They're just "locked" (not accessible via scripting commands)
Two of the most important ones for me are:
1. No command for manually controlling AI aiming. This limits my AI movement a lot. I have a workaround for it but I'd rather use the native engine aiming, because that would be faster and better looking.
2. No command for controlling vehicles (acceleration and steering). There's only setDriveOnPath which is not sufficient.

They don't prevent me from completing the mod, but I might remove some stuff if those features are not added.

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, Leopard20 said:


It's not. If it was I would announce it. No need to ask every time.

 

No worries. Sounds your mode is mostly finished. Happy to do some beta testing if this would help you.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×