Jump to content
Keelah

Fox's Arma Server Tool Extended Rewrite (FASTER)

Recommended Posts

22 hours ago, Tankbuster said:

I have a problem that may or may not be related to FASTER.

The application won't run properly. When I double click it, the logo appears then nothing. It's not in task manager.

Any ideas, anyone?

Running as a Administrator ?

Share this post


Link to post
Share on other sites
On 5/20/2020 at 10:01 AM, Rockapes said:

Have you check event log to see if it is producing the .net error? If so and error is occuring then delete the "FASTER" folder as mentioned above and issue hopefully will be rectified

Ah, well done. That seems to have fixed it. Thanks.

 

On 5/20/2020 at 9:01 PM, Arghbra said:

Running as a Administrator ?

I was, but the appdata dir needed deleting. Now it's back up and running/. 🙂

Share this post


Link to post
Share on other sites

I have been getting the following error in the steam log every time i try updating the workshop mods:

c:\buildslave\steam_rel_client_win32\build\src\clientdll\depotreconstruct.cpp (1362) : Assertion Failed: m_nOutstandingWorkItems == 0

 

anyone know how to fix this or what the cause of it is?

Share this post


Link to post
Share on other sites

I think this is just related to SteamCMD.
It's an error I get as well sometimes. Haven't had troubles though.
Are you having issues downloading content ?

Share this post


Link to post
Share on other sites
Posted (edited)

@Keelah im having a little trouble with the HC. I can launch is and get him to connect but it doesn't enter the HC slot and i cannot move him in it as admin.

EDIT: Issue fixed, i haddn't named the HC entity correctly.

Edited by SHIFTY_TFD

Share this post


Link to post
Share on other sites

Cannot say I have ever seen a HC enter an admin role, works fine here ( when I have used it as not supported by all missions )

 

Share this post


Link to post
Share on other sites

I get this error when updating mods.

 

Enter the current code from your Steam Guard Mobile Authenticator app
Two-factor code:Logged in OK
Waiting for user info...OK
Downloading item 463939057 ...

ERROR! Download item 463939057 failed (Failure).Redirecting stderr to 'x:\Program Files (x86)\STEAMCMD\logs\stderr.txt'
[  0%] Checking for available updates...

 

That file is then blank. Also the API is not under a steam name or anything, it's just a random name.

I'm using a different steam account that doesn't own Arma 3, on a different computer, does that matter? Pretty sure I have all my ports right.

Share this post


Link to post
Share on other sites
Quote

5. Can't download a certain mod but other mods works fine !
If your steamCMD error is a Timeout downloading item : SteamCMD have a weird way of handling downloads. Mods can only be downloaded by packs of 1Gb and must be started again. Just keep trying a few times.
If your STeamCMD error is just (Failure) : This issue is sometimes caused by cache files not deleted by steamCMD. You have to delete them manually. THese files named state_107410_107410_somenumbers.patch  are located in YourSteamCMDFolder\steamapps\workshop\downloads\
If none of those apply, try putting your own SteamAPI key. You can get it though the following link : https://steamcommunity.com/dev/apikey

 

From the discord.

  • Like 1

Share this post


Link to post
Share on other sites

I couldn't find any information on this somewhere, is there a way to disable Battleye loading?

 

Trying to run a private server with a friend but having issues due to BE - I tried editing the config file to have Battleye = 0; but it resets itself to a value of 1 every time I launch the server. I also tried adding it to the Additional Parameters section in the Performance + Scripting tab in the server profile aswell, this just makes it complain about a duplicate line and refuses to launch instead.

 

With TADST as an example you could simply just untick a Battleye option in the client, which was incredibly handy for this situation - however FASTER doesn't have the option and I don't believe there are any launch parameters to disable BE with either

Share this post


Link to post
Share on other sites

If you are using FASTER then it is on first page below admin password. check make sure BattleEye is not selected ( ticked ). Otherwise check you launchers ( client ) under the BATTLEYE option and make sure Clients don't have it enabled

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Just a bit of news for you all !
There haven't been any update for a while for a good reason :
I'm not dead (not that I know of, at least) but I'm actively working on a whole new profile system.

The current system was a clusterfuck of code and functions doing too many things. It was all working with sticks and duct-tape.

The new system is a lot more simple and feature a realtime save system to avoid losing your settings if something bad happens. Also a few more design novelties and improvements.
You can go check the progress on Discord where I'm more active (link in first post).

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Sneak peak of the new profile !

Spoiler


    SERVER.CFG tab

unknown.png



    Profile and Mods tab
unknown.png


This is still a work in progress but it should look super cool and a lot easier to use

 


For more updates and previews, head to the Discord server.

  • Thanks 1

Share this post


Link to post
Share on other sites

It's far from finished but the UI changed a lot and should be *roll drums* FASTER

  • Like 1

Share this post


Link to post
Share on other sites
On 4/18/2020 at 10:09 PM, Mack. said:

deleted the AppData\Local\Temp\.net\FASTER directory and ran FASTER again. It rebuild all the DLL's and is now working again. Ive saved a copy of the folder and the DLL'S to be sure.

I'm having to do this after every Windows restart. 😞

Share this post


Link to post
Share on other sites
14 hours ago, Tankbuster said:

I'm having to do this after every Windows restart. 😞

 

Same here, I have made a short cut to the directory to speed things up. Now I think about its easy enough to write bat file to automate the process.

  • Like 1

Share this post


Link to post
Share on other sites

My least favorite bug !
 

From the Discord FAQ channel :

3. FASTER does not start anymore / keeps crashing ! Check in your logs if you are having issues about missing DLLs. The message should look like the following : System.IO.FileNotFoundException: Could not load file or assembly 'System.Something.I.Gess, Version=4.0.0.0, Culture=neutral, PublicKeyToken=blahblahblah'. The system cannot find the file specified. This is a known bug. FASTER files are extracted in the temp folder while running and windows likes to "clean" this folder. Current workaround is to set the DOTNET_BUNDLE_EXTRACT_BASE_DIR environment variable to some path such as C:\Users\your_user_name\Documents\Apps\FASTER (refer to #faq n°7 for this procedure). It should prevent Windows from deleting the files.

 

7. Wait, how do I change Environment Variables ? Search into your Windows Search bar for "Environment" Then Edit your System Environment Variables > Environment Variables... > New... and fill the information like so

unknown.png

 

Share this post


Link to post
Share on other sites

Hi having a small issue. Launching the HC it says "steam authentication failed". I have the Headless IP and Local Client as 127.0.0.1 and a playable HC in the mission. Any idea why?
Nevermind, didn't have battle eye ticked. Feel free to delete

Share this post


Link to post
Share on other sites

Brace yourselves !

Tomorrow (or Saturday if I'm late)  I will release FASTER 1.7 featuring the new Profile View and the FASTER Maintenance executable
A migration procedure is in the latter to easily convert your old 1.6 profiles to 1.7 without losing any data

The git repo have also changed :
https://github.com/Foxlider/FASTER

  • Like 4

Share this post


Link to post
Share on other sites

Update 1.7 also contains very important fixes about adding mods causing crashes

  • Like 1

Share this post


Link to post
Share on other sites

////// IMPORTANT ///////

There have been a major delay in the release for 1.7 because of a few glitches that arrived a bit late. These have been fixed and it's been about a week with no bug reports so release should be arriving soon.

MAKE SURE YOU READ THE WIKI ABOUT FASTER_Maintenance.exe FOR THE MIGRATION TO THE NEW VERSION OTHERWISE YOU MIGHT LOOSE YOUR PROFILES

Share this post


Link to post
Share on other sites

New MAJOR release today !

Update 1.7a

 

Changelog :

Added :

  •  UI Fixes
  •  NEW PROFILE SYSTEM
  •  FASTER_Maintenance module (check the wiki : https://github.com/Foxlider/FASTER/wiki)
  •  Load mods preset from html file into your profile
  •  Support of Arma3 Performance Branch
  •  Support of Folders ! Now you can load PBOs and Mission folders
  •  Support or OPUS Voice CODEX
  •  Modified Mod Keys behavior
  •  Network Config Presets
  •  Sort mods by ID or Name

Fixed :

  •  Crash when adding a mod with a big ID (int maxValue overflow)
  •  Fixed some config glitches
  •  Fixed some network glitches


NOTE : If you need a 32 bit version, contact me directly

IMPORTANT NOTE : Please read the Wiki
VERY IMPORTANT NOTE :  You will lose all your profiles with this update if you don't run the FASTER_Maintenance Program.

GitHub link

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×