Jump to content

Recommended Posts

Hey, so I've got a question regarding the setting up of multiplayer spawns *on* static ships in ARMA 3. No matter what I do, I am unable to successfully spawn onto a static ship, such as in the hangar bay of a destroyer, or on the flight deck of a carrier. Is there some secret Bohemian sorcery that I simply don't know that makes it work, because there's absolutely zero material out there on this matter and it's beginning to get frustrating.

Share this post


Link to post
Share on other sites
22 minutes ago, Kassaran said:

No matter what I do

Welcome to Bis forums!

So what have you done or tried, and are trying to do to spawn?

Share this post


Link to post
Share on other sites

So, I've gone through and spawned in both of the ships as part of a 'fleet'. I've done my research into how to create multiple respawn points for NATO, including the variable naming conventions and using respawn_west prefix.

The problem comes in making the spawn put players on static ship surfaces. So while I can make a ship spawn in, and I can spawn players in, the spawnpoint refuses to put players onto the ships.

Share this post


Link to post
Share on other sites

Technically in the editor you dont "spawn" anything, they are "entities" or assets that are placed.

In your mission's folder do you have a description.ext

 

Code:

respawn = "base";
respawndelay = 10;

 

Do this:

  1. At the top under Attributes, go to Multiplayer
  2. Go to respawn and set the dropdown menu for respawn on custom position
  3. Go to F5 Systems, then to Multiplayer
  4. Place down a respawn position on top of the carrier, make sure the Toggle surface snapping button is clicked at the top of the editor (icon looks like 2 arrows pointing to a line).
  5. In the variable name box of the respawn position module, put respawn_west
  6. Save.
  7. Go to play at the top of the editor, then down to play in MP, choose your unit, and press continue, from there press escape and then click on respawn you should respawn on top of the carrier where you placed the module.

Share this post


Link to post
Share on other sites

I think it might be fixed now, but it'll take a minute for me to make sure. I'm pretty sure it was just the Toggle Surface Snapping button which was making it nigh impossible to do otherwise. Surprisingly enough, I figured it'd just spit someone out at or above the altitude the module was placed at, but maybe there's an additional functionality in placing it "on" a surface? Anyways...

Share this post


Link to post
Share on other sites
11 minutes ago, Kassaran said:

maybe there's an additional functionality in placing it "on" a surface?

Nope, just make sure the Toggle Surface Snapping tool is set where the arrows are pointing to the line and not away from it, then

the module will snap to the surface of the carrier or ship your using thats all you need to do.

Share this post


Link to post
Share on other sites

So while I couldn't fix the original mission, I've now successfully managed to make the spawns hold elsewhere. Thanks for the advice, there seems to be some other underlying issue with all of this, but it isn't rearing its head towards me anymore.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×