Jump to content
UNIT_normal

[Release] Vehicle Appearance Manager GUI

Recommended Posts

@UNIT_normal - I did exactly as you listed per your instructions.  The HPP files were/are in the VAM_GUI folder.  You saw entire description file too.  Your lines are the only thing present.

 

 I will try your 'sample' mission to see 'what is what' and let you know!

 

Thanks for your reply!

 

:)

 

  • Like 1

Share this post


Link to post
Share on other sites

@UNIT_normal - Ok, here is what I did.

 

I ran CfgConvert on your SQM file and then was able by trying to pull it into every map that it is a VR map.

 

After figuring that out, I load/ran your mission.  I did work as stated.

 

I examined my files again, and I do not see what happened.  I copied your files over again to my mission folder and then it worked.

 

I have no idea what the issues was.  I am not a 'noob' at ARMA, 11k+ hours in A3 and 17+ years with ARMA itself....beats me...???

 

I would recommend you save your mission file properly as this will cause issues for others as no one knows what map goes with this mission.  Opening and Merging, neither would work for any map.  After 'decoding' it, was I able to use it and use it in any map, though placement would be 'off' on the wrong maps...  😉

( e.g. Save/package/rename as:  VAM_GUI.VR)

 

Just a thought...  🙂

 

So all is well now and I do thank you for your help!  Nice mod and good work on such a simple task!  Good job!  🙂

 

 

🙂

 

Share this post


Link to post
Share on other sites
51 minutes ago, z80cpu said:

@UNIT_normal - Ok, here is what I did.

 

I ran CfgConvert on your SQM file and then was able by trying to pull it into every map that it is a VR map.

 

After figuring that out, I load/ran your mission.  I did work as stated.

 

I examined my files again, and I do not see what happened.  I copied your files over again to my mission folder and then it worked.

 

I have no idea what the issues was.  I am not a 'noob' at ARMA, 11k+ hours in A3 and 17+ years with ARMA itself....beats me...???

 

I would recommend you save your mission file properly as this will cause issues for others as no one knows what map goes with this mission.  Opening and Merging, neither would work for any map.  After 'decoding' it, was I able to use it and use it in any map, though placement would be 'off' on the wrong maps...  😉

( e.g. Save/package/rename as:  VAM_GUI.VR)

 

Just a thought...  🙂

 

So all is well now and I do thank you for your help!  Nice mod and good work on such a simple task!  Good job!  🙂

 

 

🙂

 

That's weird. My friends(They makes scripts and help script test.) didn't get any problem.

My mission just saved properly so you just should put VAM.VR or VAM_alt.VR folder from zip file on C:\Users\*USER_NAME*\Documents\Arma 3\missions.

t2mD00Z.jpg

sh08DS5.jpg

nTitqnM.jpg

I think you just messed with 'Save As'. Or unzip with improper way.

Anyway have nice day with my script!

Share this post


Link to post
Share on other sites

@UNIT_normal - Thank you for your reply.

 

No, I did not save it wrong.  I did find out what was wrong though...  😉

 

I thought I got it from Google, BUT, I got it from ARMAHolic.

 

If you look at the screenshots below, you'll see what happened and why I had such 'issues'.

 

On the AH site, the zip file name is:  vehicle-Appearance-Manager-GUI-Alternative-version-1.30.ZIP  Notice, there is no 'VR' in the name, thus my problem.

 

You just need to rename the AH version...  🙂

 Note:  I have no idea if the 'normal' AH version is named correctly or not...

 

Simple problem, but identified and THAT is all that matters!  🙂

 

Thanks again and it is working just fine!  🙂 

 

🙂

 

SS #1:  https://imgur.com/XCHLBX8 - This is a SS from my 'Download Manager' within FireFox.

SS #2:  https://imgur.com/XzMn603 - This is the contents of the above file.

 

 

 

  • Confused 1

Share this post


Link to post
Share on other sites
44 minutes ago, z80cpu said:

@UNIT_normal - Thank you for your reply.

 

No, I did not save it wrong.  I did find out what was wrong though...  😉

 

I thought I got it from Google, BUT, I got it from ARMAHolic.

 

If you look at the screenshots below, you'll see what happened and why I had such 'issues'.

 

On the AH site, the zip file name is:  vehicle-Appearance-Manager-GUI-Alternative-version-1.30.ZIP  Notice, there is no 'VR' in the name, thus my problem.

 

You just need to rename the AH version...  🙂

 Note:  I have no idea if the 'normal' AH version is named correctly or not...

 

Simple problem, but identified and THAT is all that matters!  🙂

 

Thanks again and it is working just fine!  🙂 

 

🙂

 

SS #1:  https://imgur.com/XCHLBX8 - This is a SS from my 'Download Manager' within FireFox.

SS #2:  https://imgur.com/XzMn603 - This is the contents of the above file.

 

 

 

I didn't upload on Armaholic myself...

I don't know why this is on there...

(confused)

I didn't expect that kind of problem...

  • Confused 1

Share this post


Link to post
Share on other sites
16 hours ago, UNIT_normal said:

I didn't upload on Armaholic myself...

I don't know why this is on there...

http://www.armaholic.com/page.php?id=35222

Armaholic atleast says it was authored by you. But that wouldn't be the first time I see Armaholic uploading something without permission, without asking, and without even notifying the author.

  • Thanks 1

Share this post


Link to post
Share on other sites

OP,

 

You may want to check out this thread, there are unused textures you can apply to some of the vehicles. For example, this is a black texture for the Hummingbird.  \a3\air_f\Heli_Light_01\Data\heli_light_01_ext_ion_co.paa

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, stburr91 said:

OP,

 

You may want to check out this thread, there are unused textures you can apply to some of the vehicles. For example, this is a black texture for the Hummingbird.  \a3\air_f\Heli_Light_01\Data\heli_light_01_ext_ion_co.paa

 

 

 

This script already uses hidden(unused) textures. (ex. NATO texture Gorgon and Black texture Hummingbird that you mentioned.)

I applied only completed hidden(unused) textures. Incompleted textures are not included on this script.

Share this post


Link to post
Share on other sites

@UNIT_normal - thanks like your script which works fine. I dont want players to change the colors of the vehicles only the camouflage. Is that posible by excluding a part of the script. Im not a scripter more a noob 🙂   - thanks

 

Best

Share this post


Link to post
Share on other sites
On 7/29/2019 at 7:43 PM, UNIT_normal said:

 

 

Adding options to repair, rearm, refuel the vehicle  would make this the ultimate mechanic Script/UI!

 

Anyways, that you! Using this in my missions!

Share this post


Link to post
Share on other sites

Great script. I agree. If we could some how combine this with GOM loadout script, this would be complete.

Share this post


Link to post
Share on other sites

Nice project! 🙂

 

Is there any way I can apply my own textures to your project?

I'd like to apply the texture I made through your GUI!

 

Cheers!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×