Jump to content
W. Diaz

How to make AI not spawn unless a real player is playing it

Recommended Posts

Hi there, I am trying to setup my units training map (im a new map dev) I am trying to have it where if there is no actual player for the position then the AI does not spawn if that makes sense.


For example



- AI 1

- AI 2

- AI 3 


There is a player in AI 1, which would show and be playable by a real person but there is no real person playing AI's 2 and 3, how do I make 2 and 3 not spawn. 


I would like it where we can still have AI spawn to play as OPFOR or for Civilian AI's if we decide to do a training event using AI's



Share this post

Link to post
Share on other sites

There is a setting in the editor that you can check, or that you can add to description.ext:

disabledAI = 1; // 0: disabled - 1: enabled. Default: 0

1 (checked) will do what you want, 0 (not checked) will allow AI to be in place of playable units. This does not disable AI units entirely, only units set to player or playable.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now