Jump to content
snkman

Tactical Combat Link - TypeX

Recommended Posts

10 hours ago, Unleashthepain said:

Do the AI setup static weapons with this? Just wondering as i'm yet to see them do it

nope, thats only in Vcom ai mod

 

Share this post


Link to post
Share on other sites

How MP and Zues friendly is this mod?

Currently using LambsAI and having alot of issues with AI not following orders and player set waypoints.

Share this post


Link to post
Share on other sites

At times the "ai" takes control over the player, commanding and sometimes the actions as well, only thing the player is in control of is the movement.

Did a mission where i was doing recon over a town and all of a sudden my character told the other ai to open fire and flank, had to tell them to hold fire and regroup about 5 times.

 

Another time was when me and a friend were playing Dynamic Recon Ops and my character through smoke, told my team mate (the friend) to flank. He on the other had had problems where his weapon was constantly going down and couldn't stop healing himself, he was injured and had no meds.

 

I've had problems like this before using Vcom, the healing problem, and it just breaks everything and makes the playing with the mod unplayable.

 

Really good mod tho, when everything is working, fights feel dynamic and fun.

  • Like 1

Share this post


Link to post
Share on other sites

AI start with 0 skill or at least are set to 0 skill briefly after spawning then i have to increase is again, anyway to change this? I want to increase the default spawn skill.

Share this post


Link to post
Share on other sites

I'm having problems with TCL and I might have to just give up on this. I've tried the out of the box 1.31 version and tried editing the userconfig myself. Neither seem to net any results. The userconfig files are properly located in the directory.

 

If I Garrison AI units in the editor, they start the mission out in combat mode and clear the compound, then rush into the field like they're attacking an objective that isn't there. They also immediately throw smoke grenades while in the buildings at the very start of the mission.

 

I also have units placed on the map as dynamic patrols. Instead of following their presets to be "SAFE" and moving at "LIMITED" speeds, they rush around and try to clear the town they're supposed to be patroling through.

 

I love this mod for the firefights you can have in an open field. But this seems to break any editing I do. Can anyone advise what might be going wrong? Otherwise I just have to fall back to using LAMBS.

Share this post


Link to post
Share on other sites
35 minutes ago, Semper_OFP said:

I'm having problems with TCL and I might have to just give up on this. I've tried the out of the box 1.31 version and tried editing the userconfig myself. Neither seem to net any results. The userconfig files are properly located in the directory.

 

If I Garrison AI units in the editor, they start the mission out in combat mode and clear the compound, then rush into the field like they're attacking an objective that isn't there. They also immediately throw smoke grenades while in the buildings at the very start of the mission.

 

I also have units placed on the map as dynamic patrols. Instead of following their presets to be "SAFE" and moving at "LIMITED" speeds, they rush around and try to clear the town they're supposed to be patroling through.

 

I love this mod for the firefights you can have in an open field. But this seems to break any editing I do. Can anyone advise what might be going wrong? Otherwise I just have to fall back to using LAMBS.

everything is configurable via the user config just remove the "//" when you change the values.

for.your patrol units you may need to change their combat mode to "do not engage, stay in formation" or "never fire, keep formation" you may want to check this:

,https://community.bistudio.com/wiki/setCombatMode

for your garrison units if you want them to hold their location you may try this on each units init "dostop this;" it should stop them also check their behavior and combat mode, i remember having this issue, i changed something in the userconfig but i really dont remember it, you may need to check there for things to disable ...

besides you can use lambs with TCL both together, they work pretty well together ; )

however, you need to adjust the settings to fit spesefic missions, even when using vanilla ai you need to script down commands to assure that things will work correctly and as expected.

Share this post


Link to post
Share on other sites

I'm not sure what's causing it exactly. When I remove the mod, it goes back to how it should be. I've also noticed using UAV's becomes erratic and they don't follow loiter waypoints when given orders in the terminal.

 

I've tried using LAMBS because I like their specialized waypoints and CQB system for AI, however I do think it clashes with TCL by having two conflicting "take cover" systems. The AI behavior in TCL is much better once the firefight beings, but the erratic behavior is killing me lol

Share this post


Link to post
Share on other sites

I've tried disabling many of the features. It seems like the BLUFOR all know where the OPFOR are at the beggining of the mission. All mounted units get out of their vehicles and pursue on foot even if they're far away across the map. The marker around the town is pulsing when I view it in the map. I did not set this market on my own althought the ones on the right are my doing. I've tried doing everything you've said above. I've tried turning everything off in the userconfig. I've never had a problem until now with this mod and I can't figure out what the hell is wrong. It seems like AI only like to be given preset waypoints and lose their minds if they're given a dynamic patrol order or no waypoint at all.

 

ppSKMB2.png

Share this post


Link to post
Share on other sites

which mission are you using ?

does it happens on other missions too?

what kind of scripts are you using on that one and are you using any modules ?

also which mods are you using, it could be mod conflict.

... i used lambs with TCL i didn't got any issues with the cover system, because lambs danger just improves the vanilla ones and then TCL will overwrite it with its own system, lambs doesnt add anything in that, it only conflicts with knowledge sharing between the ai, and you can disable that as well.

Share this post


Link to post
Share on other sites

I think I resolved the issue. I had placed three AI units with animations in the town to the west. When I removed the animations, suddenly the BLUFOR began to act regularly again. I'm not sure why that would cause the AI to be aware of OPFOR across the map, but it did. I was only running RHS and TCL.

Share this post


Link to post
Share on other sites

Might be related to what I found out a while ago:

 

I believe this is caused by some specifics of BIS_fnc_ambientAnimCombat:

This function always seems to spawn some blufor entities for displaying the animation, while hiding the original units.

TCL opfor AI then probably registers those spawned blue entities (whatever they are) as threats.

Share this post


Link to post
Share on other sites

Still seems to be the best mod out for Arma 3. Being 2020 I was hoping for so.e awesome fully finished AI mods. Sad. 

Share this post


Link to post
Share on other sites

My AI squad frequently takes it upon themselves to ignore the orders and begin giving commands to the rest of the group despite the fact that I'm the squad leader. This could be anything from move orders to engaging and opening fire. Is there a way to prevent this? Is this a bug or by design?

Share this post


Link to post
Share on other sites

Another issue I can't shake is the AI still throwing smoke grenades when wounded.

 

I've changed the values to 0 and false, removed the "//" from the comment in the script. Still getting AI throwing smokes when wounded. Any ideas?

Share this post


Link to post
Share on other sites
On 5/26/2020 at 11:11 PM, Semper_OFP said:

Another issue I can't shake is the AI still throwing smoke grenades when wounded.

 

I've changed the values to 0 and false, removed the "//" from the comment in the script. Still getting AI throwing smokes when wounded. Any ideas?

throwing smokes is also a vanilla thing, try without TCL and see if that happens again also are using other mods that affect the ai ?

Share this post


Link to post
Share on other sites

Is this made for Zeus multiplayer missions or Eden Editor missions?

Share this post


Link to post
Share on other sites

Does this work well with ALiVE?

Share this post


Link to post
Share on other sites

I'm having a problem with TCL whenever I engage in combat with the enemy the AI takes over my player and issues movement and engagement orders to my team, randomly pulls out binoculars if I have any, and throws smoke grenades. If I tell them to fall back or hold their fire the AI overwrites my orders with it's own orders. Is there any way to fix this? This AI mod is the best I've come across but this problem is really frustrating.

Share this post


Link to post
Share on other sites
On 8/22/2020 at 12:21 AM, steam-76561198020733662 said:

I'm having a problem with TCL whenever I engage in combat with the enemy the AI takes over my player and issues movement and engagement orders to my team, randomly pulls out binoculars if I have any, and throws smoke grenades. If I tell them to fall back or hold their fire the AI overwrites my orders with it's own orders. Is there any way to fix this? This AI mod is the best I've come across but this problem is really frustrating.

does that happens with playable units ?
i have the same issue if thats what you are experiencing 

Share this post


Link to post
Share on other sites

Yes it does. It's also very noticeable when I'm messing around with Zeus in editor. Also when I'm in a firefight the unit I'm playing as will sometimes stand up straight and touch the side of his helmet (information sharing?) and I can't move or do anything until it's over, I usually get killed before it's done.

Share this post


Link to post
Share on other sites
2 minutes ago, steam-76561198020733662 said:

Yes it does. It's also very noticeable when I'm messing around with Zeus in editor. Also when I'm in a firefight the unit I'm playing as will sometimes stand up straight and touch the side of his helmet (information sharing?) and I can't move or do anything until it's over, I usually get killed before it's done.

 

5 hours ago, AirShark said:

does that happens with playable units ?
i have the same issue if thats what you are experiencing 

 

Forgot to quote you. Sorry ^

Share this post


Link to post
Share on other sites

@snkman

 

Hi buddy,

 

I've been running ops using your awesome AI, but now we're looking into a liberation server with your AI.

They keep throwing flares, so many. we disabled the flares in the sqf file, but they keep throwing them.

 

Is there anything else we can do to stop these flare launching maniacs?

 

Thx,

Will

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×