Jump to content
Flax

FAST2 - Arma Server and Steam Workshop Tool

Recommended Posts

Great program, extremely simple and FAST to setup. I had the setup & server running in 5 minutes using this. Thanks for sharing ūüôā

Share this post


Link to post
Share on other sites
On 7/18/2019 at 3:21 AM, rekkless said:

https://imgur.com/io89l02

 

Can anyone tell me why I can't download mods? login details are correct, I have downloaded SteamCMD and can log in no problem. But as soon as the mods try to download I just get these errors.

 

Have you taken a look at the file mentioned in the error - C:\FMIS\Steam\logs\stderr.txt

 

This is a steam error rather than a FAST error. If you let me know what's in there we can see if we can sort it. 

Share this post


Link to post
Share on other sites
5 hours ago, Flax said:

 

Have you taken a look at the file mentioned in the error - C:\FMIS\Steam\logs\stderr.txt

 

This is a steam error rather than a FAST error. If you let me know what's in there we can see if we can sort it. 


I figured it out Flax, it was because the login details I was using did not own a copy of ArmA, the details could download the ArmA 3 Server files no problem as they are free, but can not download mods.

  • Like 1

Share this post


Link to post
Share on other sites

I resisted using FAST2 for some idiotic reason for far too long.  Built a new server last night and decided to use FAST2 to take care of things.  Excellent stuff!

  • Like 2

Share this post


Link to post
Share on other sites

if i change server port from 2302 to 2402  headless client  not working.i mean it(HC) stay same port 2302 and not connected to server 

Share this post


Link to post
Share on other sites

Hey sorry is I mess something up, first post on the forums ever. 

I can not seem to get my HC to work on my server with mods and I have no idea what to do I use FAST 2 so I figured this was the best place to start after a couple of hours of searching. this is the error I'm getting

UcqgtZz.png

 

Share this post


Link to post
Share on other sites

@Gary Crooks Did you happen to transport the server's MOD listing to HC?
 

If you have changed the server port you may also have problems. Flax had reported about this bug.

Share this post


Link to post
Share on other sites
On 8/11/2019 at 9:11 PM, Arghbra said:

@Gary Crooks Did you happen to transport the server's MOD listing to HC?
 

If you have changed the server port you may also have problems. Flax had reported about this bug.

 

I did not and honestly, I don't know-how

 

Share this post


Link to post
Share on other sites

https://imgur.com/a/CA2Sd32

See the image above, the first quadrant indicates the server MODs only, the second quadrant the MODs the player needs (MOD`s used in the mission edition) and the third quadrant the HC MOD¬īs. 2nd and 3rd quadrants must have the same listing as MOD¬īs
 

I could not upload the message in the Forum. Sorry

Share this post


Link to post
Share on other sites

Can't use this on my Windows 2016 dedicated server, no window pops up for me to enter my SteamGuard code.

Share this post


Link to post
Share on other sites
On 2/10/2019 at 1:29 PM, Flax said:

Yeah there seems to have been something that stops this from working. I am working on a permanent fix but for now download this exe and replace the existing FAST2 exe and run as normal. Steam CMD will open in its own window when updating and you can enter steam guard codes etc there.

 

https://www.dropbox.com/s/ct02apkejk7man5/FAST2.exe?dl=1

Do that update

Share this post


Link to post
Share on other sites

Hey guys! So, im oppening my server using FAST2 but im having some issues with it, the issue is, the server is showing on the internet and all that stuff, but when me and my friends connect if anyone just shot 1 time his gun doesn't stop shooting, even if no rounds in mag, for him its not shooting but for all the others the weapon doesn't stop! Can anyone help me with this?

 

Obs: sorry for my english!

 

Obs 2: looks like this issue happens only with players, AI its working fine.

Edited by voodoo.shogun

Share this post


Link to post
Share on other sites

This appears to be an editing error and / or MOD¬īs

 

Check your list of MOD's and if they are all compatible with a dedicated server.

Share this post


Link to post
Share on other sites

@GibboDaBeast 
 

Quote

Posted February 10

Yeah there seems to have been something that stops this from working. I am working on a permanent fix but for now download this exe and replace the existing FAST2 exe and run as normal. Steam CMD will open in its own window when updating and you can enter steam guard codes etc there.

 

https://www.dropbox.com/s/ct02apkejk7man5/FAST2.exe?dl=1

 

Share this post


Link to post
Share on other sites

Are there any particular hoops I have to jump through to enable rcon except for doing it in the BEserver_x64.cfg?

Share this post


Link to post
Share on other sites

Hey guys, I saw a post about the larger mods taking ages to download and steamcmd timing out, and having to press the update all for the mods to continue to download, but did anyone find a fix for this?

 

Or do i just keep mashing the button? lol

Share this post


Link to post
Share on other sites
11 hours ago, HumaineNZ said:

Hey guys, I saw a post about the larger mods taking ages to download and steamcmd timing out, and having to press the update all for the mods to continue to download, but did anyone find a fix for this?

 

Or do i just keep mashing the button? lol

 

Unfortunately no fix, seems to be an issue on the SteamCMD side. Haven't found a way around it yet. Like you say mash the button each time it stops and you'll be good eventually. 

  • Thanks 1

Share this post


Link to post
Share on other sites

But in the Flax program, even given timeout, the download is not lost. It is indicated as not complete and you can continue the process until the end of it.

Share this post


Link to post
Share on other sites

Are there logfiles?

 

After downloading FAST2 it worked fine until I had to restart the server. Now when I run the FAST2.exe nothing happens, it starts a task that is killed / closed right away again.

Tried to redownload / "reinstall", tried to delete the Profile folder in the game folder. No success.

 

Does your application create any files outside the application & game folder? Found nothing in Documents, AppData, Temp folder but this issue is really weird.

 

Edit: Okay, after renaming the installation folder from "FAST2" to "FAST", the application starts again. But I've got to set everything up again. Until next restart where the story repeats¬†ūüėē¬†

Share this post


Link to post
Share on other sites

Like GibboDaBeast

 

Quote

Can't use this on my Windows 2016 dedicated server, no window pops up for me to enter my SteamGuard code.

 

I have the problem to,. the logging loop indefinitely.

There is a workaround or can you do something for this ?

Thanks in advance for this wonderful tool :)

Share this post


Link to post
Share on other sites

I seem to be continually losing AddOn content every once and a while for no apparent reason, random Addons not always the same one?  I have to go into the Arma 3 directory and identify which ones are gone then go to "Steam Mods" section and "Update" individually manually to get the AddOn folder content again? Not sure why it is doing this?

 

Thanks

Vengeance

Share this post


Link to post
Share on other sites

I am having an issue. The program works great the first time I run it. I am able to install steam mods and setup a server and even launch a server with headless client it works great. The problem is when I save and quit out of FAST2 and relaunch FAST2 it crashes on startup. It shows the window and then within a second or so it closes. If I move the location of the FAST2 folder I can run it again but all settings are gone and I have to setup everything again only to have it crash on start up when I close and relaunch it. This is only after I configure a server I started it up and added the server install and a couple mods and closed it and reopened it and it worked. Setup server settings and saved, closed, and reopened FAST2 and it crashed again.

I am running Windows 10 I believe 1809 and I have the 1909 update available just haven't updated yet. Any help would be great if there are any logs or whatnot I can send I'd be more than happy to as this is the best server management tool I've used. Keep up the good work.

 

*EDIT*

I discovered that if I edited the FAST2.exe.config and set checkForModUpdates to FALSE it will start up again. So it seems that the check for mod updates on startup is causing the crash.

Edited by Govik
adding more info

Share this post


Link to post
Share on other sites
On 11/17/2019 at 9:28 PM, NorX Aengell said:

Like GibboDaBeast

 

 

I have the problem to,. the logging loop indefinitely.

There is a workaround or can you do something for this ?

Thanks in advance for this wonderful tool ūüôā

I got around this by using steamCMD alone and signing into my account. It will ask you for your steamguard code and once the steamCMD has been granted access with the code it shouldn't ask for it again and you can use FAST2 to install mods with steamCMD. If it asks every time you may need to lower your security settings in steam. I use a separate steam account for my server so I can have that one with less security and be more steamCMD friendly while my main steam account requires the steamguard codes more often which would conflict with steamCMD.

Share this post


Link to post
Share on other sites

New issue with FAST2 - I revoked my SteamAPI key which will have broken the app. I'm working on a fix. You'll actually get an update after all this time. Shocking I know!

  • Thanks 1

Share this post


Link to post
Share on other sites
16 hours ago, Flax said:

I revoked my SteamAPI key which will have broken the app

Your SteamAPI key was inside the app? That is/was a huge security risk, you should never do that.

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

√ó