Jump to content

Recommended Posts

15 minutes ago, GEORGE FLOROS GR said:

Is this house spawned during the game ?

No its preplaced in the editor.

16 minutes ago, GEORGE FLOROS GR said:

Maybe the easiest way should be with a trigger in the 3d editor.

Ya possible, but then what code would you use to prevent snow from flowing through, or spawning in the house, i suppose then you would have to take the code you

use to spawn the snowflake particles and then somehow turn them off or despawn them once they reach the trigger zone.

16 minutes ago, GEORGE FLOROS GR said:

Is it working with the other houses ?

Have no idea just only noticed the snow in the house you start in, in the mission.

I can only guess that all the houses on IFA3 maps will have the same issue.

 

Another thing would be to turn off the breath fog indoors as well, but then in the mission the doors to the patio are open so i guess its not necessary, lol

  • Like 1

Share this post


Link to post
Share on other sites
51 minutes ago, Gunter Severloh said:

IFA3 villa house classname for it is:     Land_LIB_HQ

 

Would you like to test this ?

- NOT TESTED -

 

This is just for the certain house , just test and add the radius.

 

Share this post


Link to post
Share on other sites

 

This is the error

if ((_player_pos distance2d GF_House) > GF_House_radius) then {

add also a hint in the if then , in order to know when it's working :

 

	_player_pos = getpos player;
	if ((_player_pos distance2d GF_House) > GF_House_radius) then {
	hint"true";
	GF_Snowing = true;
	}else{
	hint"false";
	GF_Snowing = false;
	};	

 

Share this post


Link to post
Share on other sites

This code is wrong because you must name the house and add the name in the script instead of the classname.

Sorry i just saw this !

If it is the same for every house then the script as it is wont help !

I'll see if i can do generally something , but as i understand, it needs to be everything changed !

Share this post


Link to post
Share on other sites

No worries, Rydygier suggested i turn the wind off and test that way, so i did and theres but a few snow particles that will

enter the house where you start in the mission and more outside, so a temp somewhat fix.

  • Like 1

Share this post


Link to post
Share on other sites

Here is a video with part of the script icluded :

( Snow + breath only )

2 hours ago, Gunter Severloh said:

Update - New mission

New mission:  Neaville Occupied Winter

This new mission was the original Neaville Occupied seen here:  https://steamcommunity.com/sharedfiles/filedetails/?id=1666645073

Now converted to a winter version, i have a video i put together, part of my Ragnarok'44 Build & Play series converting the mission, i play a little but its mainly an overview.

Check it out:

 
OP was updated with links for download with zip & Steam workshop!

More existing Ragnarok'44 winter conversion missions coming!

Stay Tuned!

 

Also want to thank Rydygier once again ....for his continued support, advice, tips, and information on code for Ragnarok'44!

Cheers my friend!  :drinking2:

Share this post


Link to post
Share on other sites

Hi sir.

 

Accidentally clicked your name when you tagged my post. Spent my Saturday afternoon trying out your scripts instead of answering my emails. 

 

Want to say "thank you" for the scripts AND documentation.

 

But, need to share a bug on this script. 

When running the demo mission, Arma shows a persistent error (line 134). See image below:
 

https://ibb.co/0K2zfnp

 

(PS I never run any mods. Only mission scripts)

 

Have a good day!

 

  • Thanks 1

Share this post


Link to post
Share on other sites
11 hours ago, Melody_Mike said:

Want to say "thank you" for the scripts AND documentation.

 

20191215062904-1.jpg

 

Hello there Melody_Mike !

 

Thank you very much!

This error is a break of the code from the latest updates , that have to do with the waituntil syntax.

 

use :

if(_Delete_Snakes)then{

	[]spawn{
		while{true}do{
			{
				if(agent _x isKindOf "Snake_random_F")then{
					deleteVehicle agent _x; 
				}; 
			}forEach agents; 			
			uisleep 2;
		};
	};
};

 

maybe the most all of my scripts need update becase of this.

 

Thanks for telling me and have fun !

 

Share this post


Link to post
Share on other sites

I am. having problem with the script init.sqf file on dedicated server. 

 

the error code is:

 

22:18:38 Error in expression <ehicle agent _x;
};
}forEach agents;
sleep 5;

};
};
};

diag_log "//____>
   Error position: <sleep 5;

};
};
};

diag_log "//____>
   Error Undefined behavior: waitUntil returned nil. True or false expected.
22:18:38 In last 10000 miliseconds was lost another 1 these messages.
22:18:38 File mpmissions\__CUR_MP.Stratis\addons\GF_Ambient_Environment_Winter\GF_AEW_init.sqf..., line 134

 

EDIT: Nevermind. I didn't saw your fix earlier. Also. This is the only script that outputs this error at the time writting this comment. 

Edited by MG141

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×