Jump to content
cssx3

Objects "showing" through glasses

Recommended Posts

The same error appear by every glasses and cars. So idk how to fix it :/

 

With my other headgears I don't get this error. 

Share this post


Link to post
Share on other sites
ambient[]={1,1,1,3.3};
diffuse[]={0.8,0.8,0.8,0.8};
forcedDiffuse[]={0.000000,0.000000,0.000000,0.000000};
emmisive[]={0.000000,0.000000,0.000000,1.000000};
specular[]= {0.1, 0.100000, 0.100000, 1.000000};
specularPower=40; /// Glossiness; 1 = high, 64 = middle, 1000 = none
PixelShaderID = "NormalMapDetailSpecularDIMap"; // The pixelshader
// The pixelshader tells what stages (modes) the face should use.

VertexShaderID = "NormalMap";

class Stage1 {
	// The "NormalMap"
	texture="r\rl\addons\textures\misc\Helmet_NormalMap.paa";
	uvSource="tex";
	class uvTransform
	{
		aside[]={1.000000,0.000000,0.000000};
		up[]={0.000000,1.000000,0.000000};
		dir[]={0.000000,0.000000,0.000000};
		pos[]={0.000000,0.000000,0.000000};
	};
};

class Stage2 {
	// The "Detail"
	texture="r\rl\addons\textures\misc\Helmet_DiffuseMap.paa";
	uvSource="tex";
	class uvTransform
	{
		aside[]={1.000000,0.000000,0.000000};
		up[]={0.000000,1.000000,0.000000};
		dir[]={0.000000,0.000000,0.000000};
		pos[]={0.000000,0.000000,0.000000};
	};
};

class Stage3 {
	// The "SpecularDIMap"
	texture="r\rl\addons\textures\misc\Helmet_SpecularMap.paa";
	uvSource = "tex";

	class uvTransform {
		aside[] = {1.000000, 0.000000, 0.000000};
		up[] = {0.000000, 1.000000, 0.000000};
		dir[] = {0.000000, 0.000000, 0.000000};
		pos[] = {0.000000, 0.000000, 0.000000};
	};
};

 

Share this post


Link to post
Share on other sites

Try using this one then tell me if the problem persists.

 

#define _ARMA_

ambient[] = {1,1,1,1};
diffuse[] = {1,1,1,1};
forcedDiffuse[] = {0,0,0,0};
emmisive[] = {0,0,0,1};
specular[] = {0.3,0.3,0.3};
specularPower = 60;
PixelShaderID = "Super";
VertexShaderID = "Super";
class Stage1
{
	texture = "r\rl\addons\textures\misc\Helmet_NormalMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage2
{
	texture = "r\rl\addons\textures\misc\Helmet_DiffuseMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage3
{
	texture = "#(argb,8,8,3)color(0,0,0,0,MC)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage4
{
	texture = "#(argb,8,8,3)color(0.75,0.75,0.75,1,AS)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage5
{
	texture = "r\rl\addons\textures\misc\Helmet_SpecularMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage6
{
	texture = "#(ai,64,64,1)fresnel(1,0.7)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage7
{
	texture = "a3\data_f\env_co.paa";
	useWorldEnvMap = "true";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};

 

Share this post


Link to post
Share on other sites
9 hours ago, warlord554 said:

Do you not want it to show through glass? After all, most glass is see through

 

This is what I mean:

 

cUrFGEg.png

 

10 hours ago, Noks - Ohliger said:

Try using this one then tell me if the problem persists.

 


#define _ARMA_

ambient[] = {1,1,1,1};
diffuse[] = {1,1,1,1};
forcedDiffuse[] = {0,0,0,0};
emmisive[] = {0,0,0,1};
specular[] = {0.3,0.3,0.3};
specularPower = 60;
PixelShaderID = "Super";
VertexShaderID = "Super";
class Stage1
{
	texture = "r\rl\addons\textures\misc\Helmet_NormalMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage2
{
	texture = "r\rl\addons\textures\misc\Helmet_DiffuseMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage3
{
	texture = "#(argb,8,8,3)color(0,0,0,0,MC)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage4
{
	texture = "#(argb,8,8,3)color(0.75,0.75,0.75,1,AS)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage5
{
	texture = "r\rl\addons\textures\misc\Helmet_SpecularMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage6
{
	texture = "#(ai,64,64,1)fresnel(1,0.7)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage7
{
	texture = "a3\data_f\env_co.paa";
	useWorldEnvMap = "true";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};

 

and really thanks, I will try it when I'm back at home

Share this post


Link to post
Share on other sites

In Object Builder, select the glass faces on the car and then Faces > Move Top.

 

If it also happens on a vanilla vehicle, like a Hunter, please show a screenshot.

  • Like 1

Share this post


Link to post
Share on other sites

Ahhhhhhhhh gotcha. Check your alpha faces in O2. Highlight helmet, faces tab, move top (I think is the path, I'm not at my computer)

Share this post


Link to post
Share on other sites
On 2.10.2018 at 1:20 PM, UK_Apollo said:

In Object Builder, select the glass faces on the car and then Faces > Move Top.

 

If it also happens on a vanilla vehicle, like a Hunter, please show a screenshot.

iP9OuyM.png

Share this post


Link to post
Share on other sites
On 2.10.2018 at 10:22 PM, warlord554 said:

Ahhhhhhhhh gotcha. Check your alpha faces in O2. Highlight helmet, faces tab, move top (I think is the path, I'm not at my computer)

I tried it multiple times, but it seems not working :(

Share this post


Link to post
Share on other sites
On 1.10.2018 at 10:55 PM, Noks - Ohliger said:

Try using this one then tell me if the problem persists.

 


#define _ARMA_

ambient[] = {1,1,1,1};
diffuse[] = {1,1,1,1};
forcedDiffuse[] = {0,0,0,0};
emmisive[] = {0,0,0,1};
specular[] = {0.3,0.3,0.3};
specularPower = 60;
PixelShaderID = "Super";
VertexShaderID = "Super";
class Stage1
{
	texture = "r\rl\addons\textures\misc\Helmet_NormalMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage2
{
	texture = "r\rl\addons\textures\misc\Helmet_DiffuseMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage3
{
	texture = "#(argb,8,8,3)color(0,0,0,0,MC)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage4
{
	texture = "#(argb,8,8,3)color(0.75,0.75,0.75,1,AS)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage5
{
	texture = "r\rl\addons\textures\misc\Helmet_SpecularMap.paa";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage6
{
	texture = "#(ai,64,64,1)fresnel(1,0.7)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage7
{
	texture = "a3\data_f\env_co.paa";
	useWorldEnvMap = "true";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};

 

At first, the helmet looks much better (ty), but it also not solving my problem

Share this post


Link to post
Share on other sites

Oh yes, this is something I forgot to tell you.

As PuFu said, you need to use proper texture suffixes.

When TexView is converting your .png file (for example) to a .paa file, it applies a filter on your image and this filter is different for every suffixe.

 

(It will certainly not solve your issue but that's a good thing to know)

 

Helmet_NormalMap.paa --> Helmet_nohq.paa

Helmet_DiffuseMap.paa --> Helmet_dt.paa

Helmet_SpecularMap.paa --> Helmet_smdi.paa

Share this post


Link to post
Share on other sites

Now I'm back to the topic. It wasn't a rvmat error or something alse.. It was an error on the model itself "idk what the error was"

 

After reimporting from blender it was still working. Thanks for your help!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×