Jump to content

Recommended Posts

So I am making plans on using the BIS_fnc_playVideo function and I am wondering if it is MP compatible. I tried searching for the answer to no avail and I cannot test it myself at this time so,

 

is it MP compatible and if not how can I make it? 

and in general are such functions MP compatible?

 

The BIS_fnc_ambientAnim one is. I have tested that one.

I have also tried implementing the BIS_fnc_MP to be sure and not have to ask but it reported an error.  

 

So any help will be appreciated..

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

Hello there John  !

 

Try to run in the init an  .ogv video

2 cutText ["", "BLACK OUT"]; 
sleep 1; 
_video = ["intro.ogv"] spawn bis_fnc_playVideo; 
waitUntil {scriptDone _video}; 
sleep 1; 
4 cutText ["", "BLACK IN"]; 

This should be MP compatible , for intro.

Otherwise you should remoteExec it.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

use remoteExec, not bis_fnc_mp. the playVideo command is local so it needs to be remoteExec for others to see if

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

@GEORGE FLOROS GR

@gokitty1199

 

Dang the wiki has no example. So I am partly guessing that I have to place this in the script:

 

remoteExec [[_video, [10, 10]] call BIS_fnc_playVideo;];

 

But there is also an addition to the description.ext in the wiki so I got confused. 

Anyways if that is not it please tell me how to. Logically speaking I will know how to use remoteExec afterwards. The basics at least.

 

  • Like 1

Share this post


Link to post
Share on other sites

@HazJ

 

Thank you very much!

In the [""] I will place the .ovg video location and it should work in MP dedicated or not I suppose.

 

Share this post


Link to post
Share on other sites

Is there any other game where the same scipt caused three different results in my three tests?

 

Why doesn't this one:
 

["TV\Youtube\Videos\action1.ogv"] remoteExec ["BIS_fnc_playVideo", [10,10] select isDedicated, false];

have the same effect with this one:
 

["TV\Youtube\Videos\action1.ogv",[10,10]] spawn bis_fnc_playvideo; [/code]

I am trying to make this script: http://www.armaholic.com/page.php?id=29895

//The owner allows me to: You can use this script as you want and edit it, but leave credit.

MP compatible but using the above made the video show in the whole screen at first and after changing the numbers to [10,10] the video:

 

1.] Got stuck in the first try.

2.] Was shown as an image in the second try.

3.] Showed another image in the third try.

 

Guys it is really important for me to make this one work so if anyone can help please do. Just one video to be shown in one tv. That is it.

 

EDIT: I have erased the [/code] because it showed an error and it kept working after the erase.

Share this post


Link to post
Share on other sites
["TV\Youtube\Videos\action1.ogv", [10, 10]] remoteExec ["BIS_fnc_playVideo", [10,10] select isDedicated, false];

?

  • Thanks 1

Share this post


Link to post
Share on other sites

@HazJ

 

First try showed a grey screen.

Changed the second [10,10] to [0, -2] and ............... it worked!!!

 

Thank you man! Or woman! I will even add you to the credits for this. Okay, editing can continue!!

  • Haha 1

Share this post


Link to post
Share on other sites

Yeah, didn't look at the arguments. I just copied it from your post. You didn't have that in the remoteExec line. Thought you didn't know how to add it.

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, JohnKalo said:

@HazJ

 

First try showed a grey screen.

Changed the second [10,10] to [0, -2] and ............... it worked!!!

 

Thank you man! Or woman! I will even add you to the credits for this. Okay, editing can continue!!

99% sure woman

  • Haha 3

Share this post


Link to post
Share on other sites
3 hours ago, JohnKalo said:

Thank you man! Or woman!

 

1 hour ago, gokitty1199 said:

99% sure woman

 

1 hour ago, major-stiffy said:

LOL 100% sure not. :f:

 

Ok this is a Good Start for the topic !

 

- Function MP Compatible ? -

 

 

 

#Compatible

 

 

  • Haha 3

Share this post


Link to post
Share on other sites

DO NOT ASSUME MY GENDER. THANKS. Especially in this day and age... LOL :rofl::rofl:

PS: I'm 110% man though.

  • Haha 2

Share this post


Link to post
Share on other sites
7 hours ago, HazJ said:

PS: I'm 110% man though.

Definitely man, always over stating the size of things :icon_biggrin:

  • Haha 2

Share this post


Link to post
Share on other sites
4 hours ago, Larrow said:

stating the size of things :icon_biggrin:

 

I 've noticed this also in some posts !

 

On 6/7/2018 at 6:57 PM, HazJ said:

 

But is it shorter better than longer? :rofl:

 

d0fc2352d5b1c2ca39f85b2a6948dc71--typogr

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×