Jump to content

Recommended Posts

So Arma3 Launcher suddenly decided to axe all of the mods I had subscribed to.


Says mods do not contain Addons folder (when they clearly do as I checked and double checked).




EDiT: to add some further context.

- I can still launch and play the game without any mods active;

-newly subscribed addons do not download and are stuck in an eternal quenue limbo;

-I had played A3 with same update just the previous day with no such issues;

-Repair tab does nothing

Share this post

Link to post
Share on other sites

Before you go and unsubscribe all of your mods do this:


Find your X:\Steam\steamapps\workshop\content\107410\ folder where the X is the Drive Letter it is installed on. The rest of the link points to the actual folder where all mods are downloaded into by STEAM.


There should a lot of numbered folders inside of the 107410 folder.


You can then set your ARMA 3 Launcher to auto ADD all the mods from the 10740 by watching it. Some mods should show up with names or nearly the same names intacted and some will be listed as numbers since all mods from steam are placed into a number folder.


Mods that show up with names only if the author/uploader had configured a mod.cpp text file INSIDE that folder with name= "modname"; line.


Otherwise, you have to figure it out or just look up the number on steam work's arma mod page.


If you have all of your mods, just run it this way until the launcher gets fixed.


I had this problem before due to some routing issue, not on my end but STEAM's end, which did not download the mod list for some reason on startup. I think it was BIS Wizard that fixed it for me. It was ongoing for a good 6-8 months!!!


Actually, my Arma 3 Launcher has been recently "finding" all 2000+ steam mods in the launcher lately so I think there is a network issue on Steam's end.

Share this post

Link to post
Share on other sites
7 hours ago, Valken said:



Thanks for the tips, but what if I have all my mods on an HDD and A3 on a separate SSD? I have mod folder linked to Steam WS folder on SSD via cmd.


EDiT: so I couldn't give enough fucks to do all the WS gymnastics and just unsubbed everything. Despite that my HDD mod folder still has all the mods intact. So i'm suspecting one of W10 "updates" broke the cmd link somehow.

Tried to redo the link but cmd refuses to creat it due to "Cannot create a file when that file already exists."


Here's the link cmd I use: mklink /d "C:\Program Files (x86)\Steam\steamapps\workshop\content\107410" "D:\A3_MODS\"

Share this post

Link to post
Share on other sites

It happened to me before. What I did was "backup" that 107410 folder by renaming it. So all the content stays intact.


Then you can move it to another folder, like your SSD.


Or you can make a copy of all or part of the content back INTO the 107410 folder, then re-subscribe to the mod. It should check it and update it if need be.


That is assuming your link to Steam is working because the ONLY reason your PC would forget about all the mods is if your HDD or SSD with the mods is going bad. Otherwise, it is more than likely STEAM WORKSHOP or their servers having problems in your region.


For big mods, I would copy it as a backup to see if Steam can find it. I hated waiting over 48 hours to verify all the workshops mods that still exists on my SSD. It is a pain until Steam is setup for delta patching for ARMA.

Share this post

Link to post
Share on other sites

I rechecked both the SSD and HDD - they are ok and have sufficient free space for operation. Not for my 84GB mod folder backup tho... :dozingoff:


I've decided to just go with "blunt stick" approach and purged everything mods related but A3 itself. I'll see if that sticks.


EDiT: I obviously tried to change Steam dl server location and clearing chache before just carpet-bombing the folders. No bueno.


Oh and did I mention fuck Steam and fuck PhysX (not directly related to the issue but still)

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this