Jump to content

Recommended Posts

13 hours ago, acmars said:

i come from china hope u can help me~~~thank you~~~

都是国人就好说了……有没有QQ啥的,方便点

Share this post


Link to post
Share on other sites
On 12/13/2018 at 2:56 PM, Fin_ said:

hi,sir,i can't find 'Users' Folder on  ARMA3 directory ,so where server.Arma3Profile should i copy?

 

PM me a copy of your server RPT

Share this post


Link to post
Share on other sites
5 hours ago, luminous815 said:

都是国人就好说了......有没有QQ啥的,方便点

有啊 哈哈哈哈 492881302 我加您呗

Share this post


Link to post
Share on other sites
9 hours ago, animalmother1939 said:

Hello,

Is there anyway to lift the role restriction for revive? 

 

in your files, find this line

 

https://github.com/auQuiksilver/Apex-Framework/blob/master/Apex_framework.terrain/code/functions/fn_initPlayerLocal.sqf#L201

 

and add this:

 

player setUnitTrait ['medic',true,false];

 

all players should then have the ability to revive (like medics)

  • Like 1

Share this post


Link to post
Share on other sites

Mission initialization failed, complains about the real date extension need to be active. Anyone else had an issue with that lately?

Share this post


Link to post
Share on other sites
3 hours ago, specialsmith said:

Mission initialization failed, complains about the real date extension need to be active. Anyone else had an issue with that lately?

 

that .dll file needs to be in your servers game directory, as pictured in the setup.

Share this post


Link to post
Share on other sites
On 12/17/2018 at 12:58 AM, fn_Quiksilver said:

 

that .dll file needs to be in your servers game directory, as pictured in the setup.

 

And that is exactly how it is set in my dedi-server. Will try to troubleshoot again when calendar allows...

Share this post


Link to post
Share on other sites

Hello, merry christmas

Is there any way I can make helicopters and planes available to all players?

  • Like 1

Share this post


Link to post
Share on other sites

I'm stuck on having issues with the difficulty setting, whenever I wish to customize the difficulty, it doesn't let me, I have a profile setup and I'm running parameters just fine, but it's not working properly, here's how I have everything setup thus far:

 

Parameters:

-port=2322 "-config=C:\Users\Steam\arma3annex\configs\server.cfg" "-profiles=C:\Users\Steam\arma3annex\serverprofile" "-name=server" "-bepath=C:\Users\Steam\arma3annex\battleye" "-servermod=@arametrics;@Apex;" "-loadMissionToMemory" "-filePatching"

 

RPT File: https://pastebin.com/G6q0ci2S

server.cfg: https://pastebin.com/wdzC3ut0

server.Arma3Profile: https://pastebin.com/QK0SYH6u

 

I honestly tried everything, I even looked into the mission file for any modifiers but couldn't find anything, anyone know this issue and how to resolve it?


Thanks in advance

Share this post


Link to post
Share on other sites

Happy new year!

I have a new problem now,some players tell me they saw Error  Code 191,I want to know what is this mean.

Share this post


Link to post
Share on other sites
On 12/22/2018 at 6:43 PM, specialsmith said:

 

And that is exactly how it is set in my dedi-server. Will try to troubleshoot again when calendar allows...

 

Hi Quicksilver, got it solved. It needed Visual C++ Redistributable for Visual Studio 2015 to work. Downloaded, installed and tried. Works. Got the tip from Killzone_Kids site: http://killzonekid.com/arma-64-bit-extensions/

 

  • Like 1

Share this post


Link to post
Share on other sites

Here is what is in store for next patch (no ETA)

 

 

Role Selection System to replace the lobby. Change and view roles ingame, and admins can set available roles dynamically based on selected mission type, without editing the mission file. Includes multi-faction support for TvT options.

 

  • Like 2

Share this post


Link to post
Share on other sites

I am having trouble with a black screen that says "Initializing..."  and it's just that when I load in. Running win x64

Share this post


Link to post
Share on other sites
2 minutes ago, AceWinchester said:

I am having trouble with a black screen that says "Initializing..."  and it's just that when I load in. Running win x64

 


PM me a copy of your servers RPT file

Share this post


Link to post
Share on other sites
4 hours ago, AceWinchester said:

How do you enable 3rd person it's not working through custom settings

 

It should be done in Arma3Profile file.

  • Like 1

Share this post


Link to post
Share on other sites

Hello Quiksilver, I have been working on a build of this for my group's server in which I have gotten functional TFAR but the issue I have is after completing getting TFAR to work I seem to have broken the Arsenal. For either a fix or work around would manually spawned arsenals work. Any help or thoughts would be appreciated spent about a week working straight on this.

I uploaded the edited files

Share this post


Link to post
Share on other sites

When i select a role in the center it says initializing but in the upper right corner it says Apex Framework servermod @Apex must be active.

Edit: fixed it

Share this post


Link to post
Share on other sites
7 hours ago, MouldySandwich said:

in the cas hangar i can't find any aircraft

First of all - you should have a Pilot role.

Second - you have to spawn the aircraft via terminal located in a hangar.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/27/2019 at 11:14 PM, AceWinchester said:

How do you replace the Whitelist.sqf with database

You can use EXTDB3 extension by Torndeco located https://bitbucket.org/torndeco/extdb3/wiki/Home

 

Quiksilver had an implementation of it on his server before he released the framework to the public ... hence if you dig into the sqf files you will see some references to "database stuff goes here".

 

You will need to be able to have a flavor of SQL server available, able to make queries, and know where to insert the code into the sqf files.

 

QS used it for CAS whitelisting and Area 51 access.  The nice thing about using the DB backend is that it allowed folks to get whitelisted quite a bit faster and more "on the fly" than the built in method.  You could simply change the database, ask the player to log off and back in again .. BOOM access granted.  Instead of having to wait for server restarts / manually restarting the server to make those kind of changes.

 

It is like using mods with the framework ... yes, you can do it ... but the official framework doesn't support it natively because (in my opinion only) having a framework that requires an outside dependency is just too much work for one person.  Not only do they have to rely on the mod being updated in a timely fashion after patches, but they also have their own stuff to work on and get ready for Patch 9.3.2.3345.  Better to focus on one thing, do it well, and move on.

 

~M~

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I almost done every step in "Setup Guide" and my server everything work but I still have some little problem about "server.Arma3Profile".

 

Where "server.Arma3Profile" should I copy?
I can't find "Users" Folder in "D:\Program Files (x86)\Steam\steamapps\common\Arma 3" so I put "server.Arma3Profile" in "D:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\Users\user".
https://imgur.com/a/LyKsN2b

 

I sure "thirdPersonView" set 1 but I can't enable third person in game.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×