Jump to content

Server can't transmit all data (issue with mods/signatures)

Recommended Posts

Whenever I load over 16 mods on our server (only the -mod parameter, not -serverMod), It gives an error when joining through the launcher (Screenshot below).

The error reads: "Server can't transmit all data; some allowed mods might be missing or their signatures not recognized"


I've tried:

- Using a direct path to the mods.

- Creating a symlink to the workshop folder and using that.

- Downloading the server files via steam.

- Downloading the server files via steamCMD.


Misc. info

- The mods are downloaded via the steam workshop.
- It doesnt seem to matter which mod gets added/removed, it seems to be simply the amount.

- If I repack some mods into one it works fine again, as long as the total amount of mods in the -mod param is below 17.


Our server

CPU: Intel Xeon E3-1230 V2 @ 3.30GHz
RAM: 16 GB
OS: Windows Server 16


start /b arma3server_x64.exe -server -cfg=basic.cfg -config=server.cfg -profiles="C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server" -name=Administrator -nosound -nopause -nosplash -world=empty -par=mods.txt


-mod=workshop\@CBA_A3;workshop\@ALiVE;workshop\@task_force_radio;workshop\@CUP Terrains - Core;workshop\@CUP Terrains - CWA;workshop\@CUP Terrains - Maps;workshop\@RHSAFRF;workshop\@RHSGREF;workshop\@RHSSAF;workshop\@RHSUSAF;workshop\@ace;workshop\@ACEX;workshop\@Project OPFOR;workshop\@RDS Civilian Pack;workshop\@ShackTac User Interface;workshop\@ACE Compat - RHS Armed Forces of the Russian Federation;workshop\@ACE Compat - RHS- GREF;workshop\@ACE Compat - RHS United States Armed Forces;
-serverMod=@AliveServer;workshop\@Advanced Rappelling;workshop\@Advanced Sling Loading;workshop\@Advanced Towing;workshop\@Advanced Urban Rappelling;

The server gives the error with these files/parameters, repacking the ACE RHS Compat ones into one mod and loading that instead of these three makes the launcher not show the error.


I've found very little about other people having a similar problem. I believe the solution they found was that the modstring was too long, but reducing the size (character count) doesnt seem to matter for me. I am by no means an expert so it could very possibly be something simple. I'm getting rather annoyed and desperate, so any help is appreciated :p

Responses on discord

I've posted this on the Arma discord, and the main things I got as a possible solution were:

Bundle mods (not recommended)

I've done this for now because we already have too many mods. I prefer not to do this though, and that's the main reason I'm trying to fix it. Additionally I'd love to add more mods and keep it so that people can still join through the launcher, because that is the easiest option for most newer people
Go into the meta.cpp for each mod and shorten the names
I've tried this, didn't work.
Get rid of the spaces in the -mod parameter

Tried as well, didn't work.

Share this post

Link to post
Share on other sites

There may be an issue with one of the mods, so strip them right back and start with the basics then  add a few over time

@Shac, isnt that clientside ?


You can shove all your RHS into @RHS

You can shove all your islands into @Islands


Run a bat file that downloads from the workshop then copies the required mod into the required mod folder to automate keeping them up to date and shorten your command line argument

The only mod there that you cannot put into a custom mod folder is Task Force

Share this post

Link to post
Share on other sites

I know this is a older topic,  but I have had the same issue.  I found a reference at one point that indicated that the problem may not be a mod issue,  but a network issue in regard to the amount of data being sent in the packet.  I will try to find the information again,  but you can test by removing mods till it works, and to prove that it is not a single mod, keep the number of mods approximately the same,  but change which mods are loading. 


Edit: strider42's link (https://forums.bistudio.com/forums/topic/203122-how-to-get-required-addons-to-show-up-in-launcher/) was the site I was referring to.  On  April 21, 2017 flexgrip posted "It ended up having nothing to do with an individual mod, it's that the UDP stream can only send so many bytes before it gets truncated. So you can't have more than, say, 15-20 mods before it fails."



Hope this helps other people

Share this post

Link to post
Share on other sites

Hello! I may be very late, but I also had this problem before but only with the mods. I managed to get this working not so long ago. Specifically, the mod only showed up as a puzzle icon and was technically an empty mod in Arma 3 when you try to start the game with mod parameters.


The Solution(?): Remove all spaces and either replace the spaces with _ or just leave it no space. Just remember that this has to be done for BOTH parameters AND the workshop folders.

Hope this helps.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now