Jump to content
Sign in to follow this  

Respawn: Menu Location (Join in progress bug?)

Recommended Posts

Hey first time posting on here so please forgive me if I don't supply all the information needed!


Recently I've been making a team vs team mission that is based on the rush gamemode from battlefield games, but I've come across an issue when testing it on a dedicated server that has pretty much made it impossible to resume without having to restart everytime somebody joins. I'm using the RespawnTemplates: Menuposition and MenuInventory, I've set the inventory in the description and I've got revive working, but whenever somebody joins in progress they get stuck on the map screen with no menu to allow them to choose a position or a loadout.


Either i'm doing something silly for this to occur or I've came across a bug but I've tried Reddit with no replies and I've tried searching on google for countless hours with no success of a solution. The only thing I've really got that would interfere with it I guess would be the InitPlayerLocal.sqf and OnPlayerRespawn.sqf but I'm not 100% sure on how to fix this which is why I'm here

Map = 1;
saving = 0;
disabledAI = 1;
joinUnassigned = 1;
enableSentences = false;
OnLoadName = "WW2: Battle For Szydlow";
loadScreen = "pictures\background.jpg"; 
Author = "J. Doddsy (RaptorSKA)";

// Respawn
respawn = 3;
respawnDelay = 10;
respawnDialog = 1;
respawnOnStart = 1;
respawnTemplatesWest[] = {"MenuInventory","MenuPosition"};
respawnTemplatesEast[] = {"MenuInventory","MenuPosition","Tickets"};

// Revive
ReviveMode = 1;                         
ReviveUnconsciousStateMode = 0;         
ReviveRequiredTrait = 0;                
ReviveRequiredItems = 2;                
ReviveRequiredItemsFakConsumed = 1;     
ReviveDelay = 10;                        
ReviveMedicSpeedMultiplier = 2;         
ReviveForceRespawnDelay = 3;            
ReviveBleedOutDelay = 40;              

// Misc
showCompass = 1;
showGPS = 1;
showWatch = 1;
showNotePad = 1;

// Optimisation:
wreckLimit = 4;
wreckRemovalMinTime = 60;
wreckRemovalMaxTime = 120;


Ingame when the player joins after launching the session, he'll sometimes get the menu but It's just a slight chance. The players I've had join say they can only see the map screen, they have physically spawned at the respawn location - once killed they are able to actually see the menu.. I'm sorry if this has already been solved, I only took a quick look at the forums to see if anything resembled my error but it's something I've been trying to fix now for about 2 weeks and I'm still having no luck with Reddit or Google. I've tried looking at respawnonstart -1; I've even removed respawnonstart and it actually started working slightly.

Share this post

Link to post
Share on other sites

I recently experienced that also, playing on some official servers (Arma APEX Vanilla), ZEUS missions.

Several times stuck at origin, map view, nothing to do other than ALT F4, bye bye and retry. Linked to a high ping? (> 250, yes, I know...)


Share this post

Link to post
Share on other sites

The server box I'm currently using is based in the States, but members from there are getting a ping around about 50-90 ping and they are experiencing the same flaws - It's good to know that some of the official servers are having the issue though, at least it's being experienced in other places! But ALT F4 is the only solution, even bringing the server to the lobby again players are still stuck at that screen.

  • Like 1

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this