Jump to content

Recommended Posts

Hey Everyone.

I'm currently running a modded server and have signed all the mods we are using on the server with a newly generated key.


Previously I enabled checkSignatures and whenever I joined a dialogue box would come up and tell me that the mods im using dont have the right key. So I put the .bikey inside the keys folder and now instead of bringing up the box and telling me what mods dont have the right key it just throws me out after a second with the message "Session Lost" the logs for the server and the client show nothing however when I do get session lost it tells me that I had a wrong signature inside the dedicated server.


I have ran DS Check signatures and it comes out without a single error.


What am I doing wrong?

Share this post

Link to post
Share on other sites
On 4/14/2017 at 11:36 PM, i eat yellow cake said:

Bump. Still getting the issue. Repacked and Resigned all the mods twice now and still no difference.

Did you make the Mods you are re-packing? What you are saying doesnt make any sense..download a Mod..put the Mod in the main Arma 3 folder on your server and copy the key from the Mod into the "keys" folder..I dont understand what or why you are trying to re-pack mods. Unless you made the Mods yourself you should not be re-packing and trying to sign them.



Share this post

Link to post
Share on other sites

why do folks constantly leap over obstacles instead of clearing the path and proving what they have done on each step ?



1) prove vanilla install

2) prove addons with original keys

3) then prove with your own keys


if you prove 1 and 2 then your also prove you know how to install and run mods (We dont know that we can only guess). 

Again lack of information, so lets assume you have done 1 and 2 without any issues. (If you havent go back and do that first before we can continue debugging)

Check every pbo has a corresponding bisign that is for the key you host in your keys folder

Delete your existing key

Delete all existing bisigns

Create a new bikey pair (with a date stamp in it, (eg MyBikey_20170421.bikey)

Resign all the addons

Check every addon has a corresponding bisign with the correct bikey name in it (EG THE DATE TAG)

Check the bisigns with the key verification tool that BI provides

If your still having problems, clear out the mod folders, add a few addons at a time until you find the culprit

 you can quickly figure out which mod pack or addon is the cause this way


Also what O/S. mod packs and binary are you loading (Or rather than answer that supply a full rpt file dumped into pastebin)



What tool are you using to sign the keys ?

and as Diesel stated why would you unpack the addons ?

Take us through the actions you are doing to try and achieve this


  • Like 1

Share this post

Link to post
Share on other sites

I'm not sure why it didnt work but I just reinstalled Arma 3 Tools and it worked fine. The reason why I was repacking and resigning was because I dont trust external keys and alot of the mods where not even signed in the first place.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now