Jump to content
Nowhere

Players respawn on bodies, host and AI respawn on respawn point

Recommended Posts

I just cannot get this to work.

 

I made a small mission with a single respawn point (respawn_west) that is set to BLUFOR

When I host in multiplayer, I respawn on it successfully. My AI groupmates respawn on it successfully. My friends who connect to my server respawn on their dead bodies.

 

I have gone through countless video tutorials and help threads that explain how to set up a proper spawn point, and followed them exactly.

I have made sure the multiplayer attributes of the mission are set to respawn on custom position.

I have made sure the only respawn point is the one I have named respawn_west.

I have created a description.ext file that says respawn = 3, when that didnt work I tried respawn = "Base", and then respawn = Base;

None of these worked.

 

This is getting to be frustrating because everything else works. I respawn as intended, friendly AI respawns as intended. But other players do not.

 

Does anybody have ANY idea of what I could be doing wrong?

 

Share this post


Link to post
Share on other sites

Have you tried it when your friends are on the server at the beginning ?

Or only if they jip into it ?

 

Share this post


Link to post
Share on other sites
1 hour ago, Nowhere said:

I just cannot get this to work.

 

I made a small mission with a single respawn point (respawn_west) that is set to BLUFOR

When I host in multiplayer, I respawn on it successfully. My AI groupmates respawn on it successfully. My friends who connect to my server respawn on their dead bodies.

 

I have gone through countless video tutorials and help threads that explain how to set up a proper spawn point, and followed them exactly.

I have made sure the multiplayer attributes of the mission are set to respawn on custom position.

I have made sure the only respawn point is the one I have named respawn_west.

I have created a description.ext file that says respawn = 3, when that didnt work I tried respawn = "Base", and then respawn = Base;

None of these worked.

 

This is getting to be frustrating because everything else works. I respawn as intended, friendly AI respawns as intended. But other players do not.

 

Does anybody have ANY idea of what I could be doing wrong?

 

 

In the eden editor, check the drop down menus for multiplayer Options. It should open a window scroll down to respawn and change it their :)

 

Cheers

Share this post


Link to post
Share on other sites
1 hour ago, Muecke said:

Have you tried it when your friends are on the server at the beginning ?

Or only if they jip into it ?

Other way around. We've only done this while everyone is on at the beginning.

 

31 minutes ago, BlacKnightBK said:

In the eden editor, check the drop down menus for multiplayer Options. It should open a window scroll down to respawn and change it their :)

 

Cheers

 

I said in the OP that the multiplayer attributes were set properly but it still isn't working. This is why I tried making a description.ext

Share this post


Link to post
Share on other sites

Are the slots of your friends also playable ? With AI groupmates ? If so do they respawn ?

 

Share this post


Link to post
Share on other sites
15 minutes ago, Nowhere said:

I said in the OP that the multiplayer attributes were set properly but it still isn't working. This is why I tried making a description.ext

 

I used to have that issue before as well, fixed it by going into my sqm file and deleting all the attributes that are related to respawning, deleted them from the description.ext as well then set them again in the Eden editor. This time no issues.

 

Cheers

Share this post


Link to post
Share on other sites
10 hours ago, Muecke said:

Are the slots of your friends also playable ? With AI groupmates ? If so do they respawn ?

 

All the BLUFOR slots are playable.

When either myself or an AI is in the slot, we respawn normally.

When another player is in the slot, they respawn on their body.

 

Share this post


Link to post
Share on other sites

Thats weird, cause I know the opposite case. Humans respawn but AI does not.

Can you upload your mission so maybe we can find any difference to it ?

 

Share this post


Link to post
Share on other sites
36 minutes ago, Nowhere said:

All the BLUFOR slots are playable.

When either myself or an AI is in the slot, we respawn normally.

When another player is in the slot, they respawn on their body.

 

 

Have you edited your sqm file??

Share this post


Link to post
Share on other sites
41 minutes ago, Muecke said:

Thats weird, cause I know the opposite case. Humans respawn but AI does not.

Can you upload your mission so maybe we can find any difference to it ?

 

mision here: http://steamcommunity.com/sharedfiles/filedetails/?id=899699705

 

22 minutes ago, BlacKnightBK said:

Have you edited your sqm file??

I don't know how.

Nevermind I had it binarized. The annoying thing is that I cannot test this unless someone connects.

Edited by Nowhere

Share this post


Link to post
Share on other sites

Okay I've just tested this by making an entirely new mission with the same kind of setup. Only one spawn point, had two other people connected to the server.

The exact same thing happened. I could respawn on the point. The AI could respawn on the point. The other players kept respawning on their own bodies.

We tried changing into different slots with the same result.

 

I'm beginning to think the respawn system just doesn't work. Every problem I've had so far has been related to respawning things.

Share this post


Link to post
Share on other sites

I can confirm this. The respawn system is fragile as shit.

In some missions, it works nicely, then in others (in my case a free for all DM) only the host can respawn. I did all editing inside Eden and the settings are all correct. It all works, but only for the host.

Share this post


Link to post
Share on other sites

I'm not sure the binarization would have caused this even if it was just the mission alone, because as far as I know all missions are binarized by default unless specified in the eden editor preferences. Never had this happen to me personally.

Share this post


Link to post
Share on other sites

Don't write anything in description.ext for respawn. Just use the editor multiplayers menu. The mix of two is weird.

Test furthermore:

- 2 respawn points;

- choice of the respawn position (editor menu).

Share this post


Link to post
Share on other sites

Hello guys!! So I have the same problem in multiplayer - me and AI spawns at the spawn point but not my mates, they spawn on their dead bodies even tho that action is not enabled. :( :( . Any easy fix for it now? 

Share this post


Link to post
Share on other sites
1 hour ago, 0neclickheadsh0t said:

Hello guys!! So I have the same problem in multiplayer - me and AI spawns at the spawn point but not my mates, they spawn on their dead bodies even tho that action is not enabled. 😞 😞. Any easy fix for it now? 

Enable the "select respawn position" option for choice.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×