Jump to content
LtBlackFire

Arma 3 64Bit Worst FPS than 32Bit

Recommended Posts

Evening,

 

As you know by now that 64bit is out, and i updated then launched the game with out any mods or Prams To be shocked of how low fps i get. In 32Bit i used to get about 40-50 FPS on daily bases but with 64Bit i get about 15-20 FPS LOW Settings. I Derangement the files and verified the integrate via steam and still no improvement, I Have no clue what is wrong here but if any one knows a fix or steps to take it would be appreciated

 

My Specs:

 

Windows 8.1 

GTX 850M

I7-4700HQ CPU 2.40GHz

12 GB RAM

64Bit Operating System x64-Based Processer

1TB Storage

 

Thank you!

Share this post


Link to post
Share on other sites

same issue here mate. go to C:\Users\*yourusername*\AppData\Local\Arma 3 and open up the latest Arma3_x64*blah blah blah* .RPT file see if the new version is detecting your video card. mine isn't. i have a GTX970m and it is not showing in the RPT file, its only showing the intel onboard graphics :(

let me know if its doing the same for you so we can narrow things down a bit. also it is worth mentioning if you launch with 32 bit whether it runs fine or not. for me it does. so it seems like they may have skipped out on a few graphics cards for compatability

 

Share this post


Link to post
Share on other sites

Try opening NVIDIA control panel and creating a new profile in the "manage 3d settings" tab  for ARMA3_X64.exe.

Worked for me and I had exactly what you guys are describing.

  • Like 4

Share this post


Link to post
Share on other sites

hangon mate, i think you just nailed it. Well done! and thankyou sooooooo much! i have been fighting this issue all morning!

Share this post


Link to post
Share on other sites
6 minutes ago, SonterAUS said:

hangon mate, i think you just nailed it. Well done! and thankyou sooooooo much! i have been fighting this issue all morning!

No drama.

Share this post


Link to post
Share on other sites

Got same problem but my cpu doesn't have an integrated gpu so.. :dontgetit: Btw I'm testing with YAAB with same settings, tried different startup parameters and allocator ( without mods ofc ) and always less fps than 32

Share this post


Link to post
Share on other sites
6 minutes ago, ramius86 said:

Got same problem but my cpu doesn't have an integrated gpu so.. :dontgetit: Btw I'm testing with YAAB with same settings, tried different startup parameters and allocator ( without mods ofc ) and always less fps than 32

About Yaab benchmark I think it might be a fault with the mission since the mission is 32 bit based. Don't know if you saw it but the smoke  disappear running with 64 bit exe.

Share this post


Link to post
Share on other sites
Just now, nikiforos said:

About Yaab benchmark I think it might be a fault with the mission since the mission is 32 bit based. Don't know if you saw it but the smokes disappear running with 64 bit exe.

Didn't noticed, btw I got also less fps in start menu 

Share this post


Link to post
Share on other sites
14 minutes ago, nikiforos said:

About Yaab benchmark I think it might be a fault with the mission since the mission is 32 bit based. Don't know if you saw it but the smoke  disappear running with 64 bit exe.

A mission can't be "32 bit based" really. :) The latest version was even created with the 64-bit executable.

And the smoke has been disappearing in many scenarios on the 64bit. I think there's a ticket for it on the tracker somewhere.

Other than that, I have no idea what could be the problem here. :(

Share this post


Link to post
Share on other sites

I have tested all that been said here, Arma 3 64x in the control panel, updated my driver and verified the files again but nope.

Share this post


Link to post
Share on other sites

Hi All. Today I have update 1.68/

For me, the transition to the 64-bit version has excellent consequences.

I noticed that the performance was better!  As seems to me, the FPS has increased in the range of 10-20 frames. In the end, on average now I get within a - 75-50 FPS. Before was within a 50-35. But this numbers,  if not many units in the game!

Overall, the picture is more smooth and enjoyable/

 

my PC:

 

Windows 7 Corporative, Intel Core i7-3930k (C2) 3.2 GHz
ASUS P9X79 PRO Socket 2011, X79
16Gb (4x4Gb) 2400MHz Corsair Vengeance
WDC WD2003FZEX-00Z4SAO ATA-Device
ASUS GTX-670 2048Mb

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

I have the same issues as LtBlackFire! And I have almost the same setup.

I have to research a little more to solve the problem.... in the 32 bit version works way faster!

Share this post


Link to post
Share on other sites
6 hours ago, CaneToad said:

Try opening NVIDIA control panel and creating a new profile in the "manage 3d settings" tab  for ARMA3_X64.exe.

Worked for me and I had exactly what you guys are describing.

Thanks man. Hadn't realised there was a new executable, and my Nvidia Control Panel was only showing the Arma3.exe. Manual add of the 64bit version and the issue is solved.

Share this post


Link to post
Share on other sites
10 hours ago, CaneToad said:

Try opening NVIDIA control panel and creating a new profile in the "manage 3d settings" tab  for ARMA3_X64.exe.

Worked for me and I had exactly what you guys are describing.

This helped me a lot and actually fixed the issue. Thanks buddy.

Share this post


Link to post
Share on other sites

Nvidia don't see arma3_x64.exe and if you add it manually it will not let you to configure it

Share this post


Link to post
Share on other sites

Just played 1 Hr of KOTH (US #1) with 110 peopple and got better FPS. Before 22-26 inside cities now it stays mostly 30 or higher  

Share this post


Link to post
Share on other sites
21 hours ago, CaneToad said:

Try opening NVIDIA control panel and creating a new profile in the "manage 3d settings" tab  for ARMA3_X64.exe.

Worked for me and I had exactly what you guys are describing.

Thank you, This is the fix... I did managed to add arma 3 x64 to the control panal but i forgot to set it on GTX 850M process, it was running with the intel process. 

 

 

Share this post


Link to post
Share on other sites

I have had this exact issue as I pretty much saw coming went from 40 to 50 frames on 32 bit to 15 on 64..........nothing seems to happen as its supposed to on my computer.....idk what info I should give but some of my specs are below. Note I have tried the control panel fix and the validating files and nothings worked...using this info would someone be able to guide me through the best parameters in the launcher that I should maybe be trying? I had to use JE malloc for 32 bit and it smoothed things right out for me however ive been told to not us any mem alloc for 64 bit so for this reason ive left all of my parameters default until I get answers on how I should set it up....theres not exactly a guide on this....or at least I haven't found one

 

Operating System: Windows 10 Home 64-bit (10.0, Build 14393) (14393.rs1_release_inmarket.170303-1614)

System Manufacturer: Hewlett-Packard
System Model: HP ENVY 17 Notebook PC

BIOS: F.43
Processor: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz (4 CPUs), ~2.6GHz
Memory: 12288MB RAM
Available OS Memory: 12218MB RAM

Card name: Intel(R) HD Graphics Family
Manufacturer: Intel Corporation

Chip type: Intel(R) HD Graphics Family
DAC type: Internal

Display Memory: 2160 MB

Dedicated Memory: 112 MB
Shared Memory: 2048 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)

 

Card name: NVIDIA GeForce 840M
Manufacturer: NVIDIA
Chip type: GeForce 840M
DAC type: Integrated RAMDAC
Device Type: Render-Only Device

Display Memory: 8129 MB

Dedicated Memory: 2020 MB
Shared Memory: 6109 MB

 

Share this post


Link to post
Share on other sites
On ‎3‎/‎17‎/‎2017 at 3:25 AM, CaneToad said:

Try opening NVIDIA control panel and creating a new profile in the "manage 3d settings" tab  for ARMA3_X64.exe.

Worked for me and I had exactly what you guys are describing.

How do I make a new profile??? All I see is a dropdown for which graphics its using and granted it was using integrated so I changed it to the high performance NVidia 840m however it fixed nothing

Share this post


Link to post
Share on other sites
2 hours ago, xCloudy said:

How do I make a new profile??? All I see is a dropdown for which graphics its using and granted it was using integrated so I changed it to the high performance NVidia 840m however it fixed nothing

Go to "Manage 3D settings"

select "Program settings"
from there it gives you a list of programs you wish to "customise"

 

browse to the Arma 3 64 bit exe and "add"

Share this post


Link to post
Share on other sites
Quote

For me, the transition to the 64-bit version has excellent consequences.

I noticed that the performance was better!  As seems to me, the FPS has increased in the range of 10-20 frames. In the end, on average now I get within a - 75-50 FPS. Before was within a 50-35. But this numbers,  if not many units in the game!

Overall, the picture is more smooth and enjoyable/

 

ditto

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×