Jump to content
Wyqer

[MP][CTI-COOP] Liberation (continued)

Recommended Posts

23 hours ago, Wyqer said:

@sturmfalkerda

ACE doesn't breaks the kill event handler in KP Liberation. It works fine on my end, also on KP Ranks. Maybe you're running and old version or a derivative which is based on an old version.

https://github.com/KillahPotatoes/KP-Liberation/commit/88fa4c143dc3e3a17f58fe87d96e6abfee6a3c53#diff-4c37f5c8d1d53c6d87f6425d485829dd

Just double checked, yeah. It's running a a derivative which is a mix between new and old. I've checked the way the files are called and double checked the merge of the ACE fix...

Would R3F_Log, specifically

player addEventHandler ["HandleDamage", {0}];
//and
_x setVariable ["R3F_LOG_idx_EH_HandleDamage", _x addEventHandler ["HandleDamage", {_this call R3F_LOG_FNCT_EH_HandleDamage}]];

Those are the only two lines of code across the project that I can think of that would cause it to break. I think the second is primarily for boxes, but I don't know.

 

I'll move back to the actual KP Liberation and import any changes I need selectively to avoid this.

Share this post


Link to post
Share on other sites

I haven't used R3F, but it would suprise me, if something in a "logistic mod" affects the kill event handler. Also even if it would add another kill event handler, it won't interfere the liberation one, as they're called independently from each other.

So you should maybe head to the creator of the derivative and inform him about the issue in his version.

Share this post


Link to post
Share on other sites

Ayo, loving the updates! Quick question, is there a way to transfer Liberation progress/saves from the server I host ingame (with the host server button) to a dedicated server? Thanks!!

Share this post


Link to post
Share on other sites
3 hours ago, Not_Oliver said:

Ayo, loving the updates! Quick question, is there a way to transfer Liberation progress/saves from the server I host ingame (with the host server button) to a dedicated server? Thanks!!

documents/arma3 other profiles/yourprofilename/yourprofilename.vars.arma3profile is the file you are looking for, just copy it to server profile folder and rename it so it will be yourserverprofilename.vars.arma3profile

Share this post


Link to post
Share on other sites

I'm scripting some extra stuff for this, but haven't been able to decipher the resource system. How can I reduce the amount of resources the players have? For example, -100 supplies.

Share this post


Link to post
Share on other sites

What’s there to decipher?

Have a look to the do_build.sqf for example. Remove a crate from a storage and delete it.

Share this post


Link to post
Share on other sites

For some reason my custom infantry squad are all spawning with parachutes, which is preventing the AA and AT guys from spawning with their ammo. What decides whether a squad spawns with chutes and who doesn't?
I'm using the latest hotfix version.

Share this post


Link to post
Share on other sites

dear @Wyqer 

Do you have any good idea for a build something with "init" code ?

like F/A-181 which already wing folded.

I await your reply.

Share this post


Link to post
Share on other sites

Unfortunately not. In previous versions I've had no problems with custom squads, it was only updating to 0.963a-hotfix3 that's caused the issue. Here's the bit of code from my blufor/custom.sqf

Spoiler

// Infantry squad.
blufor_squad_inf = [
    "CUP_B_US_Soldier_SL",
    "CUP_B_US_Soldier_TL",
    "CUP_B_US_Soldier_TL",
    "CUP_B_US_Soldier_AT",
    "CUP_B_US_Soldier_AA",
    "CUP_B_US_Soldier_AR",
    "CUP_B_US_Soldier_GL",
    "CUP_B_US_Medic",
    "CUP_B_US_Engineer"
];

// Paratroopers squad.
blufor_squad_para = [
    "CUP_B_US_Soldier_SL",
    "CUP_B_US_Soldier_TL",
    "CUP_B_US_Soldier_TL",
    "CUP_B_US_Soldier_AT",
    "CUP_B_US_Soldier_AA",
    "CUP_B_US_Soldier_AR",
    "CUP_B_US_Soldier_GL",
    "CUP_B_US_Medic",
    "CUP_B_US_Engineer"


Is there any other reason the game might be confusing the two squads?
I also edited the Init_Presets.sqf to change squad names, some stuff under sector so that my custom squad is spawned during attacks and kp_liberation_config.sqf to allow some vehicles to carry crates but I don;t think any of that is relevant

EDIT; It seems the code did not like that fact that the two squads had the exact same make up. Changing the paratrooper squad composition fixed the problem.

 

Share this post


Link to post
Share on other sites

Hello,

not sure if I could post here, as I am playing KP Liberation Tanoa 0.963a in SP, not in MP....

However, if you could reply I would be glad...

I have a simple problem, as I need to build a Supply production facility, and even if I have plenty of resources available to build it ( Supply 100, Ammo 490, Fuel 500 ) that appears in the resource view, I always get the message that I have not enough resources to build it...and so I do not understand why I get this reply... Do I need to bring the resources there...?

 

In any case, this is a great scenario with a lot of good features... thanks...

 

Used Mods are :

 

ace
Advanced AI Command
Advanced Rappelling,
Advanced Sling Loading
Advanced Towing
Advanced Urban Rappelling
Blastcore
C2 - Command & Control
CBA_A3
Enhanced Movement
JSRS SOUNDMOD
RDS Civilian Pack
Unit Voiceovers
Vcom AI V3.0
WW AIMenu

 

Thanks a lot for any support

 

Alex

Share this post


Link to post
Share on other sites

Thanks Wyqer...

I already read such information, but, it seems I missed the last line... :(

Sorry...

Thanks a lot.

Share this post


Link to post
Share on other sites

Hey, 

 

I have 2 questions : 

 

When i reboot my server, and i load my mission, the buildings declare themselves from their original position, do you have an idea ?

 

Is it normal that I have these same duplicate spawn buildings during the reboot ?

Share this post


Link to post
Share on other sites
10 hours ago, Sayker said:

the buildings declare themselves from their original position

I don't know what you're trying to say.

 

If you place down buildings/assets, which you can also build in the game itself, via editing the missionfile in the editor it'll be saved and loaded. But also due to the fact that it's placed in the editor at that place, it'll also load it from the mission.sqm. That way the buildings will get duplicated on each new mission load.

Share this post


Link to post
Share on other sites

yes they shift, when I use the build feature in play to build front posts, some of the objects are dacalized from their position of the last backup.

 

Concerning the problem of duplication, I do not know what to do because certain object posed in publisher is double and other not. Despite their suppression at restart and / or a total reboot of the mission.

Share this post


Link to post
Share on other sites

If I understand your issue correctly (I've still a problem to really understand your text), you experience a misplacement of buildings you've built during the game after a save/load.

If that's your issue, I'm assuming you're not using the latest stable release (0.963a). So change to the actual version and the above problem is gone.

Share this post


Link to post
Share on other sites

Hello,

playing in SP, so I am not sure this affects also MP, however :

 

- BUILD menu, it appears that the remaining resosurces level is not evaluated/checkd again each time I try to build something. e.g. I start to buil some soldiers withn enough resources, and even if my resources drop and are under the minimum level, or even 0, I could continue to build other soldiers, it seems at least if I do not change build Panel or close the build...

 

- SAVEGAME, it appears like the minutes of the Time of Day are not saved, only the Hours, so that, if I stop playing a mission at time of day 21:35, when I restart the Time of Day will be 21:00. This is quite annoying because to have time to go ahead between saves, I always need to wait to exit the game till the start of the next hour...

 

And of course, thanks for the great mission...

 

 

Share this post


Link to post
Share on other sites

Never experienced a "endless build" possibility. But I've also never really played with AI, so it could be that I just never recognized it. Guess you're clicking maybe very fast on the build button?

In general I could imagine that you build faster than your machine can handle the resource costs.

 

The "only hour" saving is how it's implemented in the old framework, yes. In 0.97 with the new framework it saves also the minutes.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×