Jump to content

Recommended Posts

I just loaded up today's version and confirmed the mod works fine.  Either you game is broke or you have a mod conflict somewhere.  That's all I can do to troubleshoot.  Try it without any other mods.

Share this post


Link to post
Share on other sites

Hi Hcpookie. I have models for aliens that i paid money for. I would let you use them in this mod if you want. I also have the full LV426 map. and a drop ship.

 

 


 


 


 

 

I also have a pro 3D modeler who i pay to make me models and UVmaps. I am also a texture artist. We could if you want go full on with the this mod. give it aliens and full Marines Vehicles.

Share this post


Link to post
Share on other sites

Nice looking model. 

 

I offered similar but got no response from him. Be nice to see this in game. I know phantom is really looking to do an aliens mission too. I have made a version of lv426 and have models for hadleys hope that just need porting to the game. 

 

Pm me if you want to talk more.

Share this post


Link to post
Share on other sites

I have a bug on the Cheyenne  where I cannot use the cannon the ammo counter just reads zero and the weapon name is called Cannon caseless 30mm. Other than that sweet mod would love to see a infantry carrier version similar to the one in AVP 2010 with drop ship like seating. https://m.youtube.com/watch?v=QYHR8VhbpxU

Share this post


Link to post
Share on other sites

Can you reupload this mod to steam workshop and fix the weapons that dosent show up in the virtual arsenal? The smartgun turns into a mk200 when you try to edit the heavy gunners loadout.

Share this post


Link to post
Share on other sites

I don't know if you've thought about this, you probably have, but you could always ask the guy behind the raptors mod (originally mr ruppertle I believe) and ask for the animation skeleton/rig. That way you would "only" replace the 3D model of the raptors with an alien model. The same was done for Operation Flashpoint back in the day I believe. They would act like raptors, jump around and stuff, pin people to the ground, but no wall-climbing, tail-impaling etc.


Yes, old Alien fan here :)

Share this post


Link to post
Share on other sites
1 hour ago, spookygnu said:

I already asked that question and the answer was no it isn't possible

Without model of a predator, it is more similar to a new plot: "Ripley in the Jurassic Park":(

Share this post


Link to post
Share on other sites

Think the best way would be make it from scratch. But who is willing to do it? Not me. Sorry!

Share this post


Link to post
Share on other sites

I hope that there will be someone who who is familiar with this tool and will help with creation of Aliens  the personality.

Share this post


Link to post
Share on other sites

I actually found a free 3D model and thought I'd have a look. 

 

Initial first look, nice textures, fully built model very representative of the alien. Not noticed a second jaw though. 

 

I use maya to build things but have yet to learn rigging and animation for it. Just means sifting through YouTube for the tuts. 

 

I know blender has an arma toolkit by alwarren but it would mean learning blender aswell, which I don't have time for ATM.  

 

Im not making any promises. I already passed on my aliens source folders to phantom (baphomet) to continue the work. Reason being my new job takes a lot of my free time away. So idk what's gunna happen regarding me getting anything done.

 

spook

 

  • Like 2

Share this post


Link to post
Share on other sites
On 8/16/2017 at 3:18 PM, God_Emperor_Trump_1488 said:

I have a bug on the Cheyenne  where I cannot use the cannon the ammo counter just reads zero and the weapon name is called Cannon caseless 30mm.

 

This is confirmed.  The recent patches apparently broke the inheritance for this weapon.

 

 

All the other "it doesn't work" errors cannot be reproduced.  If there is a bug please describe in detail how it happens because "it don't work" won't be fixed.  Otherwise, make sure you have the latest Arma update.  If you don't, then stop using pirated software ;)

 

 

Regarding the model updates - I'm not against combining things however this started as an import of Vilas' models.  The sounds are really the big problem right now.  When I get the time (around the holidays?  next year?) I want to make them better.

 

 

  • Like 2

Share this post


Link to post
Share on other sites

I also get the error "cannot find base class burst" for me the full error is bin/config.bin/CfgWeapons/UDL4_CMFlareLauncher/UDL4_CMFlareLauncher_Burst/: Cannot find base class 'Burst'. It clearly has something to do with the UDL4 Dropship but I'm not sure what the problem is, when I disable the mod everything works fine like normal. I have the most update version of Arma currently available I just downloaded an 8 gig patch on Thursday for the Laws of War dlc so I know I'm up to date. 

Share this post


Link to post
Share on other sites

What version is displayed when Arma loads?

 

Are there any other mods running?  If so does the error happen with only the Aliens mod?

Share this post


Link to post
Share on other sites

There are other mods loaded and I have confirmed that it is a mod conflict now I just gotta go through all 798 mods that I have loaded and see which one is causing the conflict. I was able to load the mod up just fine with no other mods loaded but if I load it up with my current mod list it gives me that error, now its just a matter of patience and going through the entire list. 

Share this post


Link to post
Share on other sites

Will you ever come back to this Mod, I have recently learned how to do Texture work so if i can help in any way i will.

  • Like 1

Share this post


Link to post
Share on other sites
On 8/16/2017 at 11:18 PM, God_Emperor_Trump_1488 said:

I have a bug on the Cheyenne

 

So did Ferro.

 

Sorry.

Share this post


Link to post
Share on other sites

Soon we might be getting a legit xenomorph mod by Maxjoiner, combined with this addon we have a solid Aliens experience.

 

I'm hoping we can revisit and polish this mod, mainly the weapon sounds. The smart gun and pulse rifle sound a bit too over overbearing. There is no reload sound effect for the pulse rifle. I've run into an error with the dropship cargo ramp option. Overall the addon is great I love the textures and models, all the important things work. But dem weapon sound effects, no bueno. I'd be more than happy to create different sound effects for the weapons if you'd like, just give me the word. 

 

Lastly, would it also be possible to add scopes and flashlight attachments to the weapons? The smart gun doesn't show up in the virtual arsenal btw. 

  • Like 2

Share this post


Link to post
Share on other sites

Good news everyone - Vilas is making an updated APC model!  I am addressing known bugs, popup errors, etc. to ensure the mod functions correctly in SP and MP.  I am revising the flight profile and weapon configuration on the dropship to make use of the Jets DLC Pylons feature, meaning you can adjust the weapon loadouts.  Work so far...

 

UDL-loadout.jpg

 

I am also updating the weapons to use the Components seeker heads vs. inhertance from defaults.  I am also attempting to redo the texture mapping to enable camo selections on the dropship instead of the default "basic green".  No promises on that yet... just starting to look into that.  Since I am terrible at texturing we'll just have to see how it plays out.

 

Apologies for the delays in updates but Real Life has been keeping me out of the loop.  Vilas and I are coordinating updates and attempting to add some new functionality to the mod.

  • Like 2

Share this post


Link to post
Share on other sites

More updates.  The dropship flies correctly once more!  I am using the VTOL class, so it has to have a running start before liftoff... because the BIS VTOL configuration is actually "STOL" however it takes off correctly now.  I would like to figure out how to make it "true" VTOL so it can be a completely vertical liftoff... without making it a helicopter.  I tried messing with the Envelope settings but nothing seems to make it want to jump straight up.  Always needs about a hundred meters to roll along before it can lift off the ground.  Maybe it SHOULD be a helicopter class...

 

And more good news... while Vilas is ironing out some of the other issues, I managed to figure out how to texture paint in Blender!  So we have this... these two patterns are from the "colonial marines technical manual" and aren't too bad in consideration of the fact this was a one-time pass... I may add more camo patterns for some variety:

dropshipcamotest1.jpg    dropshipcamotest2.jpg

 

I have also added user-selectable logos separate from the camo selections.  One can now choose the "bugstomper", "smartass", or other logos.  There are 9 in all, based on the movie and technical manual data sets.  I couldn't find any others to add (yet).  More could be added in the future based on feedback.  You'll see in those photos above the "Ricki's Raiders" and "Loose Moose" insignias (by the cockpits).

 

Edit to add - the pulse rifle sounds have been tweaked some too.  We think that MAYBE it sounds closer to what it should be.  That is still open to debate... willing to make more changes as necessary.

  • Like 2

Share this post


Link to post
Share on other sites

HELP - I would like to have someone smarter than myself look at the sound shader config for the pulse rifle.  The question is, how can we make it so the "only" sound made is the pulse rifle sound itself?  Here is the current config:

 

Spoiler

			class BaseSoundModeType {
//				closure1[] = {"A3\Sounds_F\arsenal\weapons\Rifles\MX\Closure_Mx_01", 0.316228, 1, 10};
//				closure2[] = {"A3\Sounds_F\arsenal\weapons\Rifles\MX\Closure_Mx_02", 0.316228, 1.1, 10};
//				soundClosure[] = {"closure1", 0.5, "closure2", 0.5};
				soundSet = "";
			};
			class StandardSound: BaseSoundModeType {
				begin1[] = {"\vil_apc\wpn\sounds\m41a_1.ogg",5.162341,1, 1800};
				begin2[] = {"\vil_apc\wpn\sounds\m41a_2.ogg",5.162341,1, 1800};
				begin3[] = {"\vil_apc\wpn\sounds\m41a_3.ogg",5.162341,1, 1800};
				begin4[] = {"\vil_apc\wpn\sounds\m41a_4.ogg",5.162341,1, 1800};
				begin5[] = {"\vil_apc\wpn\sounds\m41a_5.ogg",5.162341,1, 1800};
				begin6[] = {"\vil_apc\wpn\sounds\m41a_6.ogg",5.162341,1, 1800};
				soundBegin[] = {"begin1",0.16665,"begin2",0.16665,"begin3",0.16665,"begin4",0.16665,"begin5",0.16665,"begin6",0.16665};
				class SoundTails {
					class TailInterior {
						sound[] = {"A3\Sounds_F\arsenal\weapons\Rifles\MX\mx_tail_interior", 1.58489, 1, 1800};
						frequency = 1;
						volume = "interior";
					};
					class TailTrees {
						sound[] = {"A3\Sounds_F\arsenal\weapons\Rifles\MX\mx_tail_trees", 1, 1, 1800};
						frequency = 1;
						volume = "(1-interior/1.4)*trees";
					};
					class TailForest {
						sound[] = {"A3\Sounds_F\arsenal\weapons\Rifles\MX\mx_tail_forest", 1, 1, 1800};
						frequency = 1;
						volume = "(1-interior/1.4)*forest";
					};
					class TailMeadows {
						sound[] = {"A3\Sounds_F\arsenal\weapons\Rifles\MX\mx_tail_meadows", 1, 1, 1800};
						frequency = 1;
						volume = "(1-interior/1.4)*(meadows/2 max sea/2)";
					};
					class TailHouses {
						sound[] = {"A3\Sounds_F\arsenal\weapons\Rifles\MX\mx_tail_houses", 1, 1, 1800};
						frequency = 1;
						volume = "(1-interior/1.4)*houses";
					};
				};
			};

 

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×