Jump to content

Recommended Posts

Greetings. I'm very new to modding, but recently I've started on adding vehicles, moving stuff around and etc.

I've stumbled onto a problem with the Y-32 Xi'an Infantry Transport VTOL. 
I downloaded another mod which has successfully moved a vehicle from Independent to Blufor AND has a texture applied to it when you spawn it in.
What I'm trying to do is basically the same. I want to copy the Y-32, put it into Bluefor and have a custom texture go on it. 

Inside my mod folder:
0c651122b5ed9b38d5cc31404539982f.png

Inside my mod/data folder:
6ea6fceb168bc07f1c9f274e7f0482bc.png

config.cpp script:

#define true 1
#define false 0

class CfgPatches 
{
	class RTAF_Vehicle
	{
		units[] = {RTAF_Vehicle};
		weapons[] = {};
		requiredAddons[] = {};
	};
};
class CfgEditorCategories {
	class RTAF_Class {
		displayName = "Shield";
	};
};
class cfgVehicles 
{
	class O_T_VTOL_02_infantry_F
	{
		scope = 2;
		displayName = "Shield Y-32";
		faction = "BLU_F";
		vehicleClass = "Air";
		editorCategory = RTAF_Class;
		Side = 1;
		crew = "B_crew_f";
		hiddenSelections[] = {"camo"};
		hiddenSelectionsTextures[] = {"\Y32_VTOL\data\vtol_01_ext01_shield_co.paa","\Y32_VTOL\data\vtol_01_ext02_shield_co.paa","\Y32_VTOL\data\vtol_01_ext03_shield_co.paa","\Y32_VTOL\data\vtol_01_ext04_shield_co.paa"};
		
		class Library 
		{
			libTextDesc = "BWS";
		};
	};
};

If anyone is able to help me out it would be very appreciated. Like i said i'm quite new to this and I've been trying for quite some time to fix it.
Thank you in advance! 

Share this post


Link to post
Share on other sites

I've managed to fix the faction issue! It's now on blufor, but the texture does not want to apply on it :/

This is how it looks like:
0ff3c4955cc904ac96282e47d471cfbd.jpg

This is how it's supposed to look like:
a78444a273338f59443902c14d256b85.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×