Jump to content
Sign in to follow this  
mindstorm

Issue with geometry and rvmat

Recommended Posts

Hey guys,

 

I've got 2 separate issues with a model of mine. I made a ball and I basically want it to roll down a hill with Physx. This all works, partly. This is the p3d with textures:

https://puu.sh/sPkxb/a71ff2427e.zip

 

config:

	class ref_ball_big : Land_DuctTape_F
	{
		author = "";
		simulation="thing";
		scope = 2;
		displayName = "Big ball";
		vehicleClass = "r_ent";
		hiddenSelections[] = {""};
		hiddenSelectionsTextures[] = {"\ref_losttemple\ballbig\ballbig_co.paa"};
		model = "ref_losttemple\ballbig\ballbig";
		armor = 100;
		destrType = "DestructMan";
		mass = 500;
	};

 

 

I'm new at this, and I've been reading up a lot and making progress. 

 

First issue:

Only after I enabled the physx (setVelocity) the ball collides with players/objects. As soon as it comes to a stop it doesn't have any form of collision. 

I have a Geometry with Component01 and mass. It's fully closed. What am I missing? 

Fixed this issue. Apparently I didn't build the last pbo with the component. 

 

Second issue:

I'm completely new to texturing. Somethings wrong with the texture of the ball, some parts aren't colored correctly and appear to 'shine through'. This is probably because I messed up either the rvmat or the ballbig_nohq.paa. The mapping and everything is correct (done with blender), it's just that somehow the colors are a bit off.Image of the ball.

 

What I did now is just save the ballbig_co.paa and nohq.paa, and I'm guessing that is wrong. I don't really need the ball to look fancy so I don't mind the ball having no structure at all (from my understand that's what the nohq does.

What would be the best approach to this? I've tried looking up what the different stages mean, but I'm having a hard time finding any good documentation on it. The arma wiki is a bit vague on this.

Rvmat (also in the zip):

Spoiler

ambient[]={1,1,1,1};
diffuse[]={1,1,1,1};
forcedDiffuse[]={0,0,0,0};
emmisive[]={0,0,0,1};
specular[]={1,1,1,1};
specularPower=100;
PixelShaderID="Super";
VertexShaderID="Super";
class Stage1
{
	texture="ref_losttemple\ballbig\ballbig_nohq.paa";
	uvSource="tex";
	class uvTransform
	{
		aside[]={1,0,0};
		up[]={0,1,0};
		dir[]={0,0,0};
		pos[]={0,0,0};
	};
};
class Stage2
{
	texture="#(argb,8,8,3)color(0.5,0.5,0.5,1,DT)";
	uvSource="tex";
	class uvTransform
	{
		aside[]={1,0,0};
		up[]={0,1,0};
		dir[]={0,0,0};
		pos[]={0,0,0};
	};
};
class Stage3
{
	texture="#(argb,8,8,3)color(0,0,0,0,MC)";
	uvSource="tex";
	class uvTransform
	{
		aside[]={1,0,0};
		up[]={0,1,0};
		dir[]={0,0,0};
		pos[]={0,0,0};
	};
};
class Stage4
{
	texture = "#(argb,8,8,3)color(1,1,1,1,AS)";
	uvSource = "tex";
	class uvTransform
	{
		aside[] = {1,0,0};
		up[] = {0,1,0};
		dir[] = {0,0,0};
		pos[] = {0,0,0};
	};
};
class Stage5
{
	texture="ref_losttemple\ballbig\ballbig_smdi.paa";
	uvSource="tex";
	class uvTransform
	{
		aside[]={1,0,0};
		up[]={0,1,0};
		dir[]={0,0,0};
		pos[]={0,0,0};
	};
};
class Stage6
{
	texture="#(ai,64,64,1)fresnel(1,0.7)";
	uvSource="none";
};
class Stage7
{
	texture="a3\data_f\env_co.paa";
	uvSource="tex";
	class uvTransform
	{
		aside[]={1,0,0};
		up[]={0,1,0};
		dir[]={0,0,0};
		pos[]={0,0,0};
	};
};

 

 

Any help would be greatly appreciated! 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×