Jump to content
M1ke_SK

[RELEASE] Simple Bomb Defuse [script]

Recommended Posts

It's still not working on dedicated server with ACE3 and CBA. I'm trying the test mission, but nothing happens when i try the ACE interaction key.

Any solutions?

 

Thanks

Share this post


Link to post
Share on other sites
On 9/26/2021 at 12:22 PM, [TS]Djmitri said:

It's still not working on dedicated server with ACE3 and CBA. I'm trying the test mission, but nothing happens when i try the ACE interaction key.

Any solutions?

 

Thanks

you can disable ace3 interaction with parameter, addAction will be used. I have update ready, just testing it on dedicated server next week

Share this post


Link to post
Share on other sites
On 9/30/2021 at 10:40 AM, M1ke_SK said:

you can disable ace3 interaction with parameter, addAction will be used. I have update ready, just testing it on dedicated server next week

Damn, 8 years in this game and I somehow missed this awesome script. 

Any success testing on Dedicated?
Great job!

Share this post


Link to post
Share on other sites
On 10/12/2021 at 9:42 PM, omri2050 said:

Damn, 8 years in this game and I somehow missed this awesome script. 

Any success testing on Dedicated?
Great job!


We've used it on a dedicated server a couple of times with no issues 

  • Like 1

Share this post


Link to post
Share on other sites
On 10/14/2021 at 11:02 PM, JD Wang said:


We've used it on a dedicated server a couple of times with no issues 

 

Are you using ACE 3 interaction?

Share this post


Link to post
Share on other sites

It's been a while, but yeah pretty sure we used ACE 

Share this post


Link to post
Share on other sites
On 10/27/2021 at 5:33 AM, JD Wang said:

It's been a while, but yeah pretty sure we used ACE 

 

I have tested on my Dedicated server, the Test mission inside the script and i have no interaction with ACE 3... 😥

Share this post


Link to post
Share on other sites
6 hours ago, [TS]Djmitri said:

 

I have tested on my Dedicated server, the Test mission inside the script and i have no interaction with ACE 3... 😥

 

I mentioned this already. I have a fix ready, but testing on dedicated server. Just have a patience.

Share this post


Link to post
Share on other sites
On 11/1/2021 at 6:23 PM, M1ke_SK said:

 

I mentioned this already. I have a fix ready, but testing on dedicated server. Just have a patience.

 

Sure, i hope that the fix it's working. 😎

Share this post


Link to post
Share on other sites

Hey, I tried implementing your script but it throws several error messages like

"fn_getCondition.sqf, Line 10 Type String, expected Bool"

 

or 

 

"fn_soundLoop.sqf Line 4 Type String, expected Bool"

 

Any chance you could fix those errors?

Share this post


Link to post
Share on other sites

@NeisAEL In what situations (mods) are you getting these errors? And with what line are you calling bomb.sqf? I've just tested the newest version of the test mission in local hosted multiplayer. I don't get your errors. 

On 4/18/2022 at 2:22 PM, NeisAEL said:

"fn_getCondition.sqf, Line 10 Type String, expected Bool"

 

or 

 

"fn_soundLoop.sqf Line 4 Type String, expected Bool"


These two errors refer to parameters in bomb.sqf; specifically _object and _needKit . Do you also get it when you use the default init line on a default (metal barrel) object:

null = [this, 10, true, false] execVM "bomb\bomb.sqf";

?
=====

I also however, have a minor bug to report. 
I don't run ACE, and I have tried setting the _disableAce3 value to both true and false. But the game will still give this error:

Error in expression <[_unit] call ace_common_fnc_isEngineer

if( _isEOD || _isEngineer ) then 
{
_isE>
Error position: <if( _isEOD || _isEngineer ) then 
{
_isE>

Error Missing ;

File (...)\mikehudak-a3_bomb.vr\bomb\functions\fn_isExpert.sqf..., line 18 

-every time the mission is (re)loaded in editor or previewed, and ignore the _expertMultiplier value, unless I comment out the ACE part of fn_isExpert.sqf (lines 13-18). It's not strictly game breaking. But it is tedious for non-ACE users.  

Share this post


Link to post
Share on other sites

Thanks M1ke_SK, fun mod.

 

Anyone have a idea on how to set off a trigger if you successfully defuse the bomb?

Want to trigger the next task for the mission.

 

Edit; found this in a earlier thread which works,   bar1_1 being the bomb

! (bar1_1 getVariable ["a3f_bomb_active", true])

 

 

Share this post


Link to post
Share on other sites

 

I fixed the sound and ace interaction for dedicated servers...

first the sound, just put a trigger under the metal barrel and rename the metal barrel to bomb1

ACTIVATION: ANYPLAYER
ACTIVATION TYPE: PRESENT
REPEATABLE: UNCHECK
SERVERONLY: UNCHECK

IN CONDITION: call{player in thisList}

ON ACTIVATION:

if (!isDedicated) then {[] spawn { while { alive bomb1 && bomb1 getVariable ["a3f_bomb_active", true] } do 
{
    playSound "beep_strobe";    sleep 2;
}};};

now the ace interaction:

on line 4 of the bomb.sqf file change to if(isDedicated) exitWith {};

 

 

  • Like 3

Share this post


Link to post
Share on other sites
On 10/15/2022 at 4:45 PM, Bruno 512 said:

 

I fixed the sound and ace interaction for dedicated servers...

 

Hey there, I tried your solution. For some reason, the sound trigger avenue didn't work but it did get the ACE interaction to work. So thank you for that!
 

The issue I'm facing now on Dedicated is that the spawning of the explosion doesn't do any damage. It explodes and the barrel disappears, but players and objects are entirely unharmed (regardless of munition). This isn't the case on Singleplayer or Local MP. I don't think these are related, but maybe you've come across it?

Share this post


Link to post
Share on other sites
15 hours ago, Nillers said:

 

Hey there, I tried your solution. For some reason, the sound trigger avenue didn't work but it did get the ACE interaction to work. So thank you for that!
 

The issue I'm facing now on Dedicated is that the spawning of the explosion doesn't do any damage. It explodes and the barrel disappears, but players and objects are entirely unharmed (regardless of munition). This isn't the case on Singleplayer or Local MP. I don't think these are related, but maybe you've come across it?

I will take a look at that "no damage" issue. I mostly test script on singleplayer and dedicated server.

 

At this time I am in process of rewriting script with new commands.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×