Jump to content

Kicked - Signature Check Failed

Recommended Posts

I've had this problem for about two weeks now, I can't figure out how to fix it.


I am getting kicked from multiplayer servers, usually modded, but not always.  I am being kicked for Signature Check Failed/invalid/etc.  The errors are from a3 items, a3 expansion items, mod items, doesn't matter.  I rejoin the server, get kicked for a3.  Kicked for JSRS.  Kicked for RHS.  Kicked for a3.


I will basically continue to be kicked until I am no longer being kicked, usually within 20-60s of joining a server.  This will occur on average 4 times, but I've seen anywhere from 1-15 kicks.  Rarely I will be kicked past the period of the 'kickings' where after 1-2 hours, I will be kicked again when it seemed like things were going good.


I have performed the following steps - they have all failed:


1) Verifying game cache

2) Deleting pbo's/signature files for Arma 3, verifying cache

3) Re-installing Arma 3

4) Re-installing mods

5) Getting signature files from friends

6) Getting signature files from Armaholic

7) Verified SSD integrity, passed

8) Moved shadowplay temp recordings to HDD

9) Deleting my in-game profile (a suggested fix, this is Arma after all, your profile probably controls whether or not you game even runs)

10) Deleting all data from $appdata$ pertaining to Arma 3

11) Verified a server I was attempting to play on was running verifysignatures = 1 and not = 2

12) Reinstalled BE (downloaded from website, deleted old information

13) Arma 3, BE, Arma 3 launcher all running as admin

14) Added specific filters to firewall for BE

15) Tested ping / jitter / packet loss to server(s), all within acceptable bounds (better than acceptable)

16) Deleted Arma 3 from SSD, installed back on HDD

17) Checked/tested my routers MTU, fine

18) Manually set MTU in clientside settings

19) Manually set proper load order for mods (compatibility -> Scenario -> peripherals -> content -> maps)

20) Moved back to SSD, tried using 2 different VPN's

21) Servers updated to latest infiSTAR

22) Changed port for BE on the server from 2300->2330

23) Deleted physx_x86.dll from Arma 3 folder, redownloaded

24) Opened WAN ports for Arma 3

25) Manually moved keys from mods into the keys folder

26) Mods were moved to a folder at the top of a drive, basically F:\\Arma 3 Mods 

27) Tried changing launcher config, turned off verifysignatures (it was finding 150+errors anyway) and logs to increase performance

28) Deleted all Arma 3 related files/folders.  Restarted PC.  Deleted all Arma 3 related registry information.  Restarted PC.  Deleted all BIS files/folders/registry, restarted.  Unsubbed from all Steam content, deleted all mods, everything.  Cleared/reset SSD.  

29) Installed fresh Arma 3.  Installed fresh mods.  Joined a server.  Kicked.

30) Got new SSD, reinstalled Windows, reinstalled all programs, Arma 3, mods, disabled anti-virus, not kicked.


My PC is as follows:


i5 4670K @4.1GHz


16Gb RAM

C:\\ SSD 60gb

E:\\ HDD 1Tb

F:\\ SSD (Arma 3) 240gb 

Windows 7 64b


I was able to play fine, on any server or with any mods, until I wasn't.  Even in Arma 2, I was never kicked for Signature check errors/fails.  I'm now over 3000 hours in Arma 3, and was also never kicked for fails/errors.  


This is a link to the error RPT.  If you notice, the mods basically all fail their checks. 




However, I was kicked for a signature check error for \structures_f_exp_industrial.ebo.  As you can see:


20:30:33 Signature tests for F:\Steam\steamapps\common\Arma 3\expansion\addons\structures_f_exp_industrial.ebo.a3.bisign PASSED!



I don't know what else to do.

  • Like 1

Share this post

Link to post
Share on other sites

Hey, got the exact same problem and wonder how you fixed it or if you even fixed it.

I already tried the whole list of yours and hope I'll get a problem-solve here to play my favourite mod (Exile) again. :)





Share this post

Link to post
Share on other sites

After I completely reinstalled windows and steam/arma/software, importing no profile information or saves and having completely unsubscribed from mods on steam, etc.


The issue was fixed, it happened again later, and I disabled my anti-virus and it was fixed.  Haven't had the issue since, I have no real idea why it occurred.

Share this post

Link to post
Share on other sites

Thanks for your answere but sadly I have to say that I already did this and it didnt help.

So I have to search for another thing to solve this problem.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now