Jump to content

Server not showing up in Browser/Can't connect

Recommended Posts

I'm going to put this at the top, the ports ARE forwarded correctly.


I'm running a dedicated server on Debian Linux and starting the past couple of days, the server no longer shows up in the browser, it doesn't show up when trying to use remote, and I cannot connect to the server directly using the IP and port, I just stare at the ArmA 3 logo until I hit escape and go back to the main menu.


To clarify, the server had been working for a little over a month. Nothing was changed between when it was working to when it stopped working except for a possible unclean shutdown. No updates have been applied


According to the Steam API (http://api.steampowered.com/ISteamApps/GetServersAtAddress/v0001?addr=), the server is working as it returns the following information:

	"response": {
		"success": true,
		"servers": [
				"addr": "XX.XX.XX.XX:2303",
				"gmsindex": 65534,
				"appid": 107410,
				"gamedir": "Arma3",
				"region": -1,
				"secure": false,
				"lan": false,
				"gameport": 2302,
				"specport": 0


Additionally, the bottom of my log file shows:

23:20:11 Game Port: 2302, Steam Query Port: 2303

23:20:11 Initializing Steam server - Game Port: 2302, Steam Query Port: 2303

23:20:11 Connected to Steam servers

Full Log File


At this point I've tried validating the server.

I've completely reinstalled the server.

I've tried launching the server without mods.

I've deleted the original profile and tried using the auto generated one.


I'm willing to try about anything else at this point.

EDIT: This has been resolved. There was an issue with the physical router.

Edited by Ledere

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now