Jump to content
J0K3R 5

Insurgency - Tanoa

Recommended Posts

Ty .. checking now :)

 

EDIT:  Lots of VCOM_AI errors popping up.  Would also be useful to preload all the occupied squares before allowing players to move, as I still get that AddAll variable error and gear error, before all the squares are sorted.  (on DEV branch BTW)

  • Like 1

Share this post


Link to post
Share on other sites

Ty .. checking now :)

 

EDIT:  Lots of VCOM_AI errors popping up.  Would also be useful to preload all the occupied squares before allowing players to move, as I still get that AddAll variable error and gear error, before all the squares are sorted.  (on DEV branch BTW)

 

 

Vcomai has been removed, you shouldnt get any errors for this.

 

bloody hell google failed to update the download links :(

 

 

Share this post


Link to post
Share on other sites

LOL ... that will help :)  Glad I found the problem!

 

EDIT Just tested the _C version (top link) ... all squares are going green when close (tried about 10 minutes) .. no enemies spawning :*(  However, everything else looks just great !

 

EDIT2:  I know that you have the arsenal in the mission, but would it be possible to have some set loadouts (on the respawn dialog)?

Share this post


Link to post
Share on other sites

LOL ... that will help :)  Glad I found the problem!

 

EDIT Just tested the _C version (top link) ... all squares are going green when close (tried about 10 minutes) .. no enemies spawning :*(  However, everything else looks just great !

 

EDIT2:  I know that you have the arsenal in the mission, but would it be possible to have some set loadouts (on the respawn dialog)?

 

now thats weird, works ok my side, can you please try the steamworkshop version to see if your getting the same problem

Share this post


Link to post
Share on other sites

I test your previous versions and the actual .. and i have to say on our server we get always the same problems:

 

- Crash Game when we launch the mission. 

- No enemys in red squares.

 

I wanna ask you.. Do you test your missions on Dedicate server or just in Host?

 

Can you add the Module Zeus (login by ADMIN) just to add task so they would go to secundary objectives to get some intel. 

  • Like 1

Share this post


Link to post
Share on other sites

I test it on a lan on 2 pc's

 

What I have noticed, since the last update its broken the spawn building locations for the ai

Share this post


Link to post
Share on other sites

Looking forward for the fix :)

 

Ive totally gutted the mission and started fresh with it.

A few new things have been added and removed all the problematic scripts.

 

Its only hosted at steamworkshop, just for ease.

 

Link on first post.

Share this post


Link to post
Share on other sites

I've hosted the mission on a server box, but the vehicle spawn isn't working (not showing up to enable).  The notification mission loaded has shown up.  What am I doing wrong.

  • Like 1

Share this post


Link to post
Share on other sites

I've hosted the mission on a server box, but the vehicle spawn isn't working (not showing up to enable).  The notification mission loaded has shown up.  What am I doing wrong.

 

Just to confirm,

 

You got the hint pop up saying MISSION LOADED ?

as none of the scripts work until the hint pops up.

 

Is it turned on in the params, by default it is switched on ?

 

Has all the red box loaded on the map ?

 

Are you able to run the mission in debug mode ?

Share this post


Link to post
Share on other sites

* debug mode added for server admins

* zeus added for server admins

Share this post


Link to post
Share on other sites

I can confirm that you can't spawn in any vehicle (Spawn parameter set to true, mission fully loaded, debugging enabled).

The problem is that the player doesn't get the option to spawn any vehicle, so there's probably nothing wrong with the script,

just the initialization of the Vehicle Spawn sign regarding giving the players the option to spawn.

 

I've been looking for quite some time for another remake of the original insurgency in Arma 3 and I have to say... yours is the perfect answer for that.

 

Perhaps a few suggestions:

  • Extend the friendly area to the entire airfield and surrounding buildings, just to create a little bit of breathing room.
  • Patrolling units around the base in case the enemy does come looking?
  • Props around the base to increase the player's immersion (Perhaps a broken down hunter, mechanic etc. at the rearm area).
  • Like 1

Share this post


Link to post
Share on other sites

Standard Insurgency Tanoa - has had Vehicle spawner overhaul + Blufor random patrols + base safe zone area increase + enemy random air patrols.

Inusrgency Tanoa RHS + ACE updated

 

Other version still to be updated.

Share this post


Link to post
Share on other sites

Could we get the google drive version of the ones you have sorted please kaysio ?  I want to host on my dedi server and do some testing!

 

PS I can't remeber if you have Farooq's Revive in the mission?  I know davidoss has it in Battlefield Everywhere and it really makes a complete experience.

  • Like 1

Share this post


Link to post
Share on other sites

Kaysio, what does you mean by +ACE? because im using the RHS_AFRF_USAF_GREF_ACE version and ACE revive doesnt seem to be working. Its still instant death.

  • Like 1

Share this post


Link to post
Share on other sites

Kaysio, what does you mean by +ACE? because im using the RHS_AFRF_USAF_GREF_ACE version and ACE revive doesnt seem to be working. Its still instant death.

 

I will look into this, its meant to have the advanced medical and revive

Share this post


Link to post
Share on other sites

Just make sure that you keep the option for Farooq's revive as this is the only one I know that works RELIABLY for AI automatically.

 

PS Needs Farooq's revive ;)

  • Like 1

Share this post


Link to post
Share on other sites

Could we get the google drive version of the ones you have sorted please kaysio ?  I want to host on my dedi server and do some testing!

 

 

 

Link is on 1st post, I always update them when I make changes to them.

Just keep an eye on the latest version date.

Share this post


Link to post
Share on other sites

@kaysio talking about your newest: Insurgency_(N).Tanoa.pbo

 

are you playing this mission on a localhosted server or dedicated, because regardless what mission parameters i set (on pure vanilla dedicated server (win and linux)) there are no intel drops... rpt below, marked the only thing about intel

Error: Object(2 : 234) not found
Error: Object(2 : 238) not found
c:\w\stable\futura\lib\network\networkserver.cpp NetworkServer::OnClientStateChanged:NOT IMPLEMENTED - briefing!
"Advanced Sling Loading Loading..."
"Advanced Sling Loading Loaded"
Error in expression <



if (!isServer) exitWith {};







[f_param_weather,f_param_fog == 4,f_param>
  Error position: <f_param_weather,f_param_fog == 4,f_param>
  Error Undefined variable in expression: f_param_weather
File mpmissions\__cur_mp.tanoa\f\missionConditions\f_setMissionConditions.sqf, line 15
Strange convex component70 in a3\structures_f_exp\commercial\multistorybuilding_01\multistorybuilding_01_f.p3d:geometryFire
Strange convex component75 in a3\structures_f_exp\commercial\multistorybuilding_01\multistorybuilding_01_f.p3d:geometryFire
Strange convex component76 in a3\structures_f_exp\commercial\multistorybuilding_01\multistorybuilding_01_f.p3d:geometryFire
Strange convex component77 in a3\structures_f_exp\commercial\multistorybuilding_01\multistorybuilding_01_f.p3d:geometryFire
Strange convex component78 in a3\structures_f_exp\commercial\multistorybuilding_01\multistorybuilding_01_f.p3d:geometryFire
Weather was forced to change
String STR_f_param_mission_timer_off not found
Strange convex component16 in a3\boat_f_gamma\boat_civil_04\boat_civil_04_f.p3d:geometryView
Strange convex component25 in a3\boat_f_gamma\boat_civil_04\boat_civil_04_f.p3d:geometryView
Strange convex component26 in a3\boat_f_gamma\boat_civil_04\boat_civil_04_f.p3d:geometryView
Strange convex component27 in a3\boat_f_gamma\boat_civil_04\boat_civil_04_f.p3d:geometryView
"_dropIntelType 25 not available"
A nil object passed as a target to RemoteExec(Call) 'bis_fnc_shownotification'
A nil object passed as a target to RemoteExec(Call) 'bis_fnc_shownotification'
Error: Object(4 : 4) not found
Error: Object(4 : 3) not found
"_dropIntelType 25 not available"
  • Like 1

Share this post


Link to post
Share on other sites
The intel seems to be spawning correctly now, though randomly the ai bunch up in the building. Im still looking into this. Ive installed the script version of VCOMAI and this helped alot with the bunching up problem. Hopefully a step closer in the correct direction, The other versions will get updated a soon as I get feedback on this mission and there is no major game breaking bugs appeared.

 

 

So as it stands at the moment the Insurgency [N] has on been updated, until there is feedback on anymore problems.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×