Jump to content
MANTIA

Steam AppID set for current.........

Recommended Posts

  • Added: Dedicated Servers check the Steam AppId set for the current process and produce a warning to the console and to the log when it doesn't match expected value

 

Hey guys.  I was messing around with our dedicated server and when I started it up I saw this error that is mentioned in the changelog.  Once the headless client connected the message went away.  I searched around a bit only found it in the change log.  However, I have no idea what it really means, what caused it, and if it is something we should be concerned about?

 

Thanks

Share this post


Link to post
Share on other sites

I have the same error and I DIDN'T use Steam to install my server.  I used straight Steamcmd.  Steamcmd used A3serverBRANCH=233780 -beta .  I'm running Version 1.60.136470.  My server .RPT has this line:   2:40:26 Warning: Steam AppId doesn't match expected value:  <> 107410.  I did a search and couldn't even find the steam_appid.txt file that the link references.  where does it exist?  It seems my server still starts so what negative impact is there to this message.

 

Edit... curiouser and curiouser.   Steam_appid.txt does exist in my Arma3/server directory.  And it contains a single line - 107410.  But yet I still get that msg in my .RPT file.

 

Thanks

Share this post


Link to post
Share on other sites

Did you ever find a fix for this? I'm having the same problem

 

i too am getting this error and have the same problem. ie. the "steam_appid.txt" file in the root of the dedicated server install contains only a single line "107410", which i am seeing is the correct number, yet i am getting this error; 

 

steamappid_error.png

 

as well, our group runs a second server with this exact same setup and we are not getting an error from it. 

 

server install is up to date as of today (06/10/2016). 

 

any suggestions? 

 

Theopolus AKA JESTER at Battleboys ArmA

Share this post


Link to post
Share on other sites

Just to add after some troubleshooting - the Warning only appears when the Steam client is running on the machine with the dedicated server.  Close the Steam client, and it launches without the error.  (We launch it with ArmA 3 Sync, so we can easily manage the many addons)

 

I tried installing a brand new server using steamcmd (the server owner originally installed using steam), and the same symptoms.

 

Fortunately, it doesn't appear to actually impact the functionality of the server.

Share this post


Link to post
Share on other sites

I got this warning now aswell. When i try to join my server in arma 3 "you were kicked of the game. Steam authentication failed" pops up. And in the Arma 3 console it says "Warning: Current Steam AppId: 233780 doesn't match expected value: 107410". How do i fixe this >D

Edited by BL33D

Share this post


Link to post
Share on other sites

I am also having this problem, any help would be appreciated.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×