Jump to content
.kju

Iron Front in Arm3 LITE - preview versions

Recommended Posts

4 hours ago, Jaki said:

Could you check if AI on Lafette in bunker is actually targeting enemy AI?

I have and the ai wasn't, i was standing behind the gunner watching him and his gun, and he acted as if there was no one there when the enemy squad was about 70m out,

he didn't move nor did the gun move, not til the enemy was literally was on either side of the bunker even then he didn't target or shoot.

4 hours ago, Jaki said:

but if you say it works fine when placed outside the bunker we'll look into it.

Yes without any of the bunkers and i mean all of them, the AI engages the enemy AI apon sight which is about 150m or so as they come through a tree/bush line into an open field.

5 hours ago, Jaki said:
6 hours ago, Gunter Severloh said:

Also Mg42 (trench) was a static i was using before but i cannot locate it anywhere in the editor, anyone have any ideas or was it swapped with something else?

It was removed from Eden a while ago due to having some issues, but if you placed them before in the mission I think they'd be still available.

Ok ya, i had it preplaced a while back, probably before several updates, but then removed it as i didn't see it in the editor, so i figured i might

get issues with it if its no where else, so i changed it.

Share this post


Link to post
Share on other sites

@Madshepherd Screenshot links are broken.

Share this post


Link to post
Share on other sites
1 hour ago, keeway said:

@Madshepherd Screenshot links are broken.

 Maybe "moderator " has taken them down as some pics had Nazi  flags and gestures in them  ?

Share this post


Link to post
Share on other sites

Works for me without problems-

steps to fix it-

Open Image in new tab

refresh tab.

Share this post


Link to post
Share on other sites
33 minutes ago, jarrad96 said:

Works for me without problems-

steps to fix it-

Open Image in new tab

refresh tab.

Yep works for me too 

 

thank you  :thumb:

Share this post


Link to post
Share on other sites
On 5/27/2018 at 3:36 PM, madrussian said:

Quick question regarding IFA3 mortars:  How is the player suppose to load them?

 

Take the M2 60mm for example, which I place into the editor (simple test mission).  I walk up and it has several actions available: “Load”, “Prep 60mm HE rounds”, “Prep 60mm smoke rounds”, “Unload ammo from M2”, and then the usual get in and disassemble actions.  When I get in I see it has 2 mags of 8 rounds each.  Unloading via action functions as expected, unloading 1 magazine each time, to player’s inventory (which I checked and saw in there).  However, when I try to load it up again by first prepping ammo via either “Prep 60mm HE rounds” or “Prep 60mm smoke rounds” (to make that action turn from red to green) then do “Load” action, nothing seems to happen.  Plus if the mortar is empty, the load action gives a hint saying simply “No ammo prepared” or "No ammo", even though I’m holding the mortar rounds I unloaded moments before.


I was able to comprehend and operate the load/unload for assembled MGs successfully, so hopefully I’m just missing something simple?

 

(In my dynamic mission, mortars and MGs come in a supply drop, and must be assembled.  As the mortars start out empty upon assembly, I also put some mortar ammo in the supply drop crate for the player to load them with.)

 

I tried this mortar load action again and it works now.  If it got fixed, thanks! :smile_o:

 

Quick observations:

 

The 1-round mortar mags are configured for player to be able to pick them up and load them, but the 8-round mags are not.  Similarly, the mortar vehicles are scripted for player to be able to load 1-round mortar mags, but not 8-round mortar mags.  Specifically:

  • With 1-round mortar magazines, player can see these in inventory of a crate, pick them up, see the picked up mags in his personal inventory, go to the mortar vehicle, load the mortars, and in this case indeed everything seems to be working as intended.
  • However, with 8-round mortar magazines, when player opens a crate with these inside, a config error pops up saying in essence no picture, and player can see these 8-round mortar mags but indeed they have no picture and also the count is missing from inventory display (though I checked and the correct count of these mags is present in crate).  Player can pick them up (and again picture/count doesn't show in personal inventory), go to mortar vehicle, and try and load these 8-round mags, via “Prep 60mm HE rounds” and "Load", but it doesn't work.

Anyway probably all this is intentional, as "8-round" mortar mags probably don't exist in real life (or at least not in WW2), and if they did foot soldiers probably couldn't carry them.  (Finally, wrote a "Load all Mortars" action script to overcome this 1-round vs 8-round discrepancy in my scenarios.)

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Anyone notice IFA3 tanks have many turrets, but only the 3 standard AI crew by default (driver, gunner, commander), leaving all the extra turrets empty?

 

Ever wonder why those extra turret gunners are missing?

 

Ever tried filling those extra turrets with AI turret gunners, only to dismay when the extra AI turret gunners seemingly randomly disembark once the fighting starts?

 

If so you’re not alone, and thankfully it turns out there is an easy solution to your multi-turreted troubles.

 

First, some background.  This "IFA3 extra turret gunners disembarking" problem has long vexed me, and I tried seemingly everything (all manner of script commands, including disabling "AUTOCOMBAT") to keep those extra turret gunners in their seats, and nothing worked.  Eventually, I pinned the problem down to same-side units (even foot soldiers) near the vehicle being hit.  Same-side guy gets shot (not necessarily killed), and immediately the vehicle’s extra turret gunners disembark.  Perhaps most amazingly, this even happens when all the extra turret gunner’s AI components are disabled!  Here’s the original test:

Spoiler

 

On 3/7/2018 at 10:56 PM, madrussian said:

OK, this is really strange.  Please correct me if I'm wrong, but I seem to have characterized a major problem with tank turret gunners always disembarking when they should not.  Here is a very concise "steps to repeat":

 

1. First, place a crewed LIB tank in the editor.  For simplicity use “LIB_PzKpfwV”.  Note that it has 3 crew by default (driver, gunner, commander).  Note also it has two extra turret positions (for a total of 5 non-cargo positions).

2. Add a couple extra crew to the tank (added to crew's original group), like this:

  Reveal hidden contents

 




private ["_newUnits","_newTurretPaths","_crew","_unit0","_group","_type","_gunner","_tempGroup","_turretPath","_unit","_i"];

params ["_vehic"];

_newUnits = [];
_newTurretPaths = [];

_crew = crew _vehic;
if ((count _crew) > 0) then {
	_unit0 = _crew select 0;
	_group = group _unit0;
	_type = typeOf _unit0;
	_gunner = gunner _vehic;
	if (! (isNull _gunner)) then { _type = typeOf _gunner };
	_tempGroup = createGroup (side _group);
	
	{
		_turretPath = _x;
		_unit = _vehic turretUnit _turretPath;
		if (isNull _unit) then {
			_unit = _tempGroup createUnit [_type, [0,0,0], [], 0, "NONE"];
			_newUnits pushBack _unit;
			_newTurretPaths pushBack _turretPath;
		};
	} foreach (allTurrets _vehic);

	_newUnits joinSilent _group;
	for "_i" from 0 to ((count _newUnits) - 1) do {
		_unit = _newUnits select _i;
		_turretPath = _newTurretPaths select _i;
		_unit assignAsTurret [_vehic, _turretPath];
		_unit moveInTurret [_vehic, _turretPath];
	};
	deleteGroup _tempGroup;
	
	_newUnits allowGetIn true;
	_newUnits orderGetIn true;
};

_newUnits

 

3. Place a same sided man (it can be a default man or even a default vehicle) close to the LIB tank.  I used “B_Soldier_F”.

4. Place player foot unit (of opposite side as LIB tank), behind the LIB tank and man.  Do a “player allowDamage false” on yourself so you can observe without being killed.

5. Start the mission.  Simply shoot the other man.  (I shot him with pistol once and did not kill him.)  Immediately, LIB tank’s 2 extra gunners bail out!  Obviously, this should not happen.  (Similar multi-turreted vehicles from other mods do not eject their crew members in this manner.)  Note the original 3 crewmen stay inside the tank.

6. To further pin down the issue, run the test again but first disableAI “ALL” on all 5 of the LIB tank’s crew members.  Upon shooting the man, the 2 extra turret gunners will still bail out (even though no one in the crew has any AI running).

 

If this can be resolved, maybe at some point we can get fully crewed tanks in the editor?  (If so, that would be awesome!)  In any event, hope this helps out. :smile_o:

 

 

Fast forward to present, today I figured out how to keep IFA3 extra turret gunners in their seats, simply and cleanly:

_vehic setUnloadInCombat [false, false];

Of course that really threw me for a loop, having utterly dismissed setUnloadInCombat more than once (thinking "naw that can't possibly work, as I've tried disabling "AUTOCOMBAT" many times and know 100% that has no effect", etc).  So I don't see how or why it works, but thankfully it does (and I'm not one to look a gift horse in the mouth).

 

So load up those extra tank turrets boys, setUnloadInCombat false works perfectly! :yay:

 

On 3/13/2018 at 7:28 AM, .kju said:

@madrussian be aware that most old IF scripts are not active and likely not the cause here. also some turrets have AI disabled due to engine related issues.

 

@.kju

Can you use setUnloadInCombat to overcome all the issues you guys were having with the extra turrets?  If so, can we eventually get fully crewed tanks in the editor?  Either way, thanks again!

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Ah, the British... enough balls to tell the enemy to F*** off with style!!!
9f83023a53d3098b3e7ada2379cf1cab.jpg

  • Haha 3
  • Confused 1

Share this post


Link to post
Share on other sites

@Zhivets , Sean Connery? A Bridge Too Far (1977)???  "OPERATION MARKET GARDEN"?!? lol!!!! :f: tis a gender bender parody, this photo is... lol

 

Share this post


Link to post
Share on other sites

hi, i've to report a house inception in "staszow, poland" map @ 5853.66, 10558.9,0

vpvo7a.jpg

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

@Digger James I just watched that movie twice last week! Loved this scene, and the movie! Truly great one, along with the longest day.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Gunter Severloh said:

Can watch alot of WW2 movies, documentaries, and tv shows on my WW2Epic Utube channel

I have the full movie the Bridge to far as well ;)

 

Thanks for that Gunter. I just subscribed.

  • Thanks 1

Share this post


Link to post
Share on other sites

No words :shocked:

 

 

 

by LAxemann

  • Like 10
  • Thanks 2

Share this post


Link to post
Share on other sites
10 hours ago, warflak said:

Really neat! Do you got the lost evidence TV show?

Thanks. I had it at one time, but i think before it was copyright so the author had it taken down, and before that it was made private or something idk.

I have 4 tv shows on the channel atm i updated the front page of the channel, if you scroll down i have a list of 4 tv shows under short films.

I'll look for the lost evidence and if i find will add it again.

 

IFA3 Utube channel

I had an idea for a new channel, and this is basically like i did for my channel for Halek's Ravage mod, where i was going to create a channel for IFA3 itself, and setup all sorts of categories

based on the videos i come across.

So they would be separated on dev blog, coop, sp, clips, previews, episodes, ect,. with IFA3 it will be much more profound in how i set it up as its alot larger then Ravage is.

But once i get something setup i'll post it here and link it in my sig.

  • Like 1

Share this post


Link to post
Share on other sites

Is there any update on fixing the issue of not all of the assets appearing in Zeus? The last I saw about it in this thread was more than a year ago. I can make a list of all of the missing assets if you need as well.

Share this post


Link to post
Share on other sites

Not sure if it's been mentioned already, but the M3 Half Track seems to be very nose heavy atm... 

  • Haha 2

Share this post


Link to post
Share on other sites

@JacobyWitness we definitely want to fix this and have looked into it a couple of times without success :hang:

will give it another try for the next update

 

to have missing assets listed would be useful (if its more than some US vehicles and static dead)

post them in here please if you are aware of more: https://feedback.ww2ina3.com/T1658

 

 

@TheCr8rMaker known and to be fixed in the next update

  • Thanks 1

Share this post


Link to post
Share on other sites
On 7/19/2018 at 1:12 PM, El Tyranos said:

1st devblog for Red Devils & Desert Rats Update is live !

 

 

 

 

Nice work!

 

Any chance to see the small rubber dinghies on the side of the large boat (LCI) as separate objects?  Would be nice to have a WWII style rubber dinghy along with Feint's nice paddle addon for smaller "commando style" co-op missions.

 

 

The new plane sounds by LAxemann is totally awesome!

 

  • Thanks 1

Share this post


Link to post
Share on other sites
On 23/07/2018 at 11:21 AM, KeyCat said:

Any chance to see the small rubber dinghies on the side of the large boat (LCI) as separate objects?  Would be nice to have a WWII style rubber dinghy along with Feint's nice paddle addon for smaller "commando style" co-op missions.

 

 

This is planned for an upcoming update.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×