Jump to content
Sign in to follow this  

Ace3 .dll files blocked by Battleye

Recommended Posts

As the title says, Battleye blocks all .dll files from Ace 3.

Battleye Log shown in arma 3 launcher:


04.03.2016 23:31:08 - Starting BattlEye Service...

04.03.2016 23:31:09 - Updating BattlEye Service...

04.03.2016 23:31:19 - BattlEye Service update failed. The master server is offline or unreachable. Please ensure that you are connected to the internet and BEService.exe is not blocked by a firewall.

04.03.2016 23:31:19 - Launching the game...

04.03.2016 23:32:17 - BattlEye: Note that file blocks can be ignored if they don't cause problems with the game.

04.03.2016 23:32:17 - Blocked loading of file 'E:\SteamLibrary\steamapps\common\Arma 3\@ace\ace_medical.dll'

04.03.2016 23:32:31 - Blocked loading of file 'E:\SteamLibrary\steamapps\common\Arma 3\@ace\ace_break_line.dll'

04.03.2016 23:32:41 - Blocked loading of file 'E:\SteamLibrary\steamapps\common\Arma 3\@ace\ace_parse_imagepath.dll'

04.03.2016 23:32:51 - Blocked loading of file 'E:\SteamLibrary\steamapps\common\Arma 3\@ace\ace_clipboard.dll'

04.03.2016 23:33:01 - Blocked loading of file 'E:\SteamLibrary\steamapps\common\Arma 3\@ace\ace_fcs.dll'

04.03.2016 23:33:12 - Blocked loading of file 'E:\SteamLibrary\steamapps\common\Arma 3\@ace\ace_advanced_ballistics.dll'

 What i tried so far:

- reinstalling arma 3 and remove all files (arma 3 and appdata folders)

- remove all Battleye files and let steam redownload it

- install fresh Battleye files from the Battleye site

- updated Windows

- load fresh versions from cba and ace 3

- run arma and all Battleeye files as admin

- add arma and Battleye to the firewall

- deactivate firewall and antivirus program (windows defender)

- tried ace 3.4.2 and the newest version 3.5.0

- made a backup and remove my arma 3 profile/config files


My Pc is running Windows 8.1





Edit: added more things i tried.

Share this post

Link to post
Share on other sites

From the ACE 3 Release Page:



Please be aware that all extensions have been recompiled in this release. This means that if you use BattleEye, the new extensions could potentially be blocked until BE adds them to their whitelist.


Share this post

Link to post
Share on other sites

Hey Aristenn,

i tried the older version "3.4.2" as well and it dont work. All my friends have no problem with it.

Share this post

Link to post
Share on other sites

EDIT: I didn't see your edit


EDIT2: Did you try launching Arma 3 through the launcher with BattleEye enabled?

Share this post

Link to post
Share on other sites

"Battleye Log shown in arma 3 launcher:"

The log in my first post is from the arma 3 launcher, so yeah i start arma with the launcher and battleye enabled.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this