Jump to content

Recommended Posts

3 hours ago, lv1234 said:

@R3vo

Ah I realized what was wrong...Only the vanilla content works with the "simple object" option with 3eden enhanced & not the modded contents

 

does your 3eden enhanced "simple objects" support modded content in the first place?

Good question. Generally it does.

 

Simple object is a vanilla attribute and was not edited by me in any way. So if it doesn't work it's either a A3 or mod issue.

Share this post


Link to post
Share on other sites

for strange reason I don` t have garrison menu anymore in edit menu....

Share this post


Link to post
Share on other sites
50 minutes ago, sammael said:

for strange reason I don` t have garrison menu anymore in edit menu....

me either

Share this post


Link to post
Share on other sites
1 hour ago, Jnr4817 said:

me either

For what type of objects?

 

I am pretty sure that you right-clicked on the flag above the unit and not the unit itself. I changed that so in the next version one can click either that flag, or the unit/object.

  • Like 1

Share this post


Link to post
Share on other sites

I clicked on flag above the unit and  the unit itself...as I said before - no garisson menu for me....

can this bug may be from -my game language russian? 

Share this post


Link to post
Share on other sites

Here's a small update, hope you like it.

 

 

 

It shows everyone who contributed either by improving or providing code, or by updating the translation.

If I have missing someone please let me know. Also if someone doesn't want to be shown in the credits, let me know.

 


Edit: It's still WIP and I have not yet decided whether or not to implement it.

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

Hi,

 

I really enjoy this mod and use it constantly.

 

I have a question I'm hoping something could be clarified; the Camouflage Coefficient defaults to 1x for the standard unit. If the slider was moved to 0.5 does that mean that the unit is more difficult to be seen by enemy AI (unit has better camouflage) or does it mean that the unit has a more difficult time spotting other enemy AI? Sorry but I find the tool tip for that section too ambiguous.

 

Thanks for your help.

 

Share this post


Link to post
Share on other sites
2 hours ago, dr@gon said:

Hi,

 

I really enjoy this mod and use it constantly.

 

I have a question I'm hoping something could be clarified; the Camouflage Coefficient defaults to 1x for the standard unit. If the slider was moved to 0.5 does that mean that the unit is more difficult to be seen by enemy AI (unit has better camouflage) or does it mean that the unit has a more difficult time spotting other enemy AI? Sorry but I find the tool tip for that section too ambiguous.

 

Thanks for your help.

 

 

A lower value means the unit is harder to spot (It's camouflage becomes better)

 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

@R3vo

It seems that your mod is disabling the join command (on purpose or on accident?) for the unit that is controlled by the player. When previewing the mission  I tried to execute

[player] joinSilent (createGroup east)

while playing as a west soldier to make me switch sides. It was no problem when I played as another unit in the editor, it only appears with the one which has the player attribute checked. It's not gamebreaking but maybe you wanted to know.

 

Edit:

 

--- SOLVED: ---

 

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, 7erra said:

@R3vo

It seems that your mod is disabling the join command (on purpose or on accident?) for the unit that is controlled by the player. When previewing the mission  I tried to execute


[player] joinSilent (createGroup east)

while playing as a west soldier to make me switch sides. It was no problem when I played as another unit in the editor, it only appears with the one which has the player attribute checked. It's not gamebreaking but maybe you wanted to know.

I'll look into it, but I am sure that's a vanilla issue.

Share this post


Link to post
Share on other sites
33 minutes ago, R3vo said:

I'll look into it, but I am sure that's a vanilla issue.

Pretty sure not. I've tried without mods, with cba, and with your mod. I'm gonna doublecheck too.

Share this post


Link to post
Share on other sites

Alright I found the problem (Problem 4: In front of the PC). The player character was set captive (though I still don't know how). Obviously the player was therefore side civillian, but the group was the desired side. Sorry for the inconvenience.

Share this post


Link to post
Share on other sites

@R3vo The export loadout to config tool exports the uniform as: uniform = ""; but afaik it should be uniformClass = "";

Share this post


Link to post
Share on other sites
13 hours ago, Mr. Rad said:

@R3vo The export loadout to config tool exports the uniform as: uniform = ""; but afaik it should be uniformClass = "";

Are you sure? Because I am using

 

private _loadout = [_x,"config"] call BIS_fnc_exportInventory;

 

 

Edit: It seems you are right, furthermore I noticed that by default assigned weapon items like optics are not exported. I have written my own functions now. Would you be so kind to test it in the editor?


 

params
[
    ["_class","REPLACE",[""]],
    ["_displayName","REPLACE",[""]],
    ["_icon","REPLACE",[""]]
];

_indent = "    ";
_class = format ["class %1",_class];
_displayName = format ["displayName = ""%1"";",_displayName];
_icon = format ["icon = ""%1"";",_icon];
_uniformClass = format ["uniformClass = ""%1"";",uniform player];
_backpack = format ["backpack = ""%1"";",backpack player];
_export = _class + endl + "{" + endl + _indent + _displayName + endl + _indent + _icon + endl + _indent + _uniformClass + endl + _indent + _backpack + endl;
//From BIS_fnc_exportLoadout START
_fnc_addArray =
{
    params ["_name","_array"];

    _export = _export + format ["    " + "%1[] = {",_name];
    {
        if (_foreachindex > 0) then {_export = _export + ",";};
        _export = _export + format ["""%1""",_x];
    } foreach _array;
    _export = _export + "};" + endl;
};

["weapons",weapons player + ["Throw","Put"]] call _fnc_addArray;
["magazines",magazines player] call _fnc_addArray;
["items",items player] call _fnc_addArray;
["linkedItems",[vest player,headgear player,goggles player] + assigneditems player - weapons player + primaryWeaponItems player + secondaryWeaponItems player] call _fnc_addArray;
//From BIS_fnc_exportLoadout END
_export = _export + "};" + endl + "//Visit https://community.bistudio.com/wiki/Arma_3_Respawn for detailed information";

copyToClipboard _export;
_export

Just save the file in your mission folder and name it "t.sqf", then executed

["className","soldier","someIcon"] execVM "t.sqf";

in the debug console

Share this post


Link to post
Share on other sites

Alright, I've have fixed the export loadout issue and created a new GUI for it and function. The export is now much better and comfortable.

 

GIFMaker.org_rZhF2M.gif

  • Like 2

Share this post


Link to post
Share on other sites

@R3vo Sorry i didn't see the notification in time to test the script you told me. I also uncovered a small issue in one of my missions i made. 3den is supposedly reporting that in code 

_this setFeatureType parseNumber (_value)

the value expected is a boolean while the value received is a number. However there was no indication about where the error occurred so i couldn't investigate further.
I saw that the property was Enh_featureType so thats why i think this is one of your properties and not vanilla.

Share this post


Link to post
Share on other sites
9 hours ago, Mr. Rad said:

@R3vo Sorry i didn't see the notification in time to test the script you told me. I also uncovered a small issue in one of my missions i made. 3den is supposedly reporting that in code 


_this setFeatureType parseNumber (_value)

the value expected is a boolean while the value received is a number. However there was no indication about where the error occurred so i couldn't investigate further.
I saw that the property was Enh_featureType so thats why i think this is one of your properties and not vanilla.

I'll investigate that.

Share this post


Link to post
Share on other sites
On 2018-05-19 at 12:34 PM, lv1234 said:

@R3vo

Ah I realized what was wrong...Only the vanilla content works with the "simple object" option with 3eden enhanced & not the modded contents

 

does your 3eden enhanced "simple objects" support modded content in the first place?

Not sure if you've found out yet, but that was a change made by BI a while back. The 'simple object' checkbox now operates on a whitelist system where mods are now required to whitelist each of their assets to be simple objects. As far as I'm concerned they should have gone with a blacklist system so that old mods have the checkbox available by default.

Anyway, @R3vo, I was wondering if there's any way that 3den Enhanced could force the checkbox back into existence for all objects. I understand that BI made the change for a reason, but I feel that advanced users should be able to apply the simple object attribute to anything they feel necessary. I'd imagine it'd be simple enough to add the checkbox back; That's assuming that the whitelist doesn't get double checked on mission load as well, though.

Share this post


Link to post
Share on other sites

Unsure if this is possible. But is there anyway to use this mod to give a unit more than 100% health without making them invincible? I tried putting 200% in the health field but it defaulted back to 100%. Otherwise this mod is a God send either way.

Share this post


Link to post
Share on other sites
17 hours ago, Drift_91 said:

Not sure if you've found out yet, but that was a change made by BI a while back. The 'simple object' checkbox now operates on a whitelist system where mods are now required to whitelist each of their assets to be simple objects. As far as I'm concerned they should have gone with a blacklist system so that old mods have the checkbox available by default.

Anyway, @R3vo, I was wondering if there's any way that 3den Enhanced could force the checkbox back into existence for all objects. I understand that BI made the change for a reason, but I feel that advanced users should be able to apply the simple object attribute to anything they feel necessary. I'd imagine it'd be simple enough to add the checkbox back; That's assuming that the whitelist doesn't get double checked on mission load as well, though.

Well that is unfortunate, so back then before the change, the "simple object" option would have worked on modded vehicles and such?

 

I feel like they are just making things more harder for us modders and editors LOL

Share this post


Link to post
Share on other sites
15 hours ago, kothen said:

Unsure if this is possible. But is there anyway to use this mod to give a unit more than 100% health without making them invincible? I tried putting 200% in the health field but it defaulted back to 100%. Otherwise this mod is a God send either way.

Not possible without a workaround, sorry.

 

2 minutes ago, lv1234 said:

Well that is unfortunate, so back then before the change, the "simple object" option would have worked on modded vehicles and such?

 

I feel like they are just making things more harder for us modders and editors LOL

The problem is, that objects need to support simple objects, e.g., they need to have the appropriate config settings. You can still turn every vehicle to simpel objects https://community.bistudio.com/wiki/Arma_3_Simple_Objects#Scripting_Implementation

Share this post


Link to post
Share on other sites
4 hours ago, R3vo said:

The problem is, that objects need to support simple objects, e.g., they need to have the appropriate config settings. You can still turn every vehicle to simpel objects https://community.bistudio.com/wiki/Arma_3_Simple_Objects#Scripting_Implementation

To my understanding most of the objects included in a lot of mods are capable of being simple objects, they just haven't been updated since the whitelist was implemented. Most of the objects in CUP Terrains Core for example I've always made simple objects in the past. But even though CUP has been updated since, there's still no whitelist config in it. Also, doesn't the command "BIS_fnc_replaceWithSimpleObject" cause a lot of lag at mission start if used on too many objects?

 

I know a lot of objects don't work as simple objects, but there's a bunch more that do and the checkbox is disabled. I understand you probably want the mod to be usable by novice mission editors, so best bet would probably have it off by default and have a toggle in the 3den preferences to enable the checkbox for all objects. I know there are a lot of mission editors who would be really appreciative of such a function; There was a thread back several months ago where there was a huge argument with the devs over the implementation of the whitelist.

Share this post


Link to post
Share on other sites

I finally got around to add an incremental search to 3den Radio. (Position is not final)

 

  • Like 3

Share this post


Link to post
Share on other sites

I have updated the select preview picture UI. It's now wider and has a bigger preview and tree control. Let me know what you think. Thanks to Gunter Severloh for the idea.

 

X8yl2hC.jpg

AFTER

Jn5An0p.jpg

BEFORE

https://imgur.com/a/u9FhVur

 

 

  • Like 6

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×