Jump to content
ALiVEmod

ALiVE - Advanced Light Infantry Virtual Environment 1.0 (GA)

Recommended Posts

0:41:53 Error in expression <_fnc_profileEntity;_markers = _markers + _marker;_profiles pushback _profile;>
0:41:53   Error position: <+ _marker;_profiles pushback _profile;>
0:41:53   Error +: Type Bool, expected Number,Array,String,Not a Number
0:41:53 File \x\alive\addons\fnc_analysis\fnc_liveAnalysis.sqf [ALiVE_fnc_liveAnalysis], line 3001

23:44:09 Error in expression <e = ([ALiVE_ProfileHandler,"getProfile",_profileID] call ALiVE_fnc_profileHandle>
23:44:09   Error position: <_profileID] call ALiVE_fnc_profileHandle>
23:44:09   Error Undefined variable in expression: _profileid
23:44:09 File \x\alive\addons\mil_opcom\fnc_OPCOM.sqf [ALiVE_fnc_OPCOM], line 2550

I've been getting these kinds of errors with the current update, completely fresh mission, no database used. The OPCOM acts very passive, not attacking the enemy. Watching debug, units mostly get destination waypoints on their own side of the map, even if I set 500+ priority custom objectives to use as targets.

Share this post


Link to post
Share on other sites
On 13/07/2018 at 4:02 PM, drdetroit said:

 

I believe one of the Alive devs said to replace some/all moduels in the editor if mission doesn't start or locks up during the loading.

 

Had the same issue. I just renamed the mission name in the descrption file and the mission file name as well. Loaded and played fine after that.

 

 

Tried this, made no difference, still locked on loading.

 

Through trial and error I found the issue though.  It's the Player Logistics (Disable) module.  If I place it (settings Debug NO, all other settings YES), then it stops the mission loading, if I remove it, mission runs fine as usual.

 

This happens in SP, MP (hosted and dedicated), and trawling through my logs I can see no obvious messages about why this is happening, or even connected to it.

Share this post


Link to post
Share on other sites
1 hour ago, Capt Childs said:

 

Tried this, made no difference, still locked on loading.

 

Through trial and error I found the issue though.  It's the Player Logistics (Disable) module.  If I place it (settings Debug NO, all other settings YES), then it stops the mission loading, if I remove it, mission runs fine as usual.

 

This happens in SP, MP (hosted and dedicated), and trawling through my logs I can see no obvious messages about why this is happening, or even connected to it.

Can you post a vanilla mission and/or a rpt file from a vanilla mission that won’t load? Some errors have been reported and seen internally with Logistics, but no reports of an error preventing a mission from loading completely have been shared directly with the devs yet.

 

This would be useful if you could.

Share this post


Link to post
Share on other sites

I get this error with a freshly created mission.

10:16:32 Error in expression <e = ([ALiVE_ProfileHandler,"getProfile",_profileID] call ALiVE_fnc_profileHandle>
10:16:32   Error position: <_profileID] call ALiVE_fnc_profileHandle>
10:16:32   Error Undefined variable in expression: _profileid
10:16:32 File \x\alive\addons\mil_opcom\fnc_OPCOM.sqf [ALiVE_fnc_OPCOM], line 2550

Share this post


Link to post
Share on other sites

RFX0nkZ.jpg

 

ALiVEmod.com

The next generation dynamic persistent mission addon for ArmA3
 

Hotfix
Due to accidental redundancies in our QA department following explosive decompression of the charity coffee machine, management has concluded that QA should henceforth be outsourced, off shored, crowd funded and delegated to public committee.  There is nothing to see here, please move along. :sulkoff:

 

There were a number couple regression bugs in the 1.7 release that for some unfathomable reason didn't manifest in testing.  The performance improvements on Virtual profiles somehow impacted logistics requests for groups of AI.  There was also a bug with static data (such as map indexes) not loading properly and causing the infamous infinite loading screen, which has apparently been there for more than 3 years but only just decided to become a problem now.  #justArmAthings

 

Release Highlights

Download

Grab the latest version from ALiVEmod.com
Also available from PlayWithSix, ArmAholic and Steam (Usually within 24 hours of this post)

 

 

Please note that as with all updates, if you have an issue loading a mission made with a previous version of ALiVE, delete and replace the modules in that mission.

 

Known Issues & Support
Existing bugs are listed on Github here. Feel free to submit bugs (with vanilla repros please) or discuss any issues or ideas on our forum at http://alivemod.com/forum/.

 

Manual
Please refer to the ALiVE Wiki. All the info you need is there. If anything is missing or unclear, please let us know.

 

Are you using Linux?
ALiVE is fully supported on a Linux Dedicated Server (as well as Windows). In fact the ALiVE Official Server for testing is running Ubuntu. Here are some tips on getting ALiVE running smoothly on Linux and integrated with War Room - http://www.alivemod.com/forum/1916-setting-up-linux- dedi-server

 

Acknowledgements and Thanks
Particular thanks to all those on our support forum who have worked closely with us to identify bugs, provide logs and generally help us improve ALiVE. Your assistance is valuable and your dedication to ALiVE makes it all worth the effort!

 

Have fun!

 

ALiVE War Room is Hosted By

logo.png

  • Like 6
  • Thanks 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×