Jump to content

Recommended Posts

I just reduce the alpha on the markers in the editor, and it works fine.

Share this post


Link to post
Share on other sites
On 2017-04-15 at 4:57 PM, MrCrazyDude115 said:

Hey Engima,

 

I'm using this script to spawn in zombies instead of civs, and it's actually working just as I want it to, but I am confused as to what this line does. Are those "civ types" or what exactly? And how can they be used to spawn let's say "Zombie types" and so on.

 

a02743f684.png

 

Thanks in advance!

MrCrazyDude115,

 

 

That line is for future development. The idea is to have different personalities walking the map. Maybe a group "SOCIAL" searching each other up in the streets to have a chat. Or a small geoup "CURIOUS" that closes to battles instead of fleeing.

 

But I have not hade time to do anything with this yet. Maybe in the future...

  • Like 2

Share this post


Link to post
Share on other sites
On 2017-04-15 at 4:57 PM, MrCrazyDude115 said:

Hey Engima,

 

I'm using this script to spawn in zombies instead of civs, and it's actually working just as I want it to, but I am confused as to what this line does. Are those "civ types" or what exactly? And how can they be used to spawn let's say "Zombie types" and so on.

 

a02743f684.png

 

Thanks in advance!

MrCrazyDude115,

 

 

That line is for future development. The idea is to have different personalities walking the map. Maybe a group "SOCIAL" searching each other up in the streets to have a chat. Or a small group "CURIOUS" that closes to battles instead of fleeing.

 

But I have not hade time to do anything with this yet. Maybe in the future...

 

  • Like 3

Share this post


Link to post
Share on other sites
On 2017-06-20 at 5:31 PM, anfo said:

Having trouble with blacklist markers.

Civilians spawn as expected, but the markers for blacklisted areas don't hide on a dedi.


["UNIT_CLASSES", ["LOP_Tak_Civ_Man_01", "LOP_Tak_Civ_Man_02", "LOP_Tak_Civ_Man_03", "LOP_Tak_Civ_Man_04", "LOP_Tak_Civ_Man_05", "LOP_Tak_Civ_Man_06", "LOP_Tak_Civ_Man_07", "LOP_Tak_Civ_Man_08", "LOP_Tak_Civ_Man_09", "LOP_Tak_Civ_Man_10", "LOP_Tak_Civ_Man_11", "LOP_Tak_Civ_Man_12", "LOP_Tak_Civ_Man_13", "LOP_Tak_Civ_Man_14", "LOP_Tak_Civ_Man_15", "LOP_Tak_Civ_Random"]],
	["UNITS_PER_BUILDING", 0.1],
	["MAX_GROUPS_COUNT", 100],
	["MIN_SPAWN_DISTANCE", 50],
	["MAX_SPAWN_DISTANCE", 500],
	["BLACKLIST_MARKERS", ["markerNociv", "markerNociv_1"]],
	["HIDE_BLACKLIST_MARKERS", true],
	["ON_UNIT_SPAWNED_CALLBACK", {}],
	["ON_UNIT_REMOVE_CALLBACK", { true }],
	["DEBUG", false]

I've double-checked the variable names of the markers and they match. Perhaps I should just reduce the alpha on the markers because I think they still work?

 

Yes, reduce alpha. Thanks for notifying me. That will be fixed in future versions.

Share this post


Link to post
Share on other sites

Don't need any help, just thought I'd share something that seemed to look better than default.

To me, Arma 3 civilians in general always looked like they walked too fast to be natural. So I tried this (thanks to @-LUGER-)

["ON_UNIT_SPAWNED_CALLBACK", {(_this select 0) setAnimSpeedCoef 0.75}],

and (in my opinion) the AI now walk at a more natural, slower pace. Sharing is caring! :grinning:

  • Like 3

Share this post


Link to post
Share on other sites

^^ Doesn't work on dedi. :down:

@engima Would you have any ideas about why this might be? If not then all good.

Share this post


Link to post
Share on other sites
7 hours ago, anfo said:

^^ Doesn't work on dedi. :down:

@engima Would you have any ideas about why this might be? If not then all good.

I don't know. Maybe command setAnimSpeedCoef only has local effect? In that case you would need to broadcast it.

Share this post


Link to post
Share on other sites

First of thanks Engima, great work...

 

Being new to Arma 3 and in the process of building a dedicated server usable for everyone in my group it was a nice to have civilians/traffic populate the server for some "realism". Having a sample of what you were able to achieve with your mods, was curious if you have thought or looked into continuing this to include boats and planes? Can your code be modified/adapted to accommodate this or used as a guide to create this? just thoughts, but if possible (not knowing the Functions/behavior of the code) and you being willing I may be able to help?

 

Thanks and again great work

 

Greg 

Share this post


Link to post
Share on other sites

This is a noob question so I apologize. But where do I place this on a server? Do I place it in root as @Engima and then in the command line?

Share this post


Link to post
Share on other sites
13 minutes ago, Daedious said:

This is a noob question so I apologize. But where do I place this on a server? Do I place it in root as @Engima and then in the command line?

No, this is a script system that must be integrated into a mission file. It is well-documented by the author, and so relatively easy to do.

Share this post


Link to post
Share on other sites
2 minutes ago, Harzach said:

No, this is a script system that must be integrated into a mission file. It is well-documented by the author, and so relatively easy to do.

ohhhhhhhhhh. That makes much better sense lol I thought I was unreasonably confused about how it worked. Thank you.

Share this post


Link to post
Share on other sites
On 18/9/2017 at 4:53 AM, anfo said:

^^ Doesn't work on dedi. :down:

@engima Would you have any ideas about why this might be? If not then all good.

 

 

Just to respon on a wery old tread.. we use it alot on deidccet servers

Share this post


Link to post
Share on other sites

Hi Engima!

I am having some troubles with the "ON_UNIT_SPAWNED_CALLBACK". I call to two scripts, the first one runs perfect in local and dedicated server, however the second one with the addaction does not work on dedicated. I have tried using remotexec on every machine and still does not work.

 

["ON_UNIT_SPAWNED_CALLBACK", {
		_nul = [(_this select 0),(selectRandom ["LIB_M1895","LIB_WaltherPPK","LIB_TT33","fow_w_webley"]),16,20,west,1,0.7] execVM "externalScripts\ws_assassins.sqf";
		{_actionID = (_this select 0) addAction ["<t color='#FF0000'>Interrogar</t>", "externalScripts\conversaciones.sqf",[],5,false,true,"","(alive _target)",3];} remoteExecCall ["bis_fnc_call", 0];
	}],

 

Here is the script converasciones.sqf:

private _poolFrases = ["LUGAREÑO: No se de que me habla.",
"LUGAREÑO: Este es un pueblo tranquilo.",
"LUGAREÑO: Solo hago mi trabajo y cuido a mi familia.",
"LUGAREÑO: Por el amor de Dios, ¿no nos han interrogado ya bastante?",
"LUGAREÑO: Yo solo estoy a mis cosas.",
"LUGAREÑO: Por favor, no me haga daño, se lo suplico.",
"LUGAREÑO: No quiero meterme en problemas con ustedes.",
"LUGAREÑO: Seguro que mis vecinos no saben nada, somos gente humilde.",
"LUGAREÑO: Dejen tranquilas a las mujeres y a los niños por favor."
];

titleText [selectRandom _poolFrases,"PLAIN DOWN"];

Any idea why is not working on dedicated? Thanks!

Share this post


Link to post
Share on other sites

Not quite sure, but I suspect that the part "(_this select 0)" in the second script does not evaluate to the unit, since it is in a new scope. Test it by referencing the unit's global variable.

Share this post


Link to post
Share on other sites

I have tried with this and still not working:

["ON_UNIT_SPAWNED_CALLBACK", {
		person = (_this select 0);
		_nul = [person,(selectRandom ["LIB_M1895","LIB_WaltherPPK","LIB_TT33","fow_w_webley"]),16,20,west,1,0.7] execVM "externalScripts\ws_assassins.sqf";
		{_actionID = person addAction ["<t color='#FF0000'>Interrogar</t>", "externalScripts\conversaciones.sqf",[],5,false,true,"","(alive _target)",3];} remoteExecCall ["bis_fnc_call", 0];
	}],

 

Share this post


Link to post
Share on other sites

Hey guys so i have an issue with using this Engima's Civilians script when i load it up it says the Config.sqf is missing and i open it up and there is nothing there? Anyone have the text in the file they could upload? Thanks

Share this post


Link to post
Share on other sites

You can always get the latest version using the TypeSqf editor (www.typesqf.com).

 

1. Download it.

2. Open your mission.sqm in it using "Open mission".

3. Open the CPack console and write "install engima.civilians".

 

If you do not want TypeSqf to continue handle downloaded CPacks, remove the .tproj file and CPack.Config. 

Share this post


Link to post
Share on other sites
1 hour ago, engima said:

You can always get the latest version using the TypeSqf editor (www.typesqf.com).

 

1. Download it.

2. Open your mission.sqm in it using "Open mission".

3. Open the CPack console and write "install engima.civilians".

 

If you do not want TypeSqf to continue handle downloaded CPacks, remove the .tproj file and CPack.Config. 

ok ill try that its just when i open  "Civilians/Common/Common.sqf"  there is nothing in it for scripts or text. ill try what you said bro i appreciate the response and the traffic script works perfect! Aslo the traffic Common.sqf  has the script in the text.

Share this post


Link to post
Share on other sites

That's strange. Maybe there is some release in which I failed to get the files right.

 

(However, if you keep the CPack.Config you can then use TypeSqf to easily update such scripts in the future.)

Share this post


Link to post
Share on other sites

Confirming I ran into the same issue as above where "Common/Common.sqf" is there but the file is empty.

 

EDIT: Looked into TypeSQF and the file for Common.sqf appears to be empty not only in the latest version but the previous and the first. Is it supposed to be empty? 

 

EDIT #2: Using TypeSQF actually did work, I don't get the error I was getting about Common.sqf being missing having tried to instal manually. Seems to be working now, thanks a lot to the author!

Share this post


Link to post
Share on other sites

I tried all the releases from TypeSQF and the one from Armaholic but I still can't find one where Common.sqf exists, could anyone help?

Share this post


Link to post
Share on other sites
On 3/17/2021 at 5:08 AM, Saint Ivan said:

I tried all the releases from TypeSQF and the one from Armaholic but I still can't find one where Common.sqf exists, could anyone help?

 

It's a common file, the one in the Traffic script should work for Civilians too.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×