Jump to content
Sign in to follow this  

Addon Builder no longer wraps sqf files ?

Recommended Posts

Hi all,


I want to release an update of my HCC mod, but I'm experiencing serious troubles here.


I'm using the exact same pattern as version 1.2 but, while the config.cpp is properly binarized (built successful), the addon wont hook my boot script once ingame. I downloaded my own mod from steam to be sure, un-pbo'ed it and repacked the whole thing to check whether that would work, to no avail.


The addon structure :


     x MySourceFolder

                                 x MyAddon'sName

                                                               x $PBOPREFIX$

                                                               x boot.sqf

                                                               x config.cpp

                                                               x afewotherscripts.sqf

                                                               x init.sqf


The addon header :

class CfgPatches
	class MyAddon
		projectName = "MyAddon'sName";
		version = "A3.1.3.0";
		author = "Igitur";
		requiredVersion = 0.1;
		units[] = {};
		requiredAddons[] = {"A3_UI_F","A3_Dubbing_Radio_F"};
class cfgFunctions
	class MyFunction	{
		class addon_MyAddon
			class init
				file = "MyAddon'sName\boot.sqf";
				postInit = 1;

In the addon builder :


     x Source path : MySourceFolder

     x Destination path : SteamApps\common\Arma3\@MyAddon'sName\Addons


Built successful when I pack but I got a "boot.sqf file not found" message once in game. I notice that some empty  "myaddon'sname" files  (lowercase) are created randomly on my C drive instead.


I also tried with CBA's extended EH, to no avail.


Please help guys, i'm lost in wonderment here and i'd like to release this update before I go abroad for 2 weeks.



Thx a lot !



- Edit : After un-pboing (?) my pbo, I'm left with just the config.bin. So it looks like all sqf files got lost in the process.

Share this post

Link to post
Share on other sites

Open Addon-Builder and go to Options.

Add *.sqf; to 'List of Files to copy directly'.



Thank you for your reply, Chief.


Unfortunately, that wont work. I've tried with a semicolon, a comma, and nothing. I've tried to put the suffix in the Addon prefix field as well, and simplified the addon's name to the simplest possible tag (HCC). Nothing works.


When you have a little time, would you mind trying to pack a sqf file with the method above ? Sorry for asking, but I'd like to know whether it's me or that goddamn tool that needs a heavy tweak !

Share this post

Link to post
Share on other sites

It always worked fine for me, and it still does.


Try using this as 'List of files to copy directly':


Here's an image what it should look like:

(You don't need to add the exact same data-types, but at least .sqf)





Here's mine:


Share this post

Link to post
Share on other sites

Yeah it used to work fine for me too so far, that's why i'm puzzled today :confused: .


I have copy/pasted your line of files in the proper field, with no result. I'll have to investigate further when i'm back from abroad.



Thanks a lot for your time !




- Edit :  Hey, I finally got it ! It looks like I mixed my addon's class and name in the function init file...

  • Like 1

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this