Jump to content

Recommended Posts

What mods a certain group uses is their responsibility, and it's their responsibility to make sure their modpack works nice together and not the mod authors problem.

 

Sorry but I don't agree on that statement. As both someone that has released a mod that depends on other modders adding compatibility as well as someone who manages the modpack of my community I can tell you that that statement is just stupid.

 

Firstly in many cases people release their mods with such terms that you are unable to "make them play nice together". Case in point this very mod's readme states "You are not allowed to decompile, reverse engineer, or otherwise derive content from this addon". So as a community that uses RHS instead of CUP I can't even make this mod play nice with the rest of our modpack because its not allowed.

 

Secondly why should a buttload of modpack managers in the various communities do the exact same work a buttload of times when 1 developer (team) can do it once and everyone gets to enjoy their work. I have done a lot of making things play nice with each other both through patch configs pbo's as well as direct modifications where the license permits it and i can imagine many people will rather just not even worry about it.

 

Granted it might be a decent size amount of work, especially when you start building compatibility for all other mods. But every dev should consider what he builds compatibility for and what the prerequisites for the mod are. Now i'm not criticizing CUP being a prerequisite here. hcpookie is the creator and can do as he wishes with his creations. But saying its the users problem to make x work with y is just plain idiocy.

 

As for the mod itself: Looks nice!

  • Like 1

Share this post


Link to post
Share on other sites

it's all BIS' fault for not paying a small subcontracting team to port A2 content to A3 back in the day. we offered.

Share this post


Link to post
Share on other sites

 

Sorry but I don't agree on that statement. As both someone that has released a mod that depends on other modders adding compatibility as well as someone who manages the modpack of my community I can tell you that that statement is just stupid.

 

Firstly in many cases people release their mods with such terms that you are unable to "make them play nice together". Case in point this very mod's readme states "You are not allowed to decompile, reverse engineer, or otherwise derive content from this addon". So as a community that uses RHS instead of CUP I can't even make this mod play nice with the rest of our modpack because its not allowed.

 

Secondly why should a buttload of modpack managers in the various communities do the exact same work a buttload of times when 1 developer (team) can do it once and everyone gets to enjoy their work. I have done a lot of making things play nice with each other both through patch configs pbo's as well as direct modifications where the license permits it and i can imagine many people will rather just not even worry about it.

 

Granted it might be a decent size amount of work, especially when you start building compatibility for all other mods. But every dev should consider what he builds compatibility for and what the prerequisites for the mod are. Now i'm not criticizing CUP being a prerequisite here. hcpookie is the creator and can do as he wishes with his creations. But saying its the users problem to make x work with y is just plain idiocy.

 

As for the mod itself: Looks nice!

 

If you are not allowed to modify the addon, and you can't use the addon in your modpack because you use X instead of Y and don't want to also include Y, then the mod doesen't fit into your modpack. If the license of the mod allows modification, then sure, go to town. If not, then you're all out of luck. Maybe you can create a config patch that doesen't modify the actual PBO, but other than that there's not much you can do.
 
Bothering the author to remove dependency Y because it doesen't fit into your modpack is not a very polite solution now is it?
 
Also, Hello! fellow modder. I also develop mods and manage compatibility in some modpacks. I also work full-time as a Software Engineer, but thats not what this is about.
I work with Software Licenses and their restrictions on a weekly basis. If I find a library that fits my needs, but depends on several other libraries, there's no way in hell I'm gonna demand that the Project team makes a version that has no dependencies to fit my special use-case.
 
Same thing applies here.
 
And yes, IT IS the users responsibility to make sure the mods they choose to play with work  together. The mod authors clearly disclose what the mod needs in order to run. And what it doesen't work with. It is the users responsibility to make sure the mods they use fit in that profile.
 
Now I'm sorry to drag this discussion further but I felt compelled to write this reply.
I will also now cease discussion about this topic.
  • Like 1

Share this post


Link to post
Share on other sites

it is not possible to run this without CUP because it needs lots of bits and pieces they ported from A2.

 

i may be jumping the gun but if someone wants to make a compatibility patch for this, for non CUP users they could PM pook explaining what they can do. offers of help from sincere and talented individuals only please.  he may not want that though but it might convince him if someone else offers to bust their balls to fix the "problem" you guys have.

  • Like 3

Share this post


Link to post
Share on other sites

No worries eggbeast I was just replying to something specific and in no way was I saying the dependancy should be removed. I shall respond to kaukassus in pm to not further fill this thread with offtopic debate.

Share this post


Link to post
Share on other sites

About 1,5 km.

That's what I'm talking about. NASAMS and Pantsir can one shot each targets so why S300 can't!

And one more thing. It is not possible to get a laser lock by using lala14's TGP system on launchers or radars (at least S20. Don't know about others yet). Except vehicles like Tors. It can not find them as a target and every time I try to get a manual lock by pressing ctrl+T key on them, the pointer just goes away from targeted area. I think some parameters are not correct about them to make'em act as a normal target. Because with that TGP system it's even possible to lock on buildings by auto detect (spam T toward them) or manually.

 

You are the first person in the entire Galaxy to report that the SA20 and SA10 systems aren't TOO powerful  :)

 

I have to ask, are you experiencing this problem with "just" the CUP and this pack, or are there other addons in play?

 

THe "missile flys around in circles" behavior tells me that the plane wasn't properly "assigned" as a target to the launchers... that should never happen, unless there are script lag issues... was this a big mission?

 

THe "puff of smoke" behavior tells me the proximity fuse is going its job... that gives indirect fire damage.  To the point that most ? planes should become a flaming lawn dart.  Erratic flying may save you if you jink at the right time, taking only a little bit of damage.  I can increase damage, however everyone will bitch that these are one-shot-one-kill insanity rockets, so I have to balance it out.  More details on what you are doing will be helpful!

 

RE: unable to lock up a LALA? launcher?  The launchers in this pack are in the list... try it vs. for example an SA19 and let me know if it works.  I'm re-reading that sentence and I don't fully understand what you are trying to report?

 

Hey hcpookie, I´m trying to test this awesome mod (on the "target perspective") and so far wasn´t able to hear the RWR when your SAMs are engaging my jet (using with Firewills F-16C, spawned with MCC and using the code [_this, 5] addEventHandler ["incomingMissile", { _this execVM '\pook_SAM\scripts\incomingRWR.sqf'}]; )

 

I´d suspect something was wrong with the init code, and when I´ve tried to create a mission from scratch on the editor, when I add this to an air unit, I got an error "local variable in global space"... is this syntax alright?

 

[EDIT] I can hear the Vanilla RWR sounds (or ACE rwr if that´s the case)... I just can´t hear the custom RWRs you´ve added as the init code doesn´t work (syntax error), the editor doesn´t let me use them =)

 

I really want to make a proper Iron Hand mission with F-16s and F/A-18E/X trying hard to hit a SA-10 site... or die trying lol

 

cheers!

The volume settings may be wrong for A3.  I will have a look!

 

 

 

CRAP keep losing my edits.    THIS USES CUP. CUP IS INTENDED TO BE A "PARENT" MOD BASED ON THE MUCH-BELOVED A2 CONTENT.  IT IS TOO DIFFICULT TO ADD OTHER FACTIONS.  GEEZ!  LETS KEEP THE DISCUSSION ON POINT SHALL WE?

  • Like 4

Share this post


Link to post
Share on other sites

hcpookie >> 
If you want, I could post a small fix that makes all the units availible in Zeus, I did one for my own group. And its really easy to just add or substract units that you dont want to have in your Zeus, easy to update in future releases too. But only if you want to have it posted that is.

And BTW regarding the CUP; there are some units/factions that the CUP havent done already, its just a placeholder. So there are a lot of units/vehicles in this pack that is maned with normal CSAT as those are the placeholder that CUP has chosen. FYI.

I personally like that there are CUP, as my group is using it.. or I have made our repo and group to use it =P
But its all up to the modder; if he/she wants to have a mod that uses RHS CUP or MASSI for that matter; its all up to them.. no need to bash or so; if you dont want the mod for its dependencies; dont use it; no need to come to the forums and whine about it.

hcpookie>> your a rockstar that have been working your butt of with all this, porting from A2 to A3 is a feat on its own right ! Grats !

Share this post


Link to post
Share on other sites

hcpookie >> 

If you want, I could post a small fix that makes all the units availible in Zeus, I did one for my own group. And its really easy to just add or substract units that you dont want to have in your Zeus, easy to update in future releases too. But only if you want to have it posted that is.

And BTW regarding the CUP; there are some units/factions that the CUP havent done already, its just a placeholder. So there are a lot of units/vehicles in this pack that is maned with normal CSAT as those are the placeholder that CUP has chosen. FYI.

I personally like that there are CUP, as my group is using it.. or I have made our repo and group to use it =P

But its all up to the modder; if he/she wants to have a mod that uses RHS CUP or MASSI for that matter; its all up to them.. no need to bash or so; if you dont want the mod for its dependencies; dont use it; no need to come to the forums and whine about it.

hcpookie>> your a rockstar that have been working your butt of with all this, porting from A2 to A3 is a feat on its own right ! Grats !

Thanks for the comment!  Glad you & your group are enjoying it that much!  :D

 

I'm being told the Zeus thing just needs some class cfgPatches inclusions.  That being the case I can easily add all that stuff for the future.  I honestly used to add that all the time then stopped because I thought it was no longer being "really" used.

Share this post


Link to post
Share on other sites

This will be so much fun for my group, we are going for a QRF feel as a team. And this really makes it soooo much harder and fun =) 
Thanks man !

I msg you my PBO as a pastebin, so you see the easypeasie work that needs to be updated for the Zeus to work =)

Take care man, and thanks once again for the mod !

Share this post


Link to post
Share on other sites

Wonderful SAM....But the tail smoke effect should really be improved, expecting the next update.And may you could use Steam as your mod distribution platform. Thanks your works.

Share this post


Link to post
Share on other sites

@hcpookie, it is not a matter of volume, I can´t use the init code on an air unit for the custom RWR warnings

 

[_this, 5] addEventHandler ["incomingMissile", { _this execVM '\pook_SAM\scripts\incomingRWR.sqf'}]; 

 

cus this syntax gives me an editor error of "local variable in global space" and I can´t proceed.... could you verify the right syntax? 

 

Apart from that, everything is awesome, had a helluva brawl of a F-2, F16C, AV-8B, F/A-35 and (USAF mod) F-16C, all trying to clean a sam site with SA-10, SA-20, zsu-57, Tor and Pantsir-1 and in the end the sams won lol

 

cheers!

  • Like 1

Share this post


Link to post
Share on other sites

in the editor you cannot use the "_" before a "this" or it becomes a local variable not a global one. the EH itself uses local variables so retain the underscore. The editor placed vehicle is always global. maybe try:

 

[this, 5] addEventHandler ["incomingMissile", { _this execVM '\pook_SAM\scripts\incomingRWR.sqf'}];

 

or perhaps

 

[this] addEventHandler ["incomingMissile", { [_this,5] execVM '\pook_SAM\scripts\incomingRWR.sqf'}];

Share this post


Link to post
Share on other sites

Is there anyway to change the CUP requirement, we don't use it on our server because there is superior addons (RHS, HLC etc) and because of its size. I'm quite happy just to substitute the CUP crews/setup for vanilla atm.

Share this post


Link to post
Share on other sites

Is there anyway to change the CUP requirement, we don't use it on our server because there is superior addons (RHS, HLC etc) and because of its size. I'm quite happy just to substitute the CUP crews/setup for vanilla atm.

You might want to rephrase that, (RHS, HLC etc) are not necessary superior. They are just different mods, CUP is a different idea and uses default A3 values and is A2 content ported over. CUP will always be a requirement, as stated by the hcpookie:

 

 

CRAP keep losing my edits.    THIS USES CUP. CUP IS INTENDED TO BE A "PARENT" MOD BASED ON THE MUCH-BELOVED A2 CONTENT.  IT IS TOO DIFFICULT TO ADD OTHER FACTIONS.  GEEZ!  LETS KEEP THE DISCUSSION ON POINT SHALL WE?

 

Share this post


Link to post
Share on other sites

I recently installed this mod and I am having problems with it. How do I arm my aircraft to carry AR missiles. I am extremely confused to how this mod works and how to get the features working. If someone would make a mission with this SAM pack or a tutorial on how to set up this mission in the editor for the benifit of me and other people who may have problems I would be extremely grateful 

(I am using CUP weapons, units and CBA)

Thanks

Share this post


Link to post
Share on other sites

I recently installed this mod and I am having problems with it. How do I arm my aircraft to carry AR missiles. I am extremely confused to how this mod works and how to get the features working. If someone would make a mission with this SAM pack or a tutorial on how to set up this mission in the editor for the benifit of me and other people who may have problems I would be extremely grateful 

(I am using CUP weapons, units and CBA)

Thanks

 

did you read the guide? it's on page 57.

However it will require our missilebox to be ported in to work properly.  This is WIP.

Share this post


Link to post
Share on other sites

Thanks for the fast reply eggbeast, yes i looked at the guide but was slightly confused, do i just need to copy the 4 scrips from step 1 into the aircrafts initialization?

Share this post


Link to post
Share on other sites

well you cannot use the ARM function at the moment as the missilebox port needs to happen to allow you to add the weapons to the plane

I will be turning my attention to this pronto

Share this post


Link to post
Share on other sites

You might want to rephrase that, (RHS, HLC etc) are not necessary superior. They are just different mods, CUP is a different idea and uses default A3 values and is A2 content ported over. CUP will always be a requirement, as stated by the hcpookie:

Why would I need to rephrase my choice of words, opinion is subjective. Anyways I wasnt asking pook to redo the addons, merely point me in the right direction to edit it for my own needs.

Share this post


Link to post
Share on other sites

1. I have to ask, are you experiencing this problem with "just" the CUP and this pack, or are there other addons in play?

 

2. The "missile flys around in circles" behavior tells me that the plane wasn't properly "assigned" as a target to the launchers... that should never happen, unless there are script lag issues... was this a big mission?

 

3. The "puff of smoke" behavior tells me the proximity fuse is going its job... that gives indirect fire damage.

 

4. Erratic flying may save you if you jink at the right time, taking only a little bit of damage

 

5. More details on what you are doing will be helpful!

 

6. unable to lock up a LALA? launcher?  The launchers in this pack are in the list... try it vs. for example an SA19 and let me know if it works.  I'm re-reading that sentence and I don't fully understand what you are trying to report?

1. I've tested with just CUP and mixed addons, both. However I've found under different circumstances different result would come out. Like different targets/altitude/distance.  

2. Just put a Patriot site (specially) or SA10/20 site in the Editor and use some flying drones as the target (as most of real AA systems use UAVs for testing) . Enjoy the show.

3. Well I saw them just hit target and then there was the explosion. but I saw a lot of "proximity fuse" for AA shells (23mm , etc) :)

4. It's not hard to avoid them

5. Put them (just as a site as you made) in editor (VR map) and put multiple flying targeting against them. I've found NASAMS and Pantsir most dangerous AA missile system (very fast and accurate) while big things failed to amuse me. Targets range was about 2km/alt 500m and they were: SU-25, Drones, AC-130/KC-135/AWACS/B-2 from USAF 2015 mod as it is best air units pack for ArmA3 for now (it's a must have addon)

6. Lala14 is a BIS community member whom made the only self target lasing script available (init file) for planes (main idea by geraldbolso1899) so the pilot can whether lock onto targets (even building) by spamming lock key (Default "T") toward them for manually by pressing Ctral+T to lock on moving/static targets or simply the ground and release laser lock required armaments like LGBs and missiles. Some other addon makers used this system too. Like Firewill's F-14,F-15,F-16 and F-2 or AV-8 by another author possibly future projects. The AA sites (SA20 that I've tested, maybe all of them) act weird against it. You may test it yourself as you are getting familiar to ArmA3 

Associated topic:

https://forums.bistudio.com/topic/169324-release-script-tgp-targeting-pod-for-air-vehicles/ 

 

And just to mention:

- Some times as soon as I release missiles, bombs (even free falls), even fire cannon off a plane to hit an AA site, that ammunition explodes right in my face!!!! It's creepy when my own cannon rounds explode right in front of me like 2 or 3 meters away. It's like I'm hitting an invisible barrier that my plane is stuck inside of it.

 

- C-RAM's sound when it's finished firing should play sooner and not just start after that.

 

- ZU-23 uses two 50x 23mm ammo cartridges that makes it 100 rounds not just 40! and every 5 or 8 round shoots a tracer. I used to be a ZU-23 operator in the army service.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×