Jump to content
rsoftokz

[SP] ROADS for RAVAGE

Recommended Posts

can't play on chernarus_winter

 

downloadable content that has been deleted.xcam_source ??

 

Have the same issue. Worked on normal Chernarus but I keep getting killed as soon as I get close to the first town. 

Share this post


Link to post
Share on other sites

I checked the mission.sqm and yes xcam let a track on the files for chernarus Summer and winter .

The quickest fix is to decompile the pbo, open and edit mission.sqm, remove "xcam source" and the , at the end of the last line left then.

Safe the file, close it

Recompile the pbo and it is done

I had internet connection failure at home, so I can't update the Google drive links for now.

I'll do my best to do it faster as I can

And then see with armaholic guys to fix their link too

Sorry for the matter

From my iPhone

Rsoftokz

Share this post


Link to post
Share on other sites

I'm really enjoying this mission. Found my first survivors today. One snuck up on me while I was reading my map and scared the bejeezus out of me. I thought he was one of those grenade-tossing mofos who always kill me.

 

One thing: Is it at all possible to disable the sandstorm (i.e., through the console)? I find the way it constantly stops and starts more annoying than atmospheric and it kind of plays havoc with my frame rate. If not, maybe it could be an option, similar to how the colour overlay is an option.

  • Like 1

Share this post


Link to post
Share on other sites

just signed up to say a big thanks, to you and of course haleks, this mod/mission is fantastic, can't wait for more!

Share this post


Link to post
Share on other sites

Just a heads up,latest Cherno Packs work fine,but the Altis mission has majority of camps in the sea?

Share this post


Link to post
Share on other sites

@Jelkalen: you're welcome, Thanks for your support.

 

@miasdad.

 

I'll have to check for this; might be an error  from my side, I dropped the files in an hurry..... I never went back on them since, not much time those days....
 

I'll try to check  this week end.

thank you for  reporting.

  • Like 1

Share this post


Link to post
Share on other sites

Has there been a fix for the AI spawning with no weapons? When i find a camp usually only 2 guys have rifles the rest have either bino's or nothing at all. :(

Share this post


Link to post
Share on other sites

   I started a new mission last night and noticed that some guards at an outpost (with campfires) were animated as carrying rifles but no rifles were visible. I then started scanning through the suggested mods to use. I stopped when I got to the Russian weapons because I thought that CUP now has all of these items collective in their downloads. Could I get a clarification so I don't get duplicates please?

 

edit:  Could this be my answer?..................(copy/paste from download page)

 

known issues

 

- Lights "ON" on Chernarus map and some RAVAGE functions to spawn AIs not working because of "missing location" error on CUP_TP and Chernarus maps.

- starting mission  without burning  truck and dead buddy on Chernarus maps: restart the mission.

_ unable to save on start: restart the mission.

- error messages linked to CUP mod ( animation missing): click OK and go on playing mission.

- error messages linked to A3 weapons recoil since 1.54 update: click OK and go on playing the mission.

-some weapons dissapear once bandits killed since 1.54 update  -- MP-5 / UMP from FFAA

- weapons wobble and slide away from bodies or float upon body since 1.54 update  -- HLC and FFAA

- missing weapons on some spawned AIs since 1.54 update
- FPS drop in some case due to large amount of objects added on the map. might require some tweaking on game settings
- music will not play on mission Start .
- actual implanted chemlight system (attached to player) menu will fail to work fine fixed: function inclued in RAVAGE
- desynchronization at the intro (sound/anim ) due to CPU/GPU charge (on basic PC with budget GPU card)

Share this post


Link to post
Share on other sites

@rsoftoks: I hope you don't mind if I ask you a few mission making questions: 

 

1) I'm not sure if the original RAVAGE missions from haleks have a quicksave function via radio, but ROADS has it.  I could't find out how you did it, though, and would be glad if you could show me the ropes on this one so I can build it into my RAVAGE SP missions. 

 

2) What exactly do I need if I want the trash heaps to be lootable? Is it necessary to define manually in a script file which items will appear in the trash loot and will this script you use influence the basic RAVAGE loot modules for spawn probability as well?

 

Thanks in advance for your help,

 

tourist

Share this post


Link to post
Share on other sites

Does anyone know why the vegetation twitches, and is anyone else seeing this?

 

https://youtu.be/AmJhfrDKwEo

Looks like the weather settings, or at least the wind parameters, are being reset every x seconds.

Probably a script command that needs to be removed from a loop.

Share this post


Link to post
Share on other sites

   I started a new mission last night and noticed that some guards at an outpost (with campfires) were animated as carrying rifles but no rifles were visible. I then started scanning through the suggested mods to use. I stopped when I got to the Russian weapons because I thought that CUP now has all of these items collective in their downloads. Could I get a clarification so I don't get duplicates please?

 

edit:  Could this be my answer?..................(copy/paste from download page)

 

known issues

 

- Lights "ON" on Chernarus map and some RAVAGE functions to spawn AIs not working because of "missing location" error on CUP_TP and Chernarus maps.

 

"Lights on" as in street lamps?That is something I noticed in CUP TP..streetlights not working (even w/o Ravage).Whereas In AIA TP they worked.

Share this post


Link to post
Share on other sites

 

Does anyone know why the vegetation twitches, and is anyone else seeing this?

 

 

Looks like the weather settings, or at least the wind parameters, are being reset every x seconds.

Probably a script command that needs to be removed from a loop.

 

   Thanks for the tip. Unfortunately If that is the cause, I wouldn't have the slightest idea where to start looking to make the change.

Just by way of adding some information:

I tested Altis with only CBA and Ravage mod enabled,........Still twitches

I tested Chernarus with only CBA, Ravage, and Cup Terrains,........no twitching

???

Share this post


Link to post
Share on other sites

I assumed it was caused by a script from this mission, but, reading you, the problem might be elsewhere...

Did you have the weather module turned on? I'll run a few tests today on my end.

Share this post


Link to post
Share on other sites

Did you have the weather module turned on?

   Now when you say "the", I would take it to mean that there is one either in the ROADS mission, CBA, or Ravage itself. I'm unaware of a weather mod/setting in any of these three but then again I'm unsure. Anxious to here what your tests show. Incidentally I deleted my existing ROADS files I initially used, and downloaded the pack which has the four mapped versions, with the same results.

Thanks for looking into this as I enjoy long sagas such as these.

Share this post


Link to post
Share on other sites

Hi Guys, sorry for the late replies, I'm off Arma , far from Roads and other stuff because i'm busy elsewhere (24H a day is too short  ;)  )

 

so...

-I didn't have time to see if there is an issue in the latest pack on Altis about camps in the sea....

 

-No fix neither for the missing weapons:  not much time, no really any idea about "what does this" except it might be the script about modifying the "gearlist". It is scripted with a list of weapons from several mods, it shouldn't bring "no dependency" with those mods for the mission.
the fact is I'm not sure the way i scripted this, it would replace any random weapon firstly chosen in the list from a Mod that is not installed by one of an installed mod... so as the mod is missing, the AI just spawn without any gun.
as I already told, it is some kind of oddity that is not really a mess as "IRL" you might meet unarmed survivors/bandits/whatever they're named because weapons should be "rare".

 

- CUP weapons pack has been installed a few weeks ago on my PC, after the last update I made, so there is no scripted list for CUP weapons (It should be on the next update)

 

- the Random spawning system is into the "script\intro.sqf, as it is in the original RAVAGE demo mission. there are several spawn points placed in the Editor, all named "spawnx" where "x" is a number, 1, 2, 3.... as many as the number of spawn points you want to place.
you can name them also with names of places you choose on the map. then adapt the script lines with the proper names.

 

- the trash loot system is made with several sqf.files . one for the system itself (how it works), one with all the settings (the class names of places to search, the class names and categories of objects to spawn, setting about distances  to spawn loot/clear loot , percentage to find something-noting...etc. and some other settings and one hpp files for the UI system (the little timing icon while searching).

the only modifications you can bring is about the class names of places and items to spawn if you want ( beware you can break the system if you script wrongly )

 

_ when I ported ROADS to Chernarus, I firstly did it on Chernarus Winter with the "alpha" CUP terrains pack: RAVAGE system to switch off all the lights on a map worked perfectly then, same for random spawning of squads here and there.
then came the "beta" release of Cup Terrains Pack (CUP core and CUP maps ) and then the RAVAGE locations.sqf was unable to work: all lights were "ON" in every town and village....
I was able to cross the map  in all direction for hours without meeting any squad, renagae or survivor , except the one placed with triggers in camps....... <_<  -_- ....
Unfortunatly, I didn't have time to see if there was any update nor to test further the missions on every maps....still "only" 24 hours a day....

 

- vegetation twitches is created by the "sand storm" SFX script on Altis (removed for Chernarus maps ). I noticed this when I tried to work on a system to activate/deactivate it a few weeks ago before I have to move away form all Arma projects , but with mitiged success (I can activate the non activated effect, I'm unable to stop it once it is started.... I might remove it from the mission on further update. it is made by the "tornado sfx" setting in GOON's script ...... less noticable into his "snow storm" script he made also...
Winter map mission has a third party "random weather system" with "snow" effects. all other missions are working with RAVAGE weather module.


Hope to be back soon.

thank you for all your messages and comments.

so thank you for the time spent to check it, Haleks, but it is not on RAVAGE side.

  • Like 1

Share this post


Link to post
Share on other sites

 

vegetation twitches is created by the "sand storm" SFX script on Altis

...Thanks buddy. Quick fix and perfectly enjoyable! Keep up the good work.

Share this post


Link to post
Share on other sites

any chance you could add respawn (in random locations preferably) it's a bit annoying to have to restart the entire mission every time you die

Share this post


Link to post
Share on other sites

 

it's a bit annoying to have to restart the entire mission every time you die

? You can "save" game when ever you wish. Hit esc and select save. You might have to go into Arma game settings and check to allow save game. There is also a save game mod but I have never used it.

Share this post


Link to post
Share on other sites

@ thecoolsideofthepillow

 

   Spawning is random as you are probably aware but if you are being hounded by bandits "every" time, I don't know what to tell you. Just run like hell I suppose. I have spawned completely alone, AND with bandits showing up shortly afterward. I've spawned in the woods and near towns, just luck of the draw.

   Ammo that you can use at spawn, again, I think it's random. I can't recall ever having ammo I could use until I found it along the way.

 

Stay frosty Sergeant !!! :16_6_8:

Share this post


Link to post
Share on other sites

If it's an escape I must make, then one I shall do. I just hope I don't run right into them because it's night again.

 

Or I'll just install that CQC mod so I can sneak around and break their necks. >:)

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×