Jump to content

Linux dedicated server: Mission will immediately restart after start

Recommended Posts

I'm having some problems hosting a dedicated Arma 3 server on linux. I set the server up following this guide: https://community.bistudio.com/wiki/Arma_3_Dedicated_Server#Instructions_.28Linux_o.2Fs.29


The server used to work like that until several months ago, but when I'm trying to use it again now, I cannot get any missions started. As a player, I can connect, select a mission and press OK, but once the mission finishes loading, I find themselves back in the lobby again. If I keep pressing OK to start the mission, this will continue indefinitely.


The server is running under Ubuntu 14.04.3 LTS 32 bit. (I chose the 32 bit version because Arma 3 itself is 32 bit, so I thought this might lead to fewer compatibility problems.)


I originally encountered the problem trying to play a custom mission with a large number of third-party mods, but to debug the problem better, I ran the server without mods and with BI missions only.


This is the server.cfg:

passwordAdmin = "<censored>";
//password = "<censored>";
hostname = "TMSCTI";
maxPlayers = 160;
motd[]= {"Welcome to our TMSCTI server"};

voteThreshold = 1.1;
voteMissionPlayers = 1;
kickduplicate = 0;
logFile = "server_console.log";
persistent = 1;
verifySignatures = 0;

allowedLoadFileExtensions[] = {"hpp","sqs","sqf","fsm","cpp","paa","txt","xml","inc","ext","sqm","ods","fxy","lip","csv","kb","bik","bikb","html","htm","biedi"};
allowedPreprocessFileExtensions[] = {"hpp","sqs","sqf","fsm","cpp","paa","txt","xml","inc","ext","sqm","ods","fxy","lip","csv","kb","bik","bikb","html","htm","biedi"};
allowedHTMLLoadExtensions[] = {"htm","html","xml","txt"};

forceRotorLibSimulation = 1;

disableVoN = 1;

The command line used to start the server was this:

./arma3server -config server.cfg -mod=

The console output from the server can be found here: http://arma-tms.de/screenlog.0

(It's a bit too large to paste here verbatim.)


I've also tried setting up a completely brand new virtual server following the original guide, but this lead to the same problem.


Could someone help me with that?



Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now