Jump to content
stowed4sea

CSAT won't engage NATO?

Recommended Posts

I'm new to editing and need a little help.

 

I'm creating my second mission.  On my first I used Independents and set them unfriendly in the intel section, so they engaged me right away.  However, in my second mission, it is OPFOR vs NATO and OPFOR won't engage me until I kill one of their units no matter what I set the troop behavior as.

 

I cannot find where to set them up as enemies.

 

I'm sure this has been asked before but I cannot find it despite numerous searches, I'm probably using the wrong lingo.

 

Thanks for the help.

Share this post


Link to post
Share on other sites

CSAT is enemy for NATO by default.

 

Look into your mission init or other scripts for custom defined setfriend.

Share this post


Link to post
Share on other sites

That's some hippy sh*t.. :lol:

 

Yeah, you should look for custom scripts and commands.

  • Like 1

Share this post


Link to post
Share on other sites

I'll take a look later on tonight.  

 

However, if they are enemies by default, what did I screw up to make them friends?  I mean I landed my NATO helicopter in the middle of the CSAT base where guys were patrolling around with many AA weapons all over the place.  Nobody even glanced at me until I exited the chopper and killed one of them.

 

I am not too familiar with script editing, so I didn't go into any of that language stuff to edit anything, I have just been using the default triggers and modules to make my mission.  Whenever I clicked on a button that brought up lines of code, I got scared and cancelled/exited immediately. I'd like to know what I did so I don't do it again if anyone had any extra ideas.

Share this post


Link to post
Share on other sites

Did you place them on the map via the virtual arsenal?

Share this post


Link to post
Share on other sites

Check the intel section of the 2d editor for the friendly conditions at  the bottom of the dialog box.

I opened up the intel editor, and all it has a spot for is "Independents are friendly to: ..."  That's how I got the first mission to work, but on this mission there aren't any independants, just OPFOR and NATO and they seem to be friends.

 

 

Did you place them on the map via the virtual arsenal?

I'm not sure what the virtual arsenal is.  I placed them on the map by clicking the group button, then infantry then selected the various groups I wanted from there.

 

 

 

 

 

 

Several others have asked looking at my custom scripts.  Well, I tried and I don't really have a clue what any of that means.  I tried finding something familiar that would call out what units are enemies but couldn't locate anything like that.  Could anyone point me toward the right direction here?

 

Thanks all for all the responses.

Share this post


Link to post
Share on other sites

Have you set OPFOR's waypoint behaviour to 'careless' or combat mode to 'never fire'?

Share this post


Link to post
Share on other sites

your looking for something along the lines of setFriend

Is this located in the Functions Viewer or am I looking somewhere else?  I saw several other things in the functions viewer with the prefix set..., but not setFriend.  I'm using the editor in game to try and find these things, should I be looking somewhere else?

 

Have you set OPFOR's waypoint behaviour to 'careless' or combat mode to 'never fire'?

Nope, I've set them to safe, hold fire-engage at will.  But just to be sure I've tried every other combination as well.

Share this post


Link to post
Share on other sites

Could you upload your mission, so we could have a look?

Well, I was going to, but I decided that my mission was just too big and was working on breaking it into several smaller missions.  I noticed that after I took 90% of the troops off the map, now CSAT engages properly.  I had several hundred troops on the map.  Could too many troops cause any kind of odd behavior in the AI logic?  I've tested multiple times and all seems working properly now. 

Share this post


Link to post
Share on other sites

I believe too many troops can cause an issue like that, I seem to remember in the past I have also had it.  There is also a limit on how many groups you can have on the map which is 144 I think.

As stated by magicpanda, EOS is brilliant and well worth a look at. It might look complicated at first, but it really isn't.

Share this post


Link to post
Share on other sites

I believe too many troops can cause an issue like that, I seem to remember in the past I have also had it.  There is also a limit on how many groups you can have on the map which is 144 I think.

As stated by magicpanda, EOS is brilliant and well worth a look at. It might look complicated at first, but it really isn't.

I'll take a look.

 

Thanks a lot to all who have helped me out on this issue.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×