Jump to content

Recommended Posts

1 hour ago, wansec_6 said:

G'day @Richards.D,

 

Really liking how the new GMV is coming along. Have been using the Dev branch version over the last couple of days and am loving it. Will it have multiple liveries to match the other SOF assets available?

 

 

Keep up the great work. Looking forward to the M134 variant.

 

Hello,

 

Yes, it will have a WD camouflage pattern as well. I don't know if we'll do a "deployment" cam similar to the MATV, that one didn't turn out very well and looked a bit ugly. But perhaps we'll do one, not sure yet. 

Share this post


Link to post
Share on other sites

is the SAG-2 going on anything else? would be cool on the mrap 

Share this post


Link to post
Share on other sites

No plans to put it on anything else unless research material comes up depicting it on vehicles other than GMVs

Have only ever seen M153 CROWS on MRAPs used by SOCOM, so it's very unlikely we'll put SAG-2 on any of them

Share this post


Link to post
Share on other sites
22 hours ago, Richards.D said:

Assaulter up! The M1165A1 Ground Mobility Vehicle (GMV) provides protection, firepower, and cross-country mobility to Special Operations Forces (SOF) Assaulters, Operators, and Supporters across a variety of missions.

 

That looks great!  I believe it was you who said, in the past, that there was some effort to "muddy up" tires on the various vehicles.  Is that still on the to-do list or was any progress made (even if it's isn't ready for public consumption yet)?

 

Regardless, looking forward to the update!

Share this post


Link to post
Share on other sites
6 hours ago, gatordev said:

 

That looks great!  I believe it was you who said, in the past, that there was some effort to "muddy up" tires on the various vehicles.  Is that still on the to-do list or was any progress made (even if it's isn't ready for public consumption yet)?

 

Regardless, looking forward to the update!

 

Yeah, so it is, but we haven't made any progress. Vehicles like this have new baked wheels and are GTG, but things like the MATV have kind of crappy wheels that we want to eventually redo. 

Share this post


Link to post
Share on other sites
6 hours ago, Richards.D said:

 

Yeah, so it is, but we haven't made any progress. Vehicles like this have new baked wheels and are GTG, but things like the MATV have kind of crappy wheels that we want to eventually redo. 


So, I guess it's not like you don't know how to achieve this. It seems you want to utilize UV animations for the wheels, chassis, and part of its body? Have you been considering Spintires/Mafia-like tech, ie. the muddy version of the wheel being scaled up gradually to cover the actual wheel? The latter would not force you to wait for wheels to be reworked in other vehicles, I suppose. 

Share this post


Link to post
Share on other sites

Good day, RHS team!

 

I read a few pages above, it looks like the problem with jumping and flipping vehicles is not discussed at all. This is very strange since I cannot play for more than 10 minutes with the RHS wheeled vehicles in order not to encounter such a problem.

 

This is an RHS only problem, because it doesn't happen with vanilla vehicles.  

I have tried placing APC of both sides on the map. For example, from AFRF side it was BTR-80 and any modifications thereof, from USAF side it was M1126 (M2) and others. Always, sooner or later, I got this problem.

Note, I put the RHS wheeled vehicles ( usually using vanilla maps, like Altis, Stratis, Malden ), they can bounce or roll over after a few minutes of gameplay - sometimes this happens even without the movement of vehicles, i.e. when they are idle!

 

Also, for customisation, I tried to put the RHS transport even in a virtual garage, but even there the vehicles turn over! 

As I can guess, the physics parameters conflict with the last update of the PhysX libraries which were made relatively recently in Arma3.  Maybe I'm wrong and there is another reason.

Please try solve this problem, unfortunately it is not possible to play today using RHS vehicles without such problem. 

Try updating their configurations, see how the configurations have changed for the vanilla vehicles, I repeat that the vanilla vehicle has no such problem.

 

As a reproduction of the problem, I can suggest placing 2-4 opposing mechanized infantry groups on the map and observing them, within a 5-10 min

 

About my version of RHS. I have a Steam subscription, this is the stable version. Several weeks ago, I was forced to temporarily disable RHS, No updates since then

  • Like 1

Share this post


Link to post
Share on other sites
48 minutes ago, mickeymen said:

Good day, RHS team!

 

I read a few pages above, it looks like the problem with jumping and flipping vehicles is not discussed at all. This is very strange since I cannot play for more than 10 minutes with the RHS wheeled vehicles in order not to encounter such a problem.

 

This is an RHS only problem, because it doesn't happen with vanilla vehicles.  

I have tried placing APC of both sides on the map. For example, from AFRF side it was BTR-80 and any modifications thereof, from USAF side it was M1126 (M2) and others. Always, sooner or later, I got this problem.

Note, I put the RHS wheeled vehicles ( usually using vanilla maps, like Altis, Stratis, Malden ), they can bounce or roll over after a few minutes of gameplay - sometimes this happens even without the movement of vehicles, i.e. when they are idle!

 

Also, for customisation, I tried to put the RHS transport even in a virtual garage, but even there the vehicles turn over! 

As I can guess, the physics parameters conflict with the last update of the PhysX libraries which were made relatively recently in Arma3.  Maybe I'm wrong and there is another reason.

Please try solve this problem, unfortunately it is not possible to play today using RHS vehicles without such problem. 

Try updating their configurations, see how the configurations have changed for the vanilla vehicles, I repeat that the vanilla vehicle has no such problem.

 

As a reproduction of the problem, I can suggest placing 2-4 opposing mechanized infantry groups on the map and observing them, within a 5-10 min

 

About my version of RHS. I have a Steam subscription, this is the stable version. Several weeks ago, I was forced to temporarily disable RHS, No updates since then

Can you please make a video of such behavior. We had no other reports of it and surely if this was so unplayable we would have e heard. Please make sure you do not load with any other mods and for the future please use our feedback tracker.

  • Like 1

Share this post


Link to post
Share on other sites

I try to add silencer to Orsis t5000 but my config don`t work. Can someone help me?

And I know Orsis IRL don`t have silencer

Spoiler

class CfgPatches
{
	class Orsis_silencer
	{
		units[] = {};
		weapons[] = {"rhs_weap_orsis_Base_F","rhs_weap_t5000"};
		requiredVersion = 0.1;
		requiredAddons[] = {"rhs_c_weapons"};
	};
};
class Mode_SemiAuto;
class MuzzleSlot;
class CfgWeapons
{
	class rhs_weap_orsis_Base_F;
	class rhs_weap_t5000: rhs_weap_orsis_Base_F
	{
		class WeaponSlotsInfo;
		class Single: Mode_SemiAuto
		{
			sounds[] = {"StandardSound","SilencedSound"};
			class BaseSoundModeType;
			class SilencedSound: BaseSoundModeType
			{
				begin1[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_01",1.0,1,300};
				begin2[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_02",1.0,1,300};
				begin3[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_03",1.0,1,300};
				soundBegin[] = {"begin1",0.333,"begin2",0.333,"begin3",0.333};
				class SoundTails
				{
					class TailInterior
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_interior",1.0,1,300};
						frequency = 1;
						volume = "interior";
					};
					class TailTrees
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_trees",1.0,1,300};
						frequency = 1;
						volume = "(1-interior/1.4)*trees";
					};
					class TailForest
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_forest",1.0,1,300};
						frequency = 1;
						volume = "(1-interior/1.4)*forest";
					};
					class TailMeadows
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_meadows",1.0,1,300};
						frequency = 1;
						volume = "(1-interior/1.4)*(meadows/2 max sea/2)";
					};
					class TailHouses
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_houses",1.0,1,300};
						frequency = 1;
						volume = "(1-interior/1.4)*houses";
					};
				};
			};
		};
	};
	class rhs_weap_orsis_Base_F: rhs_weap_t5000
	{
		class WeaponSlotsInfo: WeaponSlotsInfo
		{
			class MuzzleSlot: MuzzleSlot
			{
				linkProxy = "\A3\data_f\proxies\weapon_slots\MUZZLE";
				compatibleItems[] = {"muzzle_snds_93mmg","muzzle_snds_93mmg_tan"};
				iconPosition[] = {0.0,0.43};
				iconScale = 0.2;
			};
		};
	};
};

 

the last error I have is line 77 Cfgweapons.rhs_weap_orsis_Base_F:already defined

  • Confused 1

Share this post


Link to post
Share on other sites
5 hours ago, sammael said:

I try to add silencer to Orsis t5000 but my config don`t work. Can someone help me?

And I know Orsis IRL don`t have silencer

  Hide contents


class CfgPatches
{
	class Orsis_silencer
	{
		units[] = {};
		weapons[] = {"rhs_weap_orsis_Base_F","rhs_weap_t5000"};
		requiredVersion = 0.1;
		requiredAddons[] = {"rhs_c_weapons"};
	};
};
class Mode_SemiAuto;
class MuzzleSlot;
class CfgWeapons
{
	class rhs_weap_orsis_Base_F;
	class rhs_weap_t5000: rhs_weap_orsis_Base_F
	{
		class WeaponSlotsInfo;
		class Single: Mode_SemiAuto
		{
			sounds[] = {"StandardSound","SilencedSound"};
			class BaseSoundModeType;
			class SilencedSound: BaseSoundModeType
			{
				begin1[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_01",1.0,1,300};
				begin2[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_02",1.0,1,300};
				begin3[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_03",1.0,1,300};
				soundBegin[] = {"begin1",0.333,"begin2",0.333,"begin3",0.333};
				class SoundTails
				{
					class TailInterior
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_interior",1.0,1,300};
						frequency = 1;
						volume = "interior";
					};
					class TailTrees
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_trees",1.0,1,300};
						frequency = 1;
						volume = "(1-interior/1.4)*trees";
					};
					class TailForest
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_forest",1.0,1,300};
						frequency = 1;
						volume = "(1-interior/1.4)*forest";
					};
					class TailMeadows
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_meadows",1.0,1,300};
						frequency = 1;
						volume = "(1-interior/1.4)*(meadows/2 max sea/2)";
					};
					class TailHouses
					{
						sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_houses",1.0,1,300};
						frequency = 1;
						volume = "(1-interior/1.4)*houses";
					};
				};
			};
		};
	};
	class rhs_weap_orsis_Base_F: rhs_weap_t5000
	{
		class WeaponSlotsInfo: WeaponSlotsInfo
		{
			class MuzzleSlot: MuzzleSlot
			{
				linkProxy = "\A3\data_f\proxies\weapon_slots\MUZZLE";
				compatibleItems[] = {"muzzle_snds_93mmg","muzzle_snds_93mmg_tan"};
				iconPosition[] = {0.0,0.43};
				iconScale = 0.2;
			};
		};
	};
};

 

the last error I have is line 77 Cfgweapons.rhs_weap_orsis_Base_F:already defined

I guess it should be quite obvious what is wrong now

 

obraz.png

  • Like 2
  • Haha 1

Share this post


Link to post
Share on other sites
1 hour ago, reyhard said:

I guess it should be quite obvious what is wrong now

Spoiler

class CfgPatches
{
    class Orsis_silencer
    {
        units[] = {};
        weapons[] = {"rhs_weap_orsis_Base_F","rhs_weap_t5000"};
        requiredVersion = 0.1;
        requiredAddons[] = {"rhs_c_weapons"};
    };
};
class Mode_SemiAuto;
class MuzzleSlot;
class CfgWeapons
{
    class Rifle_Base_F;
    class rhs_weap_orsis_Base_F: Rifle_Base_F
    {
        class WeaponSlotsInfo;
        class Single: Mode_SemiAuto
        {
            sounds[] = {"StandardSound","SilencedSound"};
            class BaseSoundModeType;
            class SilencedSound: BaseSoundModeType
            {
                begin1[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_01",1.0,1,300};
                begin2[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_02",1.0,1,300};
                begin3[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_short_03",1.0,1,300};
                soundBegin[] = {"begin1",0.333,"begin2",0.333,"begin3",0.333};
                class SoundTails
                {
                    class TailInterior
                    {
                        sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_interior",1.0,1,300};
                        frequency = 1;
                        volume = "interior";
                    };
                    class TailTrees
                    {
                        sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_trees",1.0,1,300};
                        frequency = 1;
                        volume = "(1-interior/1.4)*trees";
                    };
                    class TailForest
                    {
                        sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_forest",1.0,1,300};
                        frequency = 1;
                        volume = "(1-interior/1.4)*forest";
                    };
                    class TailMeadows
                    {
                        sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_meadows",1.0,1,300};
                        frequency = 1;
                        volume = "(1-interior/1.4)*(meadows/2 max sea/2)";
                    };
                    class TailHouses
                    {
                        sound[] = {"A3\Sounds_F_Mark\arsenal\weapons\LongRangeRifles\DMR_05_Cyrus\silencer_DMR_05_tail_houses",1.0,1,300};
                        frequency = 1;
                        volume = "(1-interior/1.4)*houses";
                    };
                };
            };
        };
    };
    class rhs_weap_t5000: rhs_weap_orsis_Base_F
    {
        class WeaponSlotsInfo: WeaponSlotsInfo
        {
            class MuzzleSlot: MuzzleSlot
            {
                linkProxy = "\A3\data_f\proxies\weapon_slots\MUZZLE";
                compatibleItems[] = {"muzzle_snds_93mmg","muzzle_snds_93mmg_tan"};
                iconPosition[] = {0.0,0.43};
                iconScale = 0.2;
            };
        };
    };
};
 

Thank you. Everything worked now. Now a silencer has appeared in the game and it works. The question is, is it possible to make it physically visible on the barrel?  If so, what should be added to the code?

Share this post


Link to post
Share on other sites

The rifle doesn't contain a proxy for a suppressor, so no model will show regardless of what you do to the config

  • Like 3

Share this post


Link to post
Share on other sites

Yeah. During the past day or two while Richards and I were looking for reference images on how the feed chute might be arranged for the M134 in the GMV turret (there was a dev Branch update today where you can see how the M134 GMV is going), we did come across a few photos and videos of those Green Beret M-ATVs with M134s in a SAG turret, which was news to us.

 

Richards said we might look at doing this version in future when we have more time (current focus is on finishing a few things rather than adding more stuff). The rhsusf_matv.pbo is getting quite hefty though, so I don't think we'll do more than this one extra variant if it happens

  • Like 2

Share this post


Link to post
Share on other sites

Yea all good.

looking forward to the update I have not seen the latest dev build of USAF but AFRF is looking great

Unfortunately I am willing to bet it comes out just as we finish our cold war campaign 🤷‍♂️ ah well Murphys law.

Share this post


Link to post
Share on other sites

G'Day @da12thMonkey,

 

I was just checking out the latest USAF dev update following your comment above and was unable to locate a GMV with an M134 mounted. Is it hidden perhaps?

Share this post


Link to post
Share on other sites

No, it's definitely there in the public dev branch. Should be right above the M2 version in Eden and the Garage

See messages on the previous page about needing to run launcher "repair" on some subscribed mods to force updates if you think something isn't right.

 

Workshop/Launcher seems to have gone to hell with regard to actually checking that mods are up to date and initialising downloads lately. I only just received the latest update to PSZ mod the second time I opened Arma 3 launcher this morning, when apparently the workshop item was updated in the middle of yesterday evening.

  • Like 1

Share this post


Link to post
Share on other sites

G'day @da12thMonkey,

 

Just had a chance to refresh/repair the dev branch and had a look at the M134 GMV. Very nice work. Looking forward to the completed vehicles. 

Just a quick question, will there be a Mk19 equipped version, or are Mk19's not used by SF?

Share this post


Link to post
Share on other sites

It's not something we had any intention of doing because as you say, the Mk19's seems to be increasingly absent among SOF units. Over the past 10-15 years the Mk19 seems to have been almost entirely superseded by the Mk47 so far as a crew-served GMG/AGL goes (I imagine it's still retained for CROWS and some other uses however). So it was considered to be a rather superfluous variant of the GMV to include.

 

However there are a few recent photos floating around of M1165A1 GMVs with Mk19, and we changed the way the GMVs are organised as a .pbo in the mod, which gave us some extra leeway from some technical concerns we had about file size, .pbo packing time, and model.cfg bone limits in rhsusf_m11xx.pbo. So yeah in the end, I spent this evening making a Mk19 carrier version with Richards' approval.

  • Like 8

Share this post


Link to post
Share on other sites

G'day @da12thMonkey,

 

Thanks for the feedback. Looking forward to seeing the new version in game. How are you progressing with the ammo feed chute for the M134?

Share this post


Link to post
Share on other sites

Question, I am flying Mig-29SM, I have Kh-29T (TV Missile) equiped. But when ever I ctrl+right click. It opens the targeting for the missile, but the monitor is unreadable. Is his a bug or am I doing something wrong? A-10 seems to be working fine for me I think
 

Spoiler

12344444.jpg

 

  • Like 1

Share this post


Link to post
Share on other sites

I watch the dev-branch today. AN 94 will come trly? WOW!!!!

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, t.g.1911 said:

I watch the dev-branch today. AN 94 will come trly? WOW!!!!

 

I'd rather a basic bob SVD but "Russian clockwork and pulley magic" is welcome too )

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×