Jump to content

Recommended Posts

3 hours ago, EO said:

@damsous, I'm not sure I understand your "bug" report, but going by the screenshots you don't own the Apex expansion? That particular uniform, the long sleeve/high neck uses a model from the CTRG faction from Apex Expansion and must be regarded as Premium content. :icon_cry:

No i don't have apex but its an uniform and i can grab it, only the weapon and vehicle are locked. The weaponholder show a body wearing the uniform, can only be equiped in backpack slot, and there is weird graphic bug, check the screenshoot :

-1st screen its the uniform weapon holder, not a corpse, but the uniform weapon holder show a body.

-2nd screen its just for showing wich item is bugged.

-3rd screen there a weird graphic glitch, there is an other extented neck on the top of my head + just the eyes, i can show you more screen if you need

Share this post


Link to post
Share on other sites

Thats weird i just try it by equiping it in the arsenal everything works fine no bug and the weapon holder is correct, thats should probably be an issue with the loot script, btw i just make a quick video to show you :

 

  • Haha 1

Share this post


Link to post
Share on other sites

To be honest I've no idea what's going on there, but it doesn't look pleasant. ^^

I believe Premium Content can be equipped in the Arsenal without issue as it's a kind of "try before you buy" kind of thing.  Isn't it just the case that because you don't own Apex you can't equip the uniform in the uniform slot because....you don't own Apex.

Other than that, the only strange thing I see from your screenies and video is being able to equip a uniform from the backpack slot.....:headscratch:

 

Edit, have you tried the same test with the other variations of that uniform, that would be RVG Camo, RVG Independant, RVG Bandit, and RVG Survivor Fatigues, they all use the same model from Apex, I'd imagine the results would be similar.

 

 

Share this post


Link to post
Share on other sites

No i didn't try with the other uniform, but im sure i already find them in loot placholder without issue.

 

If i equip this uniform in the arsenal i can drop it then grab it without problem, the uniform holder is correctly displayed and didn't have any issue, i think there just something wrong with the loot script.

Share this post


Link to post
Share on other sites
5 minutes ago, damsous said:

i think there just something wrong with the loot script.

 

Ravage or VA? 

Share this post


Link to post
Share on other sites

Sorry buddy, I'm bowing out of this one. :headscratch:

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

if you’re using a corpse as the loot holder that’s possibly what’s wrong...

 

Bangabob’s loot script uses a Barrel as a placeholder for loot being spawned in, then it deletes the barrel, and changes it to the loot that is classed from the script.

 

I can only think of two things...

 

1.) You edited some portions of the code, and possibly / probably changed it to something it ISNT supposed to be (example: the placeholder to a corpse?) Or you edited so much you might of broke the script.

 

2.) You have an illegitimate copy of Arma 3 and somewhere some in game files are corrupted resulting in this.

 

I’ve used Bangabob’s loot script for quite some time, never had this weird issue. When clothing is spawned via the script, it is supposed to appear folded on the ground, not show up like a mannequin is laying there wearing it. 😂😂

 

In truth I have no idea what is even going on here.  

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
6 minutes ago, MuRaZorWitchKING said:

if you’re using a corpse as the loot holder that’s possibly what’s wrong...

i just added a line to enable dynamic sim on the loot, i don't think that can cause an issue like this, i have a legal copy of the game from steam that just happen on this uniform don't know why, the other ravage uniform are fine.

  • Like 1

Share this post


Link to post
Share on other sites

I think i find where that come from im not sure i need to test, the uniform class name was in the backpack array in the loot script, but that weird there is other uniform too and i didn`t have this bug.

 

I have noticed few other thing, I know it’s not really fun to receive bug reports, but there is few functionality that didn't work on dedicated server (thats work in Single player it was working with some previous ravage version).

 

So the Trader and the recruitable survivor are not working on dedicated server, there is no action avaible.

Share this post


Link to post
Share on other sites
On 9/7/2019 at 8:50 PM, EO said:

@Bukain 

The Gear Pool Module is the friend your looking for, you can add weapons and gear from virtually any Arma 3 mod by adding the correct classnames to the relevant arrays in the Gear Pool module. Run your mouse over the tooltips for a brief description of how the arrays work.

NIArms classnames are all listed on each of the NIArms Steam Workshop pages.

 

 

Working great bro! Now Im able to put all niarms/hlc weapons in my Ravage scenario thanks

Btw the magazine classnames and muzzle alike are to be put in common and rare item array right? Cuz an error of sort pop up when i put into miliary weapon array and such. I think ravage is forcing muzzle and ammo into the hands of survivors lol. Am i right?

Edited by Bukain

Share this post


Link to post
Share on other sites
1 hour ago, Bukain said:

Working great bro! Now Im able to put all niarms/hlc weapons in my Ravage scenario thanks

Btw the magazine classnames and muzzle alike are to be put in common and rare item array right? Cuz an error of sort pop up when i put into miliary weapon array and such. I think ravage is forcing muzzle and ammo into the hands of survivors lol. Am i right?

To spawn a weapon, different code is used than spawning gear or inventory items. Weapon attachments can be spawned via additemcargoglobal or additem, hence putting it into the "item" part is correct. 

 

Reg. Magazines, these use seperate code aswell, you can not put it into the item or weapon array. 

But, it is likely that the mags are spawned automatically, based on the weapons pool. It should not be needed to add magazines. (thats just my guess however) 

  • Thanks 1

Share this post


Link to post
Share on other sites
8 hours ago, damsous said:

 

I have noticed few other thing, I know it’s not really fun to receive bug reports, but there is few functionality that didn't work on dedicated server (thats work in Single player it was working with some previous ravage version).

 

So the Trader and the recruitable survivor are not working on dedicated server, there is no action avaible.

 

No problem mate, I will look into it. 😉 

Share this post


Link to post
Share on other sites

Does the array of custom classnames overwrites the default weapon pool, or it added into it as extra stuffs to be spawn alongside Ravage officially intended to (like rha,cup, etc)? I'm asking becuz only weapons in my custom array spawn  in the hands of the raiders/survivors(haven't throughly test the loot though). And when i tested it by running like:

Common weapons "hlc_pistol_p239"

Military weapons "hlc_rifle_g3a3"

Rare weapons "hlc_rifle_aug"

only those 3 weapons shown up in the guys hands, alongside rpg for some dude, no other weapons in the common, military and rare class spawn. If i only put custom array into one type for example g3 into military weapons, then the raiders and survivors spawn with random pistols and rare weapons like it suppose to with no other miliary weapons except g3.

 

Should i have to put all classnames of the weapon i want in my scenario in particular type array, or should i has two Gear pool module one being with my custom arrays and another without them? 

 

Note though it is happening rn in the Eden editor, during test running it in the editor "PLAY SCENARIO IN SINGLEPLAYER", before exporting it to singleplayer/multiplayer. Is it the case of the issues? Haven't test it in true mission environment.

Share this post


Link to post
Share on other sites
1 hour ago, Bukain said:

Does the array of custom classnames overwrites the default weapon pool, or it added into it as extra stuffs to be spawn alongside Ravage officially intended to (like rha,cup, etc)? I'm asking becuz only weapons in my custom array spawn  in the hands of the raiders/survivors(haven't throughly test the loot though). And when i tested it by running like:

Common weapons "hlc_pistol_p239"

Military weapons "hlc_rifle_g3a3"

Rare weapons "hlc_rifle_aug"

only those 3 weapons shown up in the guys hands, alongside rpg for some dude, no other weapons in the common, military and rare class spawn. If i only put custom array into one type for example g3 into military weapons, then the raiders and survivors spawn with random pistols and rare weapons like it suppose to with no other miliary weapons except g3.

 

Should i have to put all classnames of the weapon i want in my scenario in particular type array, or should i has two Gear pool module one being with my custom arrays and another without them? 

 

Note though it is happening rn in the Eden editor, during test running it in the editor "PLAY SCENARIO IN SINGLEPLAYER", before exporting it to singleplayer/multiplayer. Is it the case of the issues? Haven't test it in true mission environment.

So i have come across the conversation of you guys regarding my question above,  at pages of 289-290 . So does that mean if i want to put one of Niarms weapon say like g3a3 or any of the weapon that isn't default compat with ravage into my scenario, i have to put the classnames of all the weapons i wanted into my scenario including those weapons Ravage has officially supposed to be spawn on its own without any input, like from RHS and cup(only things i use among ravage compated mods)?

Just want to make sure guys, if that's the case i have no problem doing that too:) just confusing out of my mind lol

 

My active mods are: cba, ravage, ravage apex, ravage cup, all cup, all rhs, niarms aio, frithninja, enhanced movement and enhanced soundscape. I play with individual niarms too, in place of aio.

Thank you.

Share this post


Link to post
Share on other sites
3 hours ago, Bukain said:

Does the array of custom classnames overwrites the default weapon pool, or it added into it as extra stuffs to be spawn alongside Ravage officially intended to (like rha,cup, etc)? I'm asking becuz only weapons in my custom array spawn  in the hands of the raiders/survivors(haven't throughly test the loot though). And when i tested it by running like:

Common weapons "hlc_pistol_p239"

Military weapons "hlc_rifle_g3a3"

Rare weapons "hlc_rifle_aug"

only those 3 weapons shown up in the guys hands, alongside rpg for some dude, no other weapons in the common, military and rare class spawn. If i only put custom array into one type for example g3 into military weapons, then the raiders and survivors spawn with random pistols and rare weapons like it suppose to with no other miliary weapons except g3.

 

Should i have to put all classnames of the weapon i want in my scenario in particular type array, or should i has two Gear pool module one being with my custom arrays and another without them? 

 

Note though it is happening rn in the Eden editor, during test running it in the editor "PLAY SCENARIO IN SINGLEPLAYER", before exporting it to singleplayer/multiplayer. Is it the case of the issues? Haven't test it in true mission environment.

When you leave the arrays empty I believe they are populated by default I basically filled every array so i'm really not having these issues as everything thing I want in the mission is listed in the arrays excluding the Ravage stuff that spawns by default. (:

Share this post


Link to post
Share on other sites

Hiho all, 

 

@ whomever might be interested😉, below an updated roadmap for the VA mod:

 

 

 

Cheers
VD

  • Like 5

Share this post


Link to post
Share on other sites

Does anyone know the variable name where the ravage time acceleration set in the module is stored? 

I need it to offset the speed up effect it has on some timers I use. 

 

Thanks! 

Vd

Share this post


Link to post
Share on other sites
19 minutes ago, Vandeanson said:

Does anyone know the variable name where the ravage time acceleration set in the module is stored? 

I need it to offset the speed up effect it has on some timers I use. 

 

Thanks! 

Vd

 

rvg_timeF is the variable you're looking for. 😉 

  • Thanks 1

Share this post


Link to post
Share on other sites
On 9/7/2019 at 5:46 AM, tourist said:

-snip-

Hey fam,

I've made some more changes and published them  to steam workshop and github.  
It seems to work (almost perfectly)* on my "dedi", but once again I'd love to see some real-world feedback.
* it works, but on first spawn, -or- logging out on dead character. == respawn  >> spawn in >> die >> respawn.

so minor issue, but still annoying and one i cant figure out just yet. 

 

If you can do me a massive favour and try again, on your next test, just run @inidbi2 as a -servermod, and dont run inidbi2 on the client
Seems great on VM, but to quote the bloodhound gang, I'd appreciate your input. :D 

  • Like 1

Share this post


Link to post
Share on other sites

Hey @JakeHekesFists, I am loving your work and how you are contributing to the ravage community!

 

It also seems that you are the guy with the most knowledge about how to make @inidbi2 work with Ravage.

 

I am wondering if, @haleks willing, could you too work on bringing a @inidbi2 based module for Ravage, integrated into the mod, so it makes it a lot simpler to have persistence on our servers and missions.

 

That would be really a dream come true for most of us!

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

@JakeHekesFists

 

Did you get inidb2 to run on dedi? 

I got it all setup and it works on hosted MP, not on dedi tho. 

 

Im going to set it up so it saves player info, and all custom ravage and VA statuses. Now i just need to get it to work on dedi. 

If you can share how you set up your server and init, initserver and initplayer local, that would be great=) 

 

I feel like i have a solution very close and its maddening that i probably messed up something with regards to locality :

 

This is the post with my code and issue:

 

 

Cheers

Vd

Share this post


Link to post
Share on other sites

I didnt do anything special with my server setup.
I just used the same mods as the mission + inidbi2 as a -servermod param

As I said before it *seems* to work on a dedi. 
but bare in mind I am using TADST on a VM to create a dedi, not doing it properly.

Dedi rental in Aus is ridic, like $300 a month. I'm not THAT rich. ooof. 

Just in case it was missed, I'll just say again... anything you see on my github. feel free to use it.
I want people to make magic

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×