Jump to content

Recommended Posts

I always forget to ask this, but is there a way to increase the luminosity of the attached chemlight on your shoulder?

Share this post


Link to post
Share on other sites
3 hours ago, RZNUNKWN said:

is there a way to increase the luminosity of the attached chemlight on your shoulder?

 

Not really, but sort of. And are you sure you want to do this?
Chemlights aren't very bright in real life. They're used as markers rather than light sources. So to increase the intensity would be rather unrealistic. Do you just want to see better in the dark? Chemlights aren't for that.

Whilst there is the setLightIntensity command, it's really just for lights you create yourself. You could use it to create a super-bright chemlight, but I don't know of any way to apply it to a found chemlight. Maybe someone else knows better.
 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 7/1/2019 at 3:23 PM, haleks said:

Hi everyone!

 

MyST Demo 2 has been uploaded on Patreon : https://www.patreon.com/posts/28043582

 

The module is a huge improvement compared to what I've done for Ravage, I think mission makers will be very happy with it. 😉

A 3rd demo should follow on Patreon - no ETA for now as it concerns the most ambitious part of the project, but the module and the Phantoms as implemented in Demo 2 are pretty much in their final state, so mission makers can already work in advance with them. Resources used so far are 100% vanilla except for a couple sound effects; the addon weights less than 300 kbs at the moment.

 

The first demo required Ravage and CBA, but I'm aiming for a standalone project in the end : Demo 2 doesn't require any 3rd party addon.

I'll open a dedicated thread soon(ish) in the Discussion section.

 

Have fun guys! And be warned, hiding in vehicles is not such a good idea anymore...

oh i just tested your Demo 2 in my dedi server only with MyST and got a problem, phantoms dosen't move for some reason, only on SP everything working fine for me, checked my RPT and found only this problem:
or it's just not supported on dedi right now?

Spoiler

2019/07/03,  1:29:34 Error in expression <ht} do {
_pitch = (random 2) max 0.25;
[_pes, ["pht_song", 100, _pitch]] remoteE>
2019/07/03,  1:29:34   Error position: <_pes, ["pht_song", 100, _pitch]] remoteE>
2019/07/03,  1:29:34   Error Undefined variable in expression: _pes
2019/07/03,  1:29:34 File \myst\functions\pht\fn_init.sqf [myst_pht_fnc_init], line 50
2019/07/03,  1:29:34 Error in expression <ht} do {
_pitch = (random 2) max 0.25;

 

Share this post


Link to post
Share on other sites
12 hours ago, RZNUNKWN said:

attached chemlight 

 

How about a Dayz like Flare ?

 

buriaPm.png

  • Like 4

Share this post


Link to post
Share on other sites
18 hours ago, GEORGE FLOROS GR said:

 

How about a Dayz like Flare ?

 

 

Anything will help, really.

  • Like 2

Share this post


Link to post
Share on other sites

@haleks

 

Oi!

 

So you might be all that when it comes to scripting and things but it appears you SUCK at math like the rest of us...

 

AI module -> unit multiplication factor: The default is '1' which makes Ravage behave like a Duke Nukem deathmatch. Now when you start scaling it down in steps of '0.1' it doesn't seem to do a whole lot until you go below '0.5'. THEN you are lucky if you see an AI group once a week. Could you please hire a math geek for the next update? Thanks mate. Also you might wanna have a look at whether or not the multiplicator affects car patrols as well.

 

ALSO (in random order):

 

- Going Zeus in the MP mission unhooks the save system, until you log out -> disconnect -> reconnect

- The Ravage Toolbox does not work on AI car patrol vehicles. Or editor placed vehicles. Or helicopters. Or.... (those AI patrol vehicles also always have 4 medkits in them, bit much?)

- Please add "structures/tanoa/military" to the loot module, my current workaround is to place altis military barracks for military loot

 

Keep up the good work mate, it is very much appreciated.

 

Cheers

 

edited to add:

 

Since the last update the server rpt log gets hyperspammed by "Object 2:2540 not found (message Type_92)" BS. Which, apparently, is due to https://feedback.bistudio.com/T82940

It is so bad I have to turn logging off entirely. I have no idea what the hell that is, so....

Share this post


Link to post
Share on other sites
12 hours ago, zagr said:

oh i just tested your Demo 2 in my dedi server only with MyST and got a problem, phantoms dosen't move for some reason, only on SP everything working fine for me, checked my RPT and found only this problem:
or it's just not supported on dedi right now?

  Reveal hidden contents

2019/07/03,  1:29:34 Error in expression <ht} do {
_pitch = (random 2) max 0.25;
[_pes, ["pht_song", 100, _pitch]] remoteE>
2019/07/03,  1:29:34   Error position: <_pes, ["pht_song", 100, _pitch]] remoteE>
2019/07/03,  1:29:34   Error Undefined variable in expression: _pes
2019/07/03,  1:29:34 File \myst\functions\pht\fn_init.sqf [myst_pht_fnc_init], line 50
2019/07/03,  1:29:34 Error in expression <ht} do {
_pitch = (random 2) max 0.25;

 

 Hi Zagr (and thank you for your support!),

I haven't tested them on dedi yet; they don't move at all? Including when they've spotted a target?

 

@icarium: I'm not good at maths, but in this case it is a design problem - the AI module needs several improvements, I will work on it soon.

  • Like 3

Share this post


Link to post
Share on other sites
23 minutes ago, haleks said:

 Hi Zagr (and thank you for your support!),

I haven't tested them on dedi yet; they don't move at all? Including when they've spotted a target?

 

@icarium: I'm not good at maths, but in this case it is a design problem - the AI module needs several improvements, I will work on it soon.

yeah, even when they spotted a target 🙂 but when i stand right in front of them they can damage me but still doesn't move, i just trough to test it on dedi to see if everything is working fine) and yeah you are welcome, keep up a good work!

  • Like 3

Share this post


Link to post
Share on other sites
15 hours ago, RZNUNKWN said:

Anything will help, really.

 

I'll try to add a solution these days !

  • Like 1

Share this post


Link to post
Share on other sites

Hey Ravagers, if your interested in adding a little more civilian variety to your missions I have just released a Civilian Expansion to compliment my gear pack. :icon_biggrin:

  • Like 7
  • Thanks 1

Share this post


Link to post
Share on other sites

Something I've noticed when using the Civilian Presence modules with Ravage loaded, (not used just loaded) the occasional civilian will spawn with the corrupted android face. Is there any way to negate this as I want to use Ravage plus the CP modules.

 

Share this post


Link to post
Share on other sites
1 hour ago, EO said:

Something I've noticed when using the Civilian Presence modules with Ravage loaded, (not used just loaded) the occasional civilian will spawn with the corrupted android face. Is there any way to negate this as I want to use Ravage plus the CP modules.

 

 

Hmmm. I had a weird glitch a little while ago where one of my squad had blue speckled skin all over... looked pretty creepy.

Should have grabbed a screen cap but at the time I think I was fiddling with CP modules too

Share this post


Link to post
Share on other sites

yep, that's the corrupted android face. ^^ 

Share this post


Link to post
Share on other sites

Should be fixed within a couple hours. 😉 

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites

Tiny update!

 


1773

Fixed :
Android faces were associated with vanilla identities.

New :
Added new uniforms by EO.
The Radiation module supports most Contact DLC items.
Added more Contact DLC items to loot lists.

 

Note that the respirator backpacks from Contact DLC are not supported at the moment; the radiation system needs a few tweaks before that happens.

Have fun guys!

  • Like 6
  • Thanks 3

Share this post


Link to post
Share on other sites
1 hour ago, cosmic10r said:

 

Hmmm. I had a weird glitch a little while ago where one of my squad had blue speckled skin all over... looked pretty creepy.

Should have grabbed a screen cap but at the time I think I was fiddling with CP modules too

Had that occur in the editor pretty weird lol

Share this post


Link to post
Share on other sites

Making factions has brought a suggestion....

Could you add a "down" version of the Compact NVG (Green) that comes with Contact DLC.

O_NVGoggles_grn_F

🙏 

  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, EO said:

Making factions has brought a suggestion....

Could you add a "down" version of the Compact NVG (Green) that comes with Contact DLC.


O_NVGoggles_grn_F

🙏

 

I'll have a look, but I'm not sure it's doable with those EBO in the way...

In any case, that's a change related to Contact Data, so I'll have to wait for the DLC release before adding it.

Share this post


Link to post
Share on other sites

Sorry man, I thought i just involved adding a path via a config tweak, I've assumed you didn't need access to the data directly.

Spoiler

mass = 20;
modelOff = "\A3\Weapons_F_Enoch\Binocular\O_NVGoggles_grn_F.p3d";
type = 616;
uniformModel = "\A3\Weapons_F_Enoch\Binocular\O_NVGoggles_grn_F.p3d";

 

Anyway it's only 3 weeks to go till Contact, I'm really eager to see how the Campaign turns out...

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Halek, what all does the MP save actually save? Anything in regards to AI placed in the editor?

Share this post


Link to post
Share on other sites
4 hours ago, acoustic said:

Halek, what all does the MP save actually save? Anything in regards to AI placed in the editor?

As far as i recall, last i played it saves everything you had, and exactly where you were when you left off like the exact spot you were standing,

as far as AI position have no idea.

Share this post


Link to post
Share on other sites

Anyone notice the "Car Patrols"  not spawning any cars? 

I'm using a custom array of GM vehicles, worked fine for the 6 OPs previously then I made OP7 (basically renaming OP6 into OP7 with my sqd in a new spot, no module changes or anything) yesterday and haven't seen a vehicle since.

Mission only has Zeus, Atmos, Ambient AI and gearpool modules on it.

 

["gm_ge_army_u1300l_container","gm_ge_army_iltis_milan","gm_gc_army_btr60pb","gm_gc_army_bmp1sp2","gm_gc_army_brdm2"]

Share this post


Link to post
Share on other sites
3 hours ago, Zakuaz said:

Anyone notice the "Car Patrols"  not spawning any cars? 

 

I just tested one of my missions on Weferlingen with a similar array to yours and it works just fine man. ^^

The only thing I can add regarding car patrols, they only ever seem to spawn if you first enable a hostile faction, I don't think it's possible to have only car patrols. 

AI vehicle patrols are a bit of a joke in Arma, no fault of Ravage of course. Just follow an AI patrol in Splendid Camera mode and it will always guarantee belly laughs. 

  • Like 3
  • Haha 1

Share this post


Link to post
Share on other sites

Thanks for checking EO!

I'm not clear what you mean by "enable hostile faction".  I do have enemy foot soldiers running around, INDFOR and OPFOR are Hostile to me.

Hmm yeah friggin weird as I can load up my "OP6" mission and enemy vehicles spawn - then - in the editor, rename the mission to "OP7"  and play it and the vehicles wont show up hahah...fuck-it, I'll try "OP8" hah. 

 

I know the AI vehicle patrols are a bit janky but put them in a BMP or BP and when they eventually find you ( if they didn't turtle on something, get out and RUN the waypoints on foot LOL)... it can be a real PITA.  I fly around looking for Survivor flares, swoop in like a QRF / SAR team, secure the area, recruit the dude so I can load him in the heli then dust off to drop him off at a small FOB I have set up, rinse / repeat.  Those Armored patrols became a problem in a little bird... so I upgraded to a Kajman haha, good times!

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×