Jump to content

Recommended Posts

15 minutes ago, whiteface73 said:

Hmm, I was thinking I‘d have to pay to use anything from this DLC? Am I wrong, are some things for free?

I don‘t care for the campaign, alien stuff is nice to have, but gear and terrain are a must have.

 

Yes, you will have to own the DLC to use its assets : weapons, gear, terrains etc...

But Alien ships will most likely be static objects, and there is no way currently to limit their use for people who didn't buy the DLC. Basically, anyone could use those alien assets in their missions, and I think BIS is trying to prevent that. Sci-fi fans will buy the DLC for the alien part, I reckon they know that and want to capitalize on it by restricting access to a selection of assets in a way they never did before.

 

And in case some of the alien ships are driveable, it's another effective way to prevent "free" use of such vehicles in mission-making : most of the scenarios would use aliens as hostiles, not make you play as one, so simply locking the ability to use it makes less sense than downright locking the asset behind ownership/paywall.

 

EDIT : DnA just confirmed my thoughts :

 

 

😕

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, Gill93 said:

Lol here are some aliens for ya to play with 🙂 https://steamcommunity.com/sharedfiles/filedetails/?id=1749774001

 

That’s pretty cool lol wish I knew how to texture bodies and what not, would love to make some creature that lurks in the woods at night in Chernarus that scares the absolute crap out of players. 😂😂

 

Something almost like ”The Rake” would be absolutely terrifying. Custom sounds, make a mini mission to hunt it.

  • Haha 1

Share this post


Link to post
Share on other sites

@mondkalb just posted the uniform classnames on his thread : feed them to the zed module and have fun guys!

(I recommend the mbg_alien_hybrid_01 one)

  • Like 5

Share this post


Link to post
Share on other sites

So Livonia...as far as lootable static assets go, as well as re-used static objects that are already supported by Ravage, I find there are at least five new ones that could be added...

1tq7I3S.jpg

"Land_Wreck_V3S_F","Land_DeerStand_01_F","Land_DeerStand_02_F","Land_GarbageBin_03_F","Land_ConcreteWell_02_F",

Unfortunately the upgraded A2 and DayZ buildings are all devoid of furniture, not even the proxies remain. 🙁

Still, there are some super cool solar tents complete with folded bags, and some neat portable floodlights...

CLxFIxT.jpg

euEVjA2.jpg

As for the rest of the terrain, It definitely has the feels.... 

  • Like 8

Share this post


Link to post
Share on other sites

We need an rvg_egg for this enterable coup...

XVDj0ak.jpg

:icon_biggrin:

  • Like 5
  • Haha 3

Share this post


Link to post
Share on other sites

Are regular Arma 3 grenades, satchel charges and mines weapons or gear? Will they drop as loot when I disable A3 weapons?

Share this post


Link to post
Share on other sites
2 hours ago, whiteface73 said:

Are regular Arma 3 grenades, satchel charges and mines weapons or gear? Will they drop as loot when I disable A3 weapons?

 

Those are hardcoded into the lists, so yeah, you can disable A3 weapons : you will still find explosives in military loot.

  • Like 4

Share this post


Link to post
Share on other sites
37 minutes ago, haleks said:

 

Those are hardcoded into the lists, so yeah, you can disable A3 weapons : you will still find explosives in military loot.

Thank you, I wasn‘t sure because I haven‘t found anything yet.

 

Hmm, come to think about it...I do remember AI using grenades against me 😵

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, whiteface73 said:

Thank you, I wasn‘t sure because I haven‘t found anything yet.

Hey man, I can confirm this...only last night i found a vanilla RGO frag on Livonia, GM content set to "yes", Vanilla A3 content set to "no". 

  • Like 1

Share this post


Link to post
Share on other sites

Any chance we could see a couple color variations with that M 50 gas mask?  I am playing tactical barbie for 3 hours now in the editor... yeah...

A coyote, dark earth and OD green would be sweet!!

  • Like 1

Share this post


Link to post
Share on other sites

Okay, so now the respawn bug is happening even with "Select respawn position" turned OFF, which means that I now have to completely disable the multiplayer persistency setting in ALL of my missions. It truly is a game breaking bug. Here are the steps to reproduce the bug:

1. Launch ArmA 3 with only CBA and Ravage loaded.

2. On the main menu, click Multiplayer, then server browser, then host server.

3. Click Altis, then "New - 3d Editor".

4. Place down a Blufor unit, then place down Ravage mod's "Save System" module.

5. Double click the "Save System" module and enable "MP Persistency"

6. Place a marker and put in the "Variable Name": "respawn_west". Copy and paste a few of these markers around the map.

7. Click attributes, then multiplayer.

8. Set respawn type to "Respawn on Custom Position". Enable the respawn button.

9. Click test mission.

10. Keep hitting "ESC" and clicking "Respawn" until the bug gradually starts to take form. By the 10th respawn, you should be getting teleported and killed immediately upon respawning.

 

Edit: The same thing happens if you decide to use the "Description.ext" method instead of the Editor Attributes method, here are some alternate steps if you would like to use this method instead:

1. Launch ArmA 3 with only CBA and Ravage loaded.

2. On the main menu, click Multiplayer, then server browser, then host server.

3. Click Altis, then "New - 3d Editor".

4. Place down a Blufor unit, then place down Ravage mod's "Save System" module.

5. Double click the "Save System" module and enable "MP Persistency"

6. Place a marker and put in the "Variable Name": "respawn_west". Copy and paste a few of these markers around the map.

7. Save the mission and name it. Alt-tab out of the game, then go to "My Documents/Arma 3/mpmissions/themissionyoujustsaved.altis"

8. Right-click and click "New", then "Text Document". Name it "description". Open the "description" file, and paste these lines:

  respawn = "BASE";
  respawnButton = 1;
  respawnDelay = 10;

9. Click File, then Save As. In the "Save as Type" drop-down menu, select "All Files", and rename it to "description.ext".

10. Go back into ArmA 3 and test the mission as usual.

11. Keep hitting "ESC" and clicking "Respawn" until the bug gradually starts to take form. By the 10th respawn, you should be getting teleported and killed immediately upon respawning.

  • Thanks 1

Share this post


Link to post
Share on other sites

@ArteyFlow: Thanks for the detailed repro method, it's going to help me debug this thing for good!

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, haleks said:

@ArteyFlow: Thanks for the detailed repro method, it's going to help me debug this thing for good!

No problem, I just want to help in getting this bug eradicated LUL

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, ArteyFlow said:

Okay, so now the respawn bug is happening even with "Select respawn position" turned OFF, which means that I now have to completely disable the multiplayer persistency setting in ALL of my missions. It truly is a game breaking bug. Here are the steps to reproduce the bug:

1. Launch ArmA 3 with only CBA and Ravage loaded.

2. On the main menu, click Multiplayer, then server browser, then host server.

3. Click Altis, then "New - 3d Editor".

4. Place down a Blufor unit, then place down Ravage mod's "Save System" module.

5. Double click the "Save System" module and enable "MP Persistency"

6. Click attributes, then multiplayer.

7. Set respawn type to "Respawn on Custom Position". Enable the respawn button.

8. Click test mission.

9. Keep hitting "ESC" and clicking "Respawn" until the bug gradually starts to take form.

10. By the 10th respawn, you should be getting teleported and killed immediately upon respawning.

 

Oi!

 

Yeah you need to stay away from the editor MP settings in general and do things via the description.ext. Works for me anyway.

 

Cheers

Share this post


Link to post
Share on other sites
3 minutes ago, icarium said:

Works for me anyway.

 

If you mean you can solve the issues ArteyFlow is having via description.ext could you show an example so everyone can benefit please. :icon_biggrin:

  • Like 3

Share this post


Link to post
Share on other sites
8 hours ago, icarium said:

 

Oi!

 

Yeah you need to stay away from the editor MP settings in general and do things via the description.ext. Works for me anyway.

 

Cheers

Actually, I have tried using the description.ext method instead of the editor mp settings, and the problem still persisted...

Share this post


Link to post
Share on other sites
On 5/25/2019 at 11:05 PM, EO said:

We need an rvg_egg for this enterable coup...

 

:icon_biggrin:

 

3 hours ago, ArteyFlow said:

Actually, I have tried using the description.ext method instead of the editor mp settings, and the problem still persisted...

Not really a solution but I heard it works for getting around this bug when it occurs. You will need to name your playable characters as player1 player2 and so on then when the bug occurs type player1 setDamage 1; in the local execute box or whatever player is experiencing the respawn issue will have to do the same.

  • Like 1

Share this post


Link to post
Share on other sites
28 minutes ago, Gill93 said:

 

Not really a solution but I heard it works for getting around this bug when it occurs. You will need to name your playable characters as player1 player2 and so on then when the bug occurs type player1 setDamage 1; in the local execute box or whatever player is experiencing the respawn issue will have to do the same.

To be honest, I think for now I'll just leave the Multiplayer Persistence setting turned off, at least the mod is still playable with it turned off, so that's always good. I might even take a break from Ravage for a while, so it really doesn't bother me too much. 👍

  • Like 1

Share this post


Link to post
Share on other sites

I noticed there is no gusts of dust if you load in from a MP save. 

I have the gusts set to yes in the Ravage module, worked great yesterday on Icebreakrs Angola map.

Everything was making dust, footsteps, vehicle movement, gusts of dust... Now after loading in from the save it's just a little trickle from vehicle movement.

Any ideas?

 

Oh and while I'm on the dust topic... it'd be cool to have a "medium, heavy dust" option it that's even possible or not a nightmare to do haha.

 

  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, ArteyFlow said:

To be honest, I think for now I'll just leave the Multiplayer Persistence setting turned off, at least the mod is still playable with it turned off, so that's always good. I might even take a break from Ravage for a while, so it really doesn't bother me too much.

I didn't have issue with ravage MP persistence on a dedicated server, every gear, object, player state are restored when connected to the server also after many respawn no issue.

For local host (listen server) you don't really need a MP persitency cause your game will be save when exit the mission.

  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, Zakuaz said:

Any ideas?

 

Dust from footsteps and vehicles come from the terrain itself, the Atmosphere module only spawns dust gusts around the player. Not sure why you have no dust loading a saved game. :headscratch:  

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, damsous said:

I didn't have issue with ravage MP persistence on a dedicated server, every gear, object, player state are restored when connected to the server also after many respawn no issue.

For local host (listen server) you don't really need a MP persitency cause your game will be save when exit the mission.

If MP persistency is turned off, then when other players disconnect and reconnect, they don't "pick up from where they left off" (they don't spawn where they last disconnected), only I do (makes sense since I'm the host).
 

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, EO said:

 

Dust from footsteps and vehicles come from the terrain itself, the Atmosphere module only spawns dust gusts around the player. Not sure why you have no dust loading a saved game. :headscratch:  

 Yeah EO, I figured as much but it is odd, one thing I've not tried is setting this up on Altis or any of the vanilla maps.  It's an easy setup, Ravage, TPW, CBA, Achilles and 3den Enhanced.

 

How intensive is the dust gust particle effect/emitter anyway?  I have always wanted to really dial that effect up but I tread not past the mission folder lol.  

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Zakuaz said:

 I have always wanted to really dial that effect up but I tread not past the mission folder lol.  

 

You can patch CfgSurfaces and increase dust on certain terrain surfaces, you can really make Altis a dust bowl...

cm2rMYu.jpg

5R9TZ3V.jpg

 

  • Like 6

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×