Jump to content

Recommended Posts

Nope, modules handle everything - you won't need any scripts, execpt maybe for advanced features - but a documentation will be available at some point.

Share this post


Link to post
Share on other sites

Sorry Haleks..

Just finished some *testing in your main release and..the Radio menu "Save" feature its broken (for me).

It will save but wont load the saved game forcing a restart :/

Share this post


Link to post
Share on other sites

Sorry Haleks..

Just finished some *testing in your main release and..the Radio menu "Save" feature its broken (for me).

It will save but wont load the saved game forcing a restart :/

You are not the first one to report this - what mods are you using?

I just tried on my end with vanilla Arma3, and I can reload a save just fine.

Share this post


Link to post
Share on other sites

Many thanks for this new version......i hope it's as brutal as v0.1.0  :SpiningDemon:

Share this post


Link to post
Share on other sites

So the ambient zombie module isn't working for me. Also is there a way to know where the radiation is and how to limit where it is. The map i'm using doesn't use any arma 3 buildings or arma 2. Is this a problem for loot spawning? I'm using the Chernobyl map.

Share this post


Link to post
Share on other sites

Thanks for informing us about the hotfix :)

New version frontpaged on the Armaholic homepage.

news_download_a3_3.png

Ravage Mod v0.1.1.1

PS: although you did not do it I decided to call this 0.1.1.1, this to make sure our site visitors see its another update. Hope that is ok with you.

Share this post


Link to post
Share on other sites

Thank you fox!

 

Also, a quick note about the update : the new loot module causes a small script error when launching the Altis scenario - this shouldn't affect gameplay.

Give a shout if you spot any game-breaking glitch though!

Share this post


Link to post
Share on other sites

You are not the first one to report this - what mods are you using?

I just tried on my end with vanilla Arma3, and I can reload a save just fine.

 

To be honest Haleks i m using ACE (also CBA and some LAxeman's sound enhancements)-and it worked fine

before the updated Ravage version.

 

If eventually save works without it/and nothing can be done ..i  guess i ll go without it :/

Share this post


Link to post
Share on other sites

To be honest Haleks i m using ACE (also CBA and some LAxeman's sound enhancements)-and it worked fine

before the updated Ravage version.

 

If eventually save works without it/and nothing can be done ..i  guess i ll go without it :/

Could you report back? Specifically regarding CBA/Laxemann's.

I love Laxemann's Enhanced Soundscapes and Sonic Cracks so so much. Just want to make sure they play nice with Ravage if you discover the culprit of your issue.

Share this post


Link to post
Share on other sites

To be honest Haleks i m using ACE (also CBA and some LAxeman's sound enhancements)-and it worked fine

before the updated Ravage version.

 

If eventually save works without it/and nothing can be done ..i  guess i ll go without it :/

If you could try again and confirm it was not a one-time thing, that would be great.

I'll try to reproduce it tomorrow (taking a break for today!).

Share this post


Link to post
Share on other sites

So the ambient zombie module isn't working for me. Also is there a way to know where the radiation is and how to limit where it is. The map i'm using doesn't use any arma 3 buildings or arma 2. Is this a problem for loot spawning? I'm using the Chernobyl map.

Share this post


Link to post
Share on other sites

 

So the ambient zombie module isn't working for me. Also is there a way to know where the radiation is and how to limit where it is. The map i'm using doesn't use any arma 3 buildings or arma 2. Is this a problem for loot spawning? I'm using the Chernobyl map.

 

Hi!

This could mean that the Chernobyl map doesn't have its buildings properly configured : if that's the case, I'm afraid zombies nor loot will work on it...

As for the Radiations, a debug option will be added for the next version! ;)

Share this post


Link to post
Share on other sites

Hi!

This could mean that the Chernobyl map doesn't have its buildings properly configured : if that's the case, I'm afraid zombies nor loot will work on it...

As for the Radiations, a debug option will be added for the next version! ;)

yeah sorry for posting twice, i just needed to know so i know if i'm wasting my time. Thanks for the replay!

Share this post


Link to post
Share on other sites

One thing I'd like to report is very bad HP healing from med kits - only 4HP healing?!  :huh: 

And for some strange reason I've been getting quite frequent memory errors (it says the memory couldnt be read or something like that) and crashes to desktop. For instance while looting, or when shooting at zeds/bandits. My drivers are up to date, so is the game. After crash I get this report:

w4IUkX2.png

 

Edit: Just crashed again when opening those loot-bags, and here what it said

 

EFxRcmW.png

Share this post


Link to post
Share on other sites

Hi lecter!

I could use your mod list and the RPT file for that session.

Share this post


Link to post
Share on other sites

Hi lecter!

I could use your mod list and the RPT file for that session.

Sure mate here's the screenshot of my mod-list:

we7eh47.png

I'll try running only Ravage to check if it crashes again. I doubt it's my PC hardware, since the game never crashed while I played the campaign or those showcase missions.

So, I had following mods active:

first one - british backpacks,

cba_a3

dragonfyre

unit sfx

massi weapon pack (nato-rus-weapons)

mag repack

and that stamina bar mod.

Edit: I think I might have found the problem - I was going through the log and found this issue with DragonFyre sound mod:

 

18:04:24 Cannot load sound 'dfyre_p_environmensounds\sfx\bell_small.wss'
 
Also this:

18:57:18 C:\Users\Windows PC\Documents\Arma 3 - Other Profiles\Archy\Saved\rvg_missions\rvg_sp\Ravage.Altis\save5.Arma3Save/Vehicles/InvisibleFar/Vehicles/Item50.loiterInfo.type: Unknown enum value ERROR
18:57:19 C:\Users\Windows PC\Documents\Arma 3 - Other Profiles\Archy\Saved\rvg_missions\rvg_sp\Ravage.Altis\save5.Arma3Save/Vehicles/InvisibleFar/Vehicles/Item52.loiterInfo.type: Unknown enum value ERROR
 
18:57:23  Mission file: Ravage
18:57:23  Mission world: altis
18:57:23  Mission directory: rvg_missions\rvg_sp\Ravage.altis\
18:57:57 Error in expression <;
_pos2 = _this select 1;
 
 
if(typename _pos1 == "OBJECT") then {_pos1 = getpos >
18:57:57   Error position: <_pos1 == "OBJECT") then {_pos1 = getpos >
18:57:57   Error select: Undefined variable in expression: _pos1
18:57:57 File A3\functions_f\geometry\fn_dirTo.sqf, line 20
18:57:57 Error in expression <
 
params ["_group"];
_group = _group call CBA_fnc_getgroup;
_group loc>
18:57:57   Error position: <_group call CBA_fnc_getgroup;
_group loc>
18:57:57   Error Undefined variable in expression: _group
18:57:57 File x\cba\addons\ai\fnc_searchNearby.sqf, line 24
 
EDIT 2: Definitely the issue is with DragonFyre SP mod. Loaded the game without it and no problems.

Share this post


Link to post
Share on other sites

Hi,

I play with the " Dragonfire Lite " 4 hours and no problems.

 

Great mod, thanks

Share this post


Link to post
Share on other sites

UPDATE!!

 

Ok ..i 've found the culprit

 

While i tested the LATEST version 0.111 and encountered the same problem..

i searched and saw loading fails because some entries as R3F,RH,CUP,RKSL missing which are

Optional (supplementary) Configs for ACE 3 (which i have installed recently)

 

Of course..i can't see any obvious reason why it requires mods which i never run ..but as a bypass for this problem is CLEAR the optional supplementary configs on ACE and everything (save/load) will work properly  ;)

 

(to save time i uninstalled/reinstalled ACE 3 again)

 

 

@lecter

Btw i cant see reason to use both ACE and magRepack mod for "repack" job ;)

  • Like 1

Share this post


Link to post
Share on other sites

Having much fun with the Mod.....running all the supported mods except ACE.....much smoother performance than v1.0.0.......no issues after 2 hours play.....except for wearing out the edge of my seat.......

 

As generous as the Module suite is........would sure love to see an Ambient Lightning module somewhere down the line.....similar to Shpook's script......

 

Keep doing what you are doing Haleks...

The strength of both Mod and Modules on offer here is frightening....... :clap:

 

Edit.

A little gameplay created with Ravage modules and Shpook's Lightning script....

 

  • Like 1

Share this post


Link to post
Share on other sites

Been playing for 5 hours without crashing now. However, I'd say that loot system is still unbalanced. In this 5hr gameplay I found only 1 milk, 1 drink, 1 med kit - it's impossible to play around with such a bad drop rate on essential items for food/drinks/healing. When the character is under 50% HP then it starts walking and finding loot is even more of a time wasting process. Been dragging around through Kavala searching for loot to heal myself from 29 HP - no luck and gave up on it <_<

Share this post


Link to post
Share on other sites

One thing to note guys...

 

And Haleks can correct me if I'm wrong..

 

But the default scenario will still have lower spawn rates...

If you want to up the loot ratio then create a custom scenario with in the editor and adjust the loot rates in the placed loot module...

 

Found my first franta soda today :)

  • Like 1

Share this post


Link to post
Share on other sites

Been playing for 5 hours without crashing now. However, I'd say that loot system is still unbalanced. In this 5hr gameplay I found only 1 milk, 1 drink, 1 med kit - it's impossible to play around with such a bad drop rate on essential items for food/drinks/healing. When the character is under 50% HP then it starts walking and finding loot is even more of a time wasting process. Been dragging around through Kavala searching for loot to heal myself from 29 HP - no luck and gave up on it <_<

 

.....there's no shame in that, the Mod is beautifully brutal in that regard.........I feel it.........Heck, we all feel it.....

 

You could always lay down a few modules in the editor and tailor an experience that suits your playstyle.

 

Edit.         Ya beat me to it cosmic :P

  • Like 1

Share this post


Link to post
Share on other sites

Very interesting mod Haleks  :respekt:  Just to report this little script error

22:14:57 Error in expression < distance _pos > 2000};
{
deleteVehicle _x;
} forEach [_eFire, _eSmoke, _light];>
22:14:57   Error position: <_x;
} forEach [_eFire, _eSmoke, _light];>
22:14:57   Error Undefined variable in expression: _x
22:14:57 File ravage\functions\main\fn_createFireEffect.sqf, line 69
22:14:57 Error in expression < distance _pos > 2000};
{
deleteVehicle _x;
} forEach [_eFire, _eSmoke, _light];>
22:14:57   Error position: <_x;
} forEach [_eFire, _eSmoke, _light];>
22:14:57   Error Undefined variable in expression: _x
22:14:57 File ravage\functions\main\fn_createFireEffect.sqf, line 69
22:14:57 Error in expression <> 2000};
{
deleteVehicle _x;
} forEach [_eFire, _eSmoke, _light];>
22:14:57   Error position: <_eFire, _eSmoke, _light];>
22:14:57   Error Undefined variable in expression: _efire
22:14:57 File ravage\functions\main\fn_createFireEffect.sqf, line 70
22:15:01 Error in expression < distance _pos > 2000};
{
deleteVehicle _x;
} forEach [_eFire, _eSmoke, _light];>
22:15:01   Error position: <_x;
} forEach [_eFire, _eSmoke, _light];>
22:15:01   Error Undefined variable in expression: _x
22:15:01 File ravage\functions\main\fn_createFireEffect.sqf, line 69
22:15:01 Error in expression < distance _pos > 2000};
{
deleteVehicle _x;
} forEach [_eFire, _eSmoke, _light];>
22:15:01   Error position: <_x;
} forEach [_eFire, _eSmoke, _light];>
22:15:01   Error Undefined variable in expression: _x
22:15:01 File ravage\functions\main\fn_createFireEffect.sqf, line 69
22:15:01 Error in expression <> 2000};
{
deleteVehicle _x;
} forEach [_eFire, _eSmoke, _light];>
22:15:01   Error position: <_eFire, _eSmoke, _light];>
22:15:01   Error Undefined variable in expression: _efire
22:15:01 File ravage\functions\main\fn_createFireEffect.sqf, line 70

Share this post


Link to post
Share on other sites

Edit.         Ya beat me to it cosmic :P

 

lol not by much...

I'm pretty sure the default scenario is pulling the default loot ratios so thats why...

I noticed a big difference when i adjusted the tables..

 

:)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×