Jump to content
Sign in to follow this  

Server goes into infinite loop because of the mod load order

Recommended Posts

I created a ticket on the feedback but it was closed because the problem is not exactly with the game. And I understand that.

So I want to hear to feedback from the community. Maybe someone has some explanation after some try and error.

Ticket - http://feedback.arma3.com/view.php?id=24301

I'm gonna just copy and paste the info from the ticket here in-case ticket gets deleted later.

Sometimes the server goes into the infinite loop after loading. I tried to determine the pattern but it's always random.

So what happens. After the server is loaded and the console shows the usual

"10:20:37 Dedicated host created.

10:20:42 Host identity created.

10:20:42 Game Port: 2302, Steam Query Port: 2303"

but the server is actually stuck in some form of infinite loop. No one can join it and it uses 25% of cpu without any progress, we can wait forever and it will never unstuck. The only way to close it is to kill the process, closing the console window does nothing.

But, the strange thing is that this can be fixed. By changing the mod load order. Sometimes I need to move one mod, sometimes the other, sometimes even remove something. It has nothing to do with dependencies, I just need to move mods around until I find the right spot. That's really strange.

For example, I can find the right load order but after the update it will break. Doesn't matter what was updated, the game or some mod, it can break. It doesn't break after any update of course, but it happens more and more. I really have no idea because it doesn't happen on the client, client can use any load order and will load successfully. I'm not running any signatures checks etc or BE.


First rpt - https://mega.co.nz/#!SlRDAQwK!7NXz6BGAwx7xVHfLtkKOPQWa6DUjKn4fIrJr25v0odE

Second rpt - https://mega.co.nz/#!H0hD1YKB!61mF5qixhT1ZKXekP0fvRm3vuuYfXJ1HWUOLtqU6Mds

So I uploaded two rpt files.

First one is when the server goes into the infinite loop.

Second is a successful load.

The only thing that I changed is I moved @murshun_mods to load last.

Share this post

Link to post
Share on other sites
Maybe you've tried this but in general CBA should be loaded first

Yeah, I tried this. It's not about dependencies, it can happen to any mod. I have no idea how to debug this situation cause it shows nothing in the rpt.

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
Sign in to follow this