Jump to content
noubernou

ACRE2 Stable Release

Recommended Posts

Should be, AFAIK API version hasn't changed in 3.0.17 so it should be good to go.

Share this post


Link to post
Share on other sites

The radio GUI scales badly with widescreen monitors. I presume the radios scale following the horisontal resolution which makes for problems for people with 2560x1080 resolutions such as myself, especially on the 152.

 

 

npkubc.jpgggmbrp.jpg

 

vbiscx.jpg

 

In addition, are you possibly looking into adding extra sounds for when you press buttons and such? Videos like these would surely help.

Share this post


Link to post
Share on other sites

+1 for Zeus support.

Also anyone else having JIP/Respawn players muted or switched to "Babel" mode (enemy speech)?

Yeah had this problem tonight and I couldn't find a way to fix it so I missed out on a tac. :(  

Share this post


Link to post
Share on other sites

So what I would like to-do is for People that want to play on out public only have to do the following. First enter our Teamspeak Server. Then enter a channel called "Public Server Waiting Room". They then find Our Public server on ARMA 3. They would connect to the Game server with ACRE 2 also installed. Once they are In the game world Teamspeak would automatically move the player from the "Waiting room" to the "Public server room" this second channel would contain everyone that is currently playing on the game server and is using ACRE.


 


My question is, how can we get Teamspeak to move people once the have entered the game, and ACRE has recognized that the player is in the game server.


Share this post


Link to post
Share on other sites

Hi, I'd like to know is there any way of modifying this so that a secondary audio interface can handle the radio transmit and receive? My aim is to use my PC's default audio interface for arma and for direct speech but use a secondary audio interface for radio traffic. Great work btw, looking forward to seeing 117s and/or 119s back in this again. Thanks

Share this post


Link to post
Share on other sites

The current iteration of ACRE2 Ombnibus Edition seems to have an issue with the way Steam labels the Arma 3 folder. When I launch the Game server and the JVON server, the JVON server can not find the arma3 config file because it is looking in D:\Steam\steamapps\common\Arma instead of D:\Steam\steamapps\common\Arma 3. Therefor, I can not make use of the JVON server instead of using TS3.

 

The installation and configuration documentation Needs to be much much better for that part. Including explainations and examples of each part of the config files. The Troubleshooting section is basically Non-existant.

Share this post


Link to post
Share on other sites

Is it possible to setup different encryption codes for sides like in TFAR?

Share this post


Link to post
Share on other sites

Hi.

My group recently fully switch to ACRE2 and we enjoy it. However, when som people die during a mission, they can't talk to each other unless they turn their plugin off.

In fact, during our missions, dead players usually switch to another TS channel in order to talk to each others while they watch the alive players continuing the mission with the Arma spectator view.

Is their another way to talk to each other while being dead than turning off the plugin ?

Edit : I just realized that the toggle spectator mode key could be the answer, is it ?

Quotting an old post just to say that the problem was on our side. Sorry about that and many thanks for your work.

However, I've got a question : in the futur, do you plan to propose a serverside userconfig for things like specator mode, voice occulsion in buildings or audibility by AI ? It Would be great.

Share this post


Link to post
Share on other sites

In addition, are you possibly looking into adding extra sounds for when you press buttons and such? Videos like these would surely help.

This isn't a real 152, it is a fake one for airsoft.

Share this post


Link to post
Share on other sites

Probably, found a bug.
I have 1280x1024 19" monitor and the interface for radios and picture of radio are misaligned. Here it is: http://i.imgur.com/lPjhVSf.png
I can change channel and volume on this radio only if cursor in red squares. But on youtube videos I found that you should be able to do that with cursor in yellow squares.
I didn't test other radios because ACRE2 is new for me.

Share this post


Link to post
Share on other sites

Any way to disable vehicle occlusion with ACRE2 setting wise?

 

Trying to talk to people in technicals (no doors, or even a completely exposed gunner) while outside the vehicle is impossible because the volume is reduced to like 1%

 

I'd rather just have the entire vehicle occlusion thing disabled similar to ACRE1, iirc. Setting wise, ofcourse.

 

Kind regards,

Sanchez

Share this post


Link to post
Share on other sites

I can't find anywhere how to setup sounds for the radio (open sound when you talk, close sound, open sound when you recieve a communication...) I'm talking from a user perspective. I have to setup a fodler in Teamspeak under the plugins folder? Or are sounds included in the ACRE2 pbos?

Share this post


Link to post
Share on other sites

OK, seems ACRE only activates on multiplayer enviroment XD

Now I hear the beep sounds

Share this post


Link to post
Share on other sites

Hello,

I'm wondering how acre_api_fnc_isBroadcasting is supposed to be used ?

A member of my group tried to use it in a script but didn't manage to make it work.

So I made a test mission running a script with these lines :

while {alive player} do {
		waitUntil {[player] call acre_api_fnc_isBroadcasting};
			sleep 0.2;
			hint "broadcasting";
			sleep 1;
};

And another one with these lines (now using acre_api_fnc_isSpeaking)

while {alive player} do {
		waitUntil {[player] call acre_api_fnc_isSpeaking};
			sleep 0.2;
			hint "speaking";
			sleep 1;
};

Tested on dedicated server : the second one displays the hint correctly when speaking but the first one doesn't when using the radio.

We can't figure out why it doesn't work, Are we doing something wrong ?

 

The repro missions if necessary :

https://www.dropbox.com/s/mpziguoglmozi6t/ACRE_test_missions_broadcasting.7z?dl=0

 

To go deeper about his script :

He wanted to display an interface when speaking on a particular chanel with a particular type of radio in order to simulate the fact that a radio operator can call for artillery support (managed by interface and played by AI) using his radio.

The script can be found here (many commented lines are in french) :

https://www.dropbox.com/s/8ttv007c1qq0uq4/Fire_Support_Script%20v1.rar?dl=0

 

Thank you in advance.

Share this post


Link to post
Share on other sites

Sorry for not being around a lot lately in this thread! For some reason after the forums upgrade I found it harder for me to want to come here (don't exactly know why).

Anyway, been working on ACRE outside of Arma haha: http://raceriv.com/acre_maps/

Share this post


Link to post
Share on other sites

Just encountered a strange issue, when pressing the Down Arrow on the 148, or Keypad 6 on the 152, the radio closes. Pressing and holding the button, dragging off the radio and releasing seems to work fine though. Thoughts?

Share this post


Link to post
Share on other sites

Just encountered a strange issue, when pressing the Down Arrow on the 148, or Keypad 6 on the 152, the radio closes. Pressing and holding the button, dragging off the radio and releasing seems to work fine though. Thoughts?

Known issue and will be fixed soon (fixed in the current repo). Something in the engine now uses idc 106, and so do we (why we use such low IDCs sometimes I am not sure), so it causes a conflict and it closes the dialog.

Share this post


Link to post
Share on other sites

I get this message that something is wrong with the mission or ARMA and that my inventory has desynced. Any idea how I can fix this? I am trying this at an simple own made mission.

Share this post


Link to post
Share on other sites

Known issue and will be fixed soon (fixed in the current repo). Something in the engine now uses idc 106, and so do we (why we use such low IDCs sometimes I am not sure), so it causes a conflict and it closes the dialog.

Hi, I know this sounds crazy but is there any chance that the biggest and easisest optimisations from ACRE2 could be rolled into ACRE1?

Alternatively, is there anyway to modify ACRE2 to run with Arma2? sort of ACRE1x?

Share this post


Link to post
Share on other sites

I get this message that something is wrong with the mission or ARMA and that my inventory has desynced. Any idea how I can fix this? I am trying this at an simple own made mission.

If you are using Arsenal, don't. It breaks the game. If you have a gear script, make sure that it either sleeps between removing and re-adding the gear, or it doesn't remove and then re-add the same type of vest/backpack/uniform.

Share this post


Link to post
Share on other sites

On ACRE2 Omnibus the JVON server starts fine but the JVON Client Bootstrapper crashes instantly.

 

Errorlog below:

 

 

Problem signature:

  Problem Event Name: APPCRASH
  Application Name: client_win32.exe
  Application Version: 0.1.359.0
  Application Timestamp: 550c475d
  Fault Module Name: client_win32.exe
  Fault Module Version: 0.1.359.0
  Fault Module Timestamp: 550c475d
  Exception Code: c0000005
  Exception Offset: 001e829c
  OS Version: 6.1.7601.2.1.0.256.1
  Locale ID: 1043
  Additional Information 1: 0a9e
  Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
  Additional Information 3: 0a9e
  Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

 

My system:

Windows 7 - 64bit

i7 (3770) - 12GB - GTX670

Share this post


Link to post
Share on other sites

Hi all.


 


Only just started using this mod, adds excellent comms options, but I have an issue that when I try to use a 148 it appears to be too big for the my screen. I am running a wide screen resolution (3440x1440) which I'm guessing is causing the issue, but it means I cannot change channels as I cannot access the controls on the top. I can use the 343 fine however.


 


I don't have a screenshot I can post, but I have pinched on from armaholic and drawn a windows showing what I see to illustrate the issue (my viewing area is the red box)


 


107410_screenshots_2013-11-24_00005_4.jp


 


Is there a keyboard shortcut that can be used to cycle channels? Or some way of entering the channels manually?


 


Thanks in advance for any help on this, tried searching but can't find anything along the same lines.


 


Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×