Jump to content
Solano

Real Light V5 - ReShade Preset

Recommended Posts

I like the effects, but have alot of ingame crashes after installing this, is there simple way to uninstall this shader??

Share this post


Link to post
Share on other sites
I like the effects, but have alot of ingame crashes after installing this, is there simple way to uninstall this shader??

Ah men sorry to hear that!

Do you have some recording software running when using ReShade?

I had problems with that once.

Sure you can just delete all the files and folders:

Folder

  • ReShade
  • SweetFX

Files

  • dxgi.dll
  • ReShade.fx
  • Sweet.fx
  • KeyCodes.txt
  • ReShade_settings.txt
  • SweetFX readme.txt
  • SweetFX_preset.txt
  • SweetFX_settings.txt

If you want to disable it temporarily you can rename dxgi.dll to something like dxgi._dll

If this file isn´t working correct ReShade doesn´t load up.

Share this post


Link to post
Share on other sites

Solano,

first of all thank you very much for your effort and for sharing the result. It was super easy to install your personal setup package. Like some others who posted on this thread I wasn't aware of the grey tint until your addon made it disappear. Now the picture is much brighter and appears crisper than before.

But I have a feeling that the image is now a bit overexposed. I opened the arsenal and placed a character in his underwear. With your effects enabled it was almost impossible to distinguish the white front and back of the T-shirt from the grey shoulders. I disabled the effects by pressing scroll lock and the difference between the grey and the white bits became clearly visible. I started a mission and repeated the experiment in case the lighting in the arsenal was off, but on the sunny island of Stratis it was the same. I tried to play with the overall brightness and gamma value of the game but that didn't help. By the way, I set Bloom to zero, too.

Am I doing something wrong or is this overexposure a known side-effect of Real Light 5?

Share this post


Link to post
Share on other sites
Solano,

Am I doing something wrong or is this overexposure a known side-effect of Real Light 5?

Hi Alpha-Kilo,

you are doing nothing wrong. The "overexposure" as you call it is intended to give the overall image a more realistic sunlight. The exposure is a real setting in the ReShade.fx which I increased. To get rid of the grey tint and create a more realistic lightning in general many different settings are involved. The Exposure is one of them and was mostly one of the hardest to adjust to get better sunlight and not burn things out too much as in your underwear example. So with this element I had and will have to make the most compromises with as it contributes a lot to the look. I surely understand that taste varies on this topic. For me personally its more realistic at 12:00 o´clock cloudless weather on a Greek Island to get really intense sunlight - so I set the exposure the way you see it at the moment.

Another factor that always comes in is the Monitor setting of every particular user of course as you surely can imagine.

But long story short; you can decrease the exposure to something more suitable for you of course and I show you where. It´s not complicated.

Open the ReShade.fx file and browse to Line 276

#define Exposure    		0.450

You can decrease that while ingame with any text editor and tab back in arma 3 again. ReShade will reload itself and you see the changes immediately.

Of course you can toggle ReShade ingame on and off as well in critial situations (or the editor as its too bright there on the textureless map) via the "scroll lock" key (above page up).

How you can rebind that Key is mentioned in an earlier post of me here as well.

I hope you can enjoy Real Light V5 more after this change and I could help you out.

Regards

Share this post


Link to post
Share on other sites

Wow,amazing ligth,very clear,well done man,guys 1000% recommended,the night light is very amazing,we love you,:yay::yay::yay:

Share this post


Link to post
Share on other sites
Wow,amazing ligth,very clear,well done man,guys 1000% recommended,the night light is very amazing,we love you,:yay::yay::yay:

Thanks a lot!

I am very glad you enjoy it that much!

Share this post


Link to post
Share on other sites

Man is not comaptible with ACE3?????

Edited by Snake67

Share this post


Link to post
Share on other sites
Solano,

first of all thank you very much for your effort and for sharing the result. It was super easy to install your personal setup package. Like some others who posted on this thread I wasn't aware of the grey tint until your addon made it disappear. Now the picture is much brighter and appears crisper than before.

But I have a feeling that the image is now a bit overexposed.

Am I doing something wrong or is this overexposure a known side-effect of Real Light 5?

Before you change anything in the config - make sure to have lowered the in game brightness setting to 0.5 - 0.7 that will realign the colour improvement to lighting. It still overexposes a little in maps, but you can always just press scroll-lock to temporarily disable.

Share this post


Link to post
Share on other sites

Solano and serjames,

thank you very much for your replies. I will experiment a bit more with "define exposure" and in game brightness and of course I am aware of the fact that the whole business of altering image quality is a very personal one, considering both personal taste and the hardware which is being used.

Share this post


Link to post
Share on other sites
Works fine with ace... was testing last night

Ah nice!

Good to hear. I didn´t tested it yet. Thanks for the info!

Share this post


Link to post
Share on other sites

Unfortunately, like for some others it does not work for me.

Only a black screen after starting A3.

Win 7Pro 64bit, GTX 970.

Running A3 in an Admin account.

---Update:

It works now. I copied Solano's complete package.

It seems like the framework installer is missing some required stuff.

And thanks for this great work. The world is so bright and colorful now.

War per se is dreary enough, so this visual cheer up is highly appreciated! :)

Edited by oldy41

Share this post


Link to post
Share on other sites
Unfortunately, like for some others it does not work for me.

Only a black screen after starting A3.

Win 7Pro 64bit, GTX 970.

Running A3 in an Admin account.

---Update:

It works now. I copied Solano's complete package.

It seems like the framework installer is missing some required stuff.

And thanks for this great work. The world is so bright and colorful now.

War per se is dreary enough, so this visual cheer up is highly appreciated! :)

I am glad it works for you in the end!

I am still not sure what the heck is causing this error for some which my package seems to fix - but if it works in the end that´s great of course!

Share this post


Link to post
Share on other sites

Happen same to me man,some time black screen after starting game,so bad,because is a god mod

Share this post


Link to post
Share on other sites

Hi Solano

iv installed as directed,i get the message that its loaded succesfully in the top left hand side of loading screen...however in game i use scroll lock,it says disabled/enabled,but there is no difference in what i can see.

I also coppied your preset,and renamed it,put it in arma directory but it did not overwrite the original fx file.. im stuck

Share this post


Link to post
Share on other sites
Hi Solano

iv installed as directed,i get the message that its loaded succesfully in the top left hand side of loading screen...however in game i use scroll lock,it says disabled/enabled,but there is no difference in what i can see.

I also coppied your preset,and renamed it,put it in arma directory but it did not overwrite the original fx file.. im stuck

But you have the original ReShade.fx file right?

That is the file that you need to overwrite.

When you download my preset at http://sfx.thelazy.net/games/preset/3533/ it has this long name: SweetFX_Settings_ArmA III_MER - ReShade - Real Light V5.txt

Just rename it to ReShade.fx (not ReShade.fx.txt or something) and overwrite the existing one. Then (re)start Arma - it should work then

Share this post


Link to post
Share on other sites
But you have the original ReShade.fx file right?

That is the file that you need to overwrite.

When you download my preset at http://sfx.thelazy.net/games/preset/3533/ it has this long name: SweetFX_Settings_ArmA III_MER - ReShade - Real Light V5.txt

Just rename it to ReShade.fx (not ReShade.fx.txt or something) and overwrite the existing one. Then (re)start Arma - it should work then

Ahh good man...i think the .txt was screwing it up.

Cheers mate and thanks for the work,game looks awesome

Share this post


Link to post
Share on other sites

Thank you!

Enjoy your new Look ;)

Share this post


Link to post
Share on other sites

Is it normal that all my gamma is gone?

so, to illustrate, with your recommended settings all ym menus have lost ALL contrast. they are pitch black with white letters. Also the game is SUPER DARK, and even the menus have changed color. Forhtermore even if I disable the app using scrolllock i still have a darker screen. So, is it correct that even though I'd use scrolllock my whole arma should still lookd differently?

or is the near pitch black interface normal? as it is right now I have to put gamma all the way up to 2.3 to get the menus look like they do in vanilla.

Share this post


Link to post
Share on other sites
Is it normal that all my gamma is gone?

so, to illustrate, with your recommended settings all ym menus have lost ALL contrast. they are pitch black with white letters. Also the game is SUPER DARK, and even the menus have changed color. Forhtermore even if I disable the app using scrolllock i still have a darker screen. So, is it correct that even though I'd use scrolllock my whole arma should still lookd differently?

or is the near pitch black interface normal? as it is right now I have to put gamma all the way up to 2.3 to get the menus look like they do in vanilla.

That isn´t normal or intended. Make sure to update to the latest version of ReShade.

Did you made some changes to the preset yourself?

Share this post


Link to post
Share on other sites

hollyyy c...!

what a change! great work, this thing makes the game so much more appealing. thank man!

Share this post


Link to post
Share on other sites
That isn´t normal or intended. Make sure to update to the latest version of ReShade.

Did you made some changes to the preset yourself?

Hey mate. I thought so. :)

I downloaded the prepacked zip you published and that fixed my problems. Works just fine now. :)

This may be a hint to you as to what went wrong, if you are interested: the files i downloaded following your instructions didn't have the SweetFX folder. However the zip i downloaded from your prepacked v5 download you posted some pages back did have a sweetfx folder. I might have dont something wrong though. Well, it works now. :D

cheers

Share this post


Link to post
Share on other sites
hollyyy c...!

what a change! great work, this thing makes the game so much more appealing. thank man!

You are very welcome!

---------- Post added at 10:10 ---------- Previous post was at 10:09 ----------

Hey mate. I thought so. :)

I downloaded the prepacked zip you published and that fixed my problems. Works just fine now. :)

This may be a hint to you as to what went wrong, if you are interested: the files i downloaded following your instructions didn't have the SweetFX folder. However the zip i downloaded from your prepacked v5 download you posted some pages back did have a sweetfx folder. I might have dont something wrong though. Well, it works now. :D

cheers

Jeah maybe that is a factor and potential source of errors...

I am building a website at the moment to host the shader and all the information around and the download and installation will be much simpler then.

Stay tuned ;)

Share this post


Link to post
Share on other sites

I will try it out. My current solution to get rid of the pale image quality is to set ingame brightness to max (1.5) and gamma to 0.8.

Share this post


Link to post
Share on other sites

Hey solano, thx for this great project ,the Daylight with the right gamma and brightness settings looks simply fantastic. But i've noticed that the nights with full moon are a little bit to dark, when i use the daysettings (gamma,brightness) and the days are realy bright.

Greetz

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×