Jump to content
silola

X-Cam 1.0 for Arma 3 released

Recommended Posts

ive been 

 

Having an issue exporting to Terrain builder a project that has objects that used, "import from mission" function. 

 

Using V1.21 all the objects from the mission import into the xcam project fine, however when i create a terrain builder export, each object does not have it's class name exported, only it's positional data.

 

So all entries in the text file export look like this: "";208881.1875;4801.641602;429.148;0;0;1;-0.125929

 

Any ideas?

 

Ive been using 1.21 since release and haven't encountered this problem

Share this post


Link to post
Share on other sites

Need Help. 

a300faf36f.jpg

 

@inidbi and @xCAm they are located in the root of the game. Not for the first time to install it, but today there was such a mistake. Prior to this, Windows10 rolled back to its original condition.

Share this post


Link to post
Share on other sites

Need Help. 

a300faf36f.jpg

 

@inidbi and @xCAm they are located in the root of the game. Not for the first time to install it, but today there was such a mistake. Prior to this, Windows10 rolled back to its original condition.

 

You have checked the xCam folder within @inidbi\db ???

Both mod folders loaded / activated ??

 

No other reason possible for this error message.

 

Silola

Share this post


Link to post
Share on other sites


if((_data select 0) && (_data select 1)) the>

0:33:44 Error position: <_data select 0) && (_data select 1)) the>

0:33:44 Error ÐÐµÐ¾Ð¿Ñ€ÐµÐ´ÐµÐ»ÐµÐ½Ð½Ð°Ñ Ð¿ÐµÑ€ÐµÐ¼ÐµÐ½Ð½Ð°Ñ Ð² выражении: _data

0:33:44 Error in expression <Cam\xCamSettings" call iniDB_exists;

if(_isIni) then

{

xCam_dialog = createDial>

0:33:44 Error position: <_isIni) then

{

xCam_dialog = createDial>

0:33:44 Error ÐÐµÐ¾Ð¿Ñ€ÐµÐ´ÐµÐ»ÐµÐ½Ð½Ð°Ñ Ð¿ÐµÑ€ÐµÐ¼ÐµÐ½Ð½Ð°Ñ Ð² выражении: _isini

0:33:44 File xCam\xCam\data\xCam_Start_UI.sqf, line 18

Share this post


Link to post
Share on other sites
if((_data select 0) && (_data select 1)) the>
 0:33:44   Error position: <_data select 0) && (_data select 1)) the>
 0:33:44   Error ÐÐµÐ¾Ð¿Ñ€ÐµÐ´ÐµÐ»ÐµÐ½Ð½Ð°Ñ Ð¿ÐµÑ€ÐµÐ¼ÐµÐ½Ð½Ð°Ñ Ð² выражении: _data
 0:33:44 Error in expression <Cam\xCamSettings" call iniDB_exists;
if(_isIni) then
{
xCam_dialog  = createDial>
 0:33:44   Error position: <_isIni) then
{
xCam_dialog  = createDial>
 0:33:44   Error ÐÐµÐ¾Ð¿Ñ€ÐµÐ´ÐµÐ»ÐµÐ½Ð½Ð°Ñ Ð¿ÐµÑ€ÐµÐ¼ÐµÐ½Ð½Ð°Ñ Ð² выражении: _isini
 0:33:44 File xCam\xCam\data\xCam_Start_UI.sqf, line 18

 

It looks like inidbi is missing.

Please check "Addons" folder within @inidbi ... maybe inidbi.pbo is not installed correctly.

 

Silola

Share this post


Link to post
Share on other sites

Is it possible to rotate a wall so that it is horizontal to the ground rather than vertical. Im making a kill house and i need to make a floor for the 2nd story. Help?

Share this post


Link to post
Share on other sites

Hi,

 

I'm working on an additional tool for X-Cam.

If you want to know more details, please watch the following video ;-)

 

https://youtu.be/O9cgBQ0bQUM

 

Silola

 

 

  • Like 3

Share this post


Link to post
Share on other sites

any plans on adding vehicle scripts Silola? I find myself using the dreaded Eden for vehicle placement.

Share this post


Link to post
Share on other sites

wow that wall builder is fantastic 

  • Like 1

Share this post


Link to post
Share on other sites

any plans on adding vehicle scripts Silola? I find myself using the dreaded Eden for vehicle placement.

 

Hi Auss,

 

no plans so far for this part of X-Cam, cause it's very time intensive to script the whole unit & vehicle part. Sorry.

Another reason is ... Eden is perfect in case of this, but it's only my opinion.

 

Silola

Share this post


Link to post
Share on other sites

Well that road placing at the end looked interesting. :P

Share this post


Link to post
Share on other sites

While writing this I put myself at the risk of repeating myself, but you are truly a god amongst men, Silola. Really good work.

Share this post


Link to post
Share on other sites

on playwithsix the mod is still in version 1.0

comes with inidbi_xcam mod

is the right indbi mod or i need the inidbi from 1.21?

thanks

Share this post


Link to post
Share on other sites

on playwithsix the mod is still in version 1.0

comes with inidbi_xcam mod

is the right indbi mod or i need the inidbi from 1.21?

thanks

 

 Please do not download X-Cam from "playwithsix", because the data structure is broken.

 

Try Armaholic or X-Cam website (Version 1.21).

 

Silola

Share this post


Link to post
Share on other sites

ok i have the last version of inidbi and xcam 1.21 from this threat 1st post.

btw,  all inidbi mods (and the last one) have problems with battleye . (inidbi.dll blocked by BE) and gives FATAL ERROR . (kartaviy post #528)

 

first

When i start the xcam mission from editor then when i move the windows of favorites , positioning etc , the main window (camera) turns blue until i leave the windows in a place.

is this normal??

 

i think not because version 1 have not this behaviour

Share this post


Link to post
Share on other sites

silola, ich habe in problem wenn ich xcam starte, habe es auch neu runtergeladen aber es klappt nicht, woran kann das liegen?

iqh9h3ok.jpg

dceiobsc.jpg

Share this post


Link to post
Share on other sites

ok i have the last version of inidbi and xcam 1.21 from this threat 1st post.

btw,  all inidbi mods (and the last one) have problems with battleye . (inidbi.dll blocked by BE) and gives FATAL ERROR . (kartaviy post #528)

 

first

When i start the xcam mission from editor then when i move the windows of favorites , positioning etc , the main window (camera) turns blue until i leave the windows in a place.

is this normal??

 

i think not because version 1 have not this behaviour

 

That's "normal" with the newest version, because with the old version it was sometimes a bit laggy if u move a window.

And yes, BE is now blocking inidbi. So simply deactivate BE as long as u are working with X-Cam.

Share this post


Link to post
Share on other sites

16.05.2016 18:41:30 - Laden von Datei 'C:\Program Files (x86)\Steam\SteamApps\common\Arma 3\@inidbi\iniDB.dll' blockiert

 

ich habe die neuste version 

Share this post


Link to post
Share on other sites

silola, ich habe in problem wenn ich xcam starte, habe es auch neu runtergeladen aber es klappt nicht, woran kann das liegen?

iqh9h3ok.jpg

dceiobsc.jpg

 

As the error message says ... I think @inidbi is missing or not (correct) loaded.

Make sure @inidbi contains the "xCam" folder with all the needed files.

 

... and deactivate BattlEye ;)

Silola

  • Like 1

Share this post


Link to post
Share on other sites

As the error message says ... I think @inidbi is missing or not (correct) loaded.

Make sure @inidbi contains the "xCam" folder with all the needed files.

 

... and deactivate BattlEye ;)

Silola

 

This did the trick! Thanks Silola for the help and this magnificent tool!

Share this post


Link to post
Share on other sites

Can you make it so we can rotate objects upside down etc? You can do it in the eden editor and it imports fine into Terrain Builder.

Share this post


Link to post
Share on other sites

Hey Silola, now that the Apex sneak peak build is available, would it be possible to get an updated library with the Tanoa objects since they're now in the Eden Editor?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×